summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-17 10:15:00 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-17 10:34:19 +0200
commit9bb2d89db1f546ff5c96201708f2dfe095d32aa0 (patch)
treed0224ca7251f0085627d3a06abf5e8edd6e67cfc
parentdev-python/bleach: Bump to 3.2.0 (diff)
downloadgentoo-9bb2d89d.tar.gz
gentoo-9bb2d89d.tar.bz2
gentoo-9bb2d89d.zip
dev-python/cfn-python-lint: Bump to 0.36.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/cfn-python-lint/Manifest1
-rw-r--r--dev-python/cfn-python-lint/cfn-python-lint-0.36.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/cfn-python-lint/Manifest b/dev-python/cfn-python-lint/Manifest
index ef3d8bea5d84..956c1b331ef1 100644
--- a/dev-python/cfn-python-lint/Manifest
+++ b/dev-python/cfn-python-lint/Manifest
@@ -1,2 +1,3 @@
DIST cfn-python-lint-0.30.1.tar.gz 4137425 BLAKE2B dd4f7d449236e567e7ea0fa662cbe983b6125a6cb557ee314de0e6647c5756b0be450deec7778ac69f1cec95b594c8c74a0a2f56ea229b7dc28ffb918983e6b3 SHA512 67b72973dc174e0de4980606b7886459233fca516a0587b91319127c4df0ce2647bbdc3302d68b63916654a76f4c9405c2f27cfd5e0ad737b00724e403815477
DIST cfn-python-lint-0.35.1.tar.gz 4501826 BLAKE2B 84da0965fc198ce7b8f955a7d43f9a1c87c9688c301594abe6843509a832b4c9c5fadad1f75ac1c5b20ce2179244fd2b9681f5a92a1dbe38738a61c94f95982a SHA512 6d277048bbd7d8950ef7681c4a31cb82ccc231fb29f5083169caef69bfa4464cd87e473f40c775d798ff511a5db1dff9a17b0c08dcc800db0188e1e84990c9e4
+DIST cfn-python-lint-0.36.0.tar.gz 4879599 BLAKE2B a79a12290e20f4db1e45b29df0486d3b69f3c028f35cae8e8ba9ab5da191c1a5f7fed6bc339d24e3212faab7a05a82e859a79135847eb90b0161fe0aa7b8c995 SHA512 286c8e614ee083981105a74f09b4c75454ae6eef48812ac59852374bea5dfc0d111b006bb67c50e42fa2a1eeb54ce6f25b8bf0f06624da236344e9bbadf4ce1c
diff --git a/dev-python/cfn-python-lint/cfn-python-lint-0.36.0.ebuild b/dev-python/cfn-python-lint/cfn-python-lint-0.36.0.ebuild
new file mode 100644
index 000000000000..09f91de4ad66
--- /dev/null
+++ b/dev-python/cfn-python-lint/cfn-python-lint-0.36.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="https://pypi.org/project/cfn-lint/ https://github.com/aws-cloudformation/cfn-python-lint"
+SRC_URI="https://github.com/aws-cloudformation/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.25.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/importlib_resources[${PYTHON_USEDEP}]
+ ' python3_6)
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.15.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.11[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}/cfn-python-lint-0.30.1-tests.patch"
+)
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ distutils_install_for_testing
+ "${EPYTHON}" -m unittest discover -v ||
+ die "tests fail with ${EPYTHON}"
+}