summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-12-17 13:43:16 -0500
committerCraig Andrews <candrews@gentoo.org>2019-12-17 13:46:34 -0500
commit9bc6eaf344b8baa00ac9d421deaeca102e4ce1a1 (patch)
treea65ece0617bae2fbf3d626a8e1e2f8d3f61b580c
parentx11-misc/xflux-gui: add python3.8 support (diff)
downloadgentoo-9bc6eaf3.tar.gz
gentoo-9bc6eaf3.tar.bz2
gentoo-9bc6eaf3.zip
net-p2p/cpuminer-opt: 3.10.4 version bump
Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: Craig Andrews <candrews@gentoo.org>
-rw-r--r--net-p2p/cpuminer-opt/Manifest1
-rw-r--r--net-p2p/cpuminer-opt/cpuminer-opt-3.10.4.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/net-p2p/cpuminer-opt/Manifest b/net-p2p/cpuminer-opt/Manifest
index 03dbfe051a8a..87d797fab7d6 100644
--- a/net-p2p/cpuminer-opt/Manifest
+++ b/net-p2p/cpuminer-opt/Manifest
@@ -1 +1,2 @@
DIST cpuminer-opt-3.10.3.tar.gz 1940128 BLAKE2B cf8b591cc10dc5507eef322de397c462a14c2164ec8806ff189a135abdc58314add18d46110d05f6ba365a475632df2bb33f97706454049a9275e08004c90d5a SHA512 cc1d4934fc17cc7ecd1402e9e32fc9caf9a493e3f3e573637036638e10679c19ba4a2e4f83376ddb462c7d404aecf747c0bd4d46e4e934013ad9d53a765a862f
+DIST cpuminer-opt-3.10.4.tar.gz 1958764 BLAKE2B 2d7aaffe51625d958c856612680de1d71711bf41ad08c30167295d26d794dcde355f967787f6d3c1f80753d9ea65ea9e38c87d22053592338851a1c5b7e0769f SHA512 6987972918a921f5763eb9eb80026fcc7ab163d0caa78003c193678ade043dfbcdc967ccd03084fdcd838752e0dd1dc7eefcb845d525706cd1f6f13d039b7fa0
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-3.10.4.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-3.10.4.ebuild
new file mode 100644
index 000000000000..666d27ee1c02
--- /dev/null
+++ b/net-p2p/cpuminer-opt/cpuminer-opt-3.10.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Optimized multi algo CPU miner"
+HOMEPAGE="https://github.com/JayDDee/cpuminer-opt"
+IUSE="cpu_flags_x86_sse2 curl libressl"
+LICENSE="GPL-2"
+SLOT="0"
+REQUIRED_USE="cpu_flags_x86_sse2"
+DEPEND="
+ dev-libs/gmp:0
+ dev-libs/jansson
+ >=net-misc/curl-7.15[ssl]
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+"
+RDEPEND="${DEPEND}"
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/JayDDee/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/JayDDee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ econf --with-crypto --with-curl
+}
+
+src_install() {
+ default
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ insinto "/etc/${PN}"
+ doins cpuminer-conf.json
+}
+
+src_test() {
+ ./cpuminer --cputest || die
+}