summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2022-03-04 11:04:44 +0100
committerLars Wendler <polynomial-c@gentoo.org>2022-03-04 11:12:55 +0100
commit9bcf4b43231553045cc01af491969aa794091761 (patch)
treea1e248b631283c8c7965b83d2b9dae43aa2b8d74
parentwww-servers/apache: Add support for systemd module (diff)
downloadgentoo-9bcf4b43.tar.gz
gentoo-9bcf4b43.tar.bz2
gentoo-9bcf4b43.zip
www-servers/apache: Move remaining lua stuff into eclass
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--eclass/apache-2.eclass2
-rw-r--r--www-servers/apache/apache-2.4.51-r2.ebuild4
-rw-r--r--www-servers/apache/apache-2.4.52-r1.ebuild4
3 files changed, 2 insertions, 8 deletions
diff --git a/eclass/apache-2.eclass b/eclass/apache-2.eclass
index e6ca32db3ea5..f9223646c8bb 100644
--- a/eclass/apache-2.eclass
+++ b/eclass/apache-2.eclass
@@ -150,6 +150,7 @@ RDEPEND="
>=net-libs/nghttp2-1.2.1
kernel_linux? ( sys-apps/util-linux )
)
+ apache2_modules_lua? ( ${LUA_DEPS} )
apache2_modules_md? ( >=dev-libs/jansson-2.10 )
apache2_modules_mime? ( app-misc/mime-types )
apache2_modules_proxy_http2? (
@@ -181,6 +182,7 @@ PDEPEND="~app-admin/apache-tools-${PV}"
REQUIRED_USE+="
apache2_modules_http2? ( ssl )
+ apache2_modules_lua? ( ${LUA_REQUIRED_USE} )
apache2_modules_md? ( ssl )
"
diff --git a/www-servers/apache/apache-2.4.51-r2.ebuild b/www-servers/apache/apache-2.4.51-r2.ebuild
index 7660f0cbf358..665efaba2fe0 100644
--- a/www-servers/apache/apache-2.4.51-r2.ebuild
+++ b/www-servers/apache/apache-2.4.51-r2.ebuild
@@ -142,10 +142,6 @@ LICENSE="Apache-2.0 Apache-1.1"
SLOT="2"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x64-macos ~sparc64-solaris ~x64-solaris"
-# FIXME! Move this to eclass once all ebuilds are EAPI-7
-RDEPEND+=" apache2_modules_lua? ( ${LUA_DEPS} )"
-REQUIRED_USE+=" apache2_modules_lua? ( ${LUA_REQUIRED_USE} )"
-
PATCHES=( "${FILESDIR}/apache-2.4.51-mpm-itk.patch" )
pkg_setup() {
diff --git a/www-servers/apache/apache-2.4.52-r1.ebuild b/www-servers/apache/apache-2.4.52-r1.ebuild
index bb742bd17560..34f5fc10b748 100644
--- a/www-servers/apache/apache-2.4.52-r1.ebuild
+++ b/www-servers/apache/apache-2.4.52-r1.ebuild
@@ -142,10 +142,6 @@ LICENSE="Apache-2.0 Apache-1.1"
SLOT="2"
KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~mips ppc ~ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x64-macos ~sparc64-solaris ~x64-solaris"
-# FIXME! Move this to eclass once all ebuilds are EAPI-7
-RDEPEND+=" apache2_modules_lua? ( ${LUA_DEPS} )"
-REQUIRED_USE+=" apache2_modules_lua? ( ${LUA_REQUIRED_USE} )"
-
pkg_setup() {
# dependend critical modules which are not allowed in global scope due
# to USE flag conditionals (bug #499260)