summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-07 05:37:45 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-07 06:29:11 +0100
commit9bd85098f5fbb06a086e8aca144a7ddd66ba8790 (patch)
tree7fcc2b4a5d6e441da1b8ff601162247f37dfe2e3
parentdev-python/botocore: Bump to 1.31.79 (diff)
downloadgentoo-9bd85098.tar.gz
gentoo-9bd85098.tar.bz2
gentoo-9bd85098.zip
dev-python/boto3: Bump to 1.28.79
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.28.79.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 8f415e356746..c28f88374424 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -2,3 +2,4 @@ DIST boto3-1.28.68.gh.tar.gz 717553 BLAKE2B dd8ba562613456e30c0f8bfe2f3befa9601b
DIST boto3-1.28.73.gh.tar.gz 720995 BLAKE2B 1ac1c85be9e095ebab3394c5b7bdc48e0ba05e97bc3e463c3fab5d6a3f46e14078f05466042cdf58250c901a42b4b80149874ee0a157b47616da8f9e65a1dbe1 SHA512 2a5f4c9e4cf86bc1b7d285d034873cedf2ada05a65ca64be3c449de8e33a351b813e4f939543cba11c183f0adb127728f20f9b769bdb2802712b47ccaa135dcb
DIST boto3-1.28.77.gh.tar.gz 723612 BLAKE2B e2a2d3919f2f0ad09c0385b5f93bf4167c003e675ac0d3d3885ed9ab5c66ce401632bbff81f9a93bddc0063ab381233607b663f5a0a6763ddb4156c3f4a5e420 SHA512 31ded8367abbe8b99e0a09f25399755e3e2912e1efb92a902ab3404498d23dcf5958217e4ae30c953ad1d588b1eb2327167ef81b70f5683e4bc90f12b96970f9
DIST boto3-1.28.78.gh.tar.gz 724185 BLAKE2B 5089a7d1eab11c23bd65699c41c3c6687f0666f10ebcc7fc4813f96225ceee5a10a008ae6969cd7927f43f09e0988178ea40386bcd91c473ac5fba1dedeeeef1 SHA512 e74f7348d369580e8d26f7c1f084276ec339d4bdd3ee628bdbe56cc6e4b1c0b22a759bb4ffe1075f0cb0d6f1692864db85a73d3cb884358dc97d6428f3fd9b0a
+DIST boto3-1.28.79.gh.tar.gz 724864 BLAKE2B b6327a3dfd0095078668c85fb539885cdbc848a73b67afeaf97f58cb7362b1f928c49cb3cb233873b59ac925b9e97bc0571129f478177802f1249ddaa597297a SHA512 55eaf9e8122ef2f3424caa86f838fe03028a666aad281b6c52e0c8629c9d64707e1659c6d2e21666fe805f60cdde2ef0aece744737952cd55a20165c1d8186af
diff --git a/dev-python/boto3/boto3-1.28.79.ebuild b/dev-python/boto3/boto3-1.28.79.ebuild
new file mode 100644
index 000000000000..0604e0996a82
--- /dev/null
+++ b/dev-python/boto3/boto3-1.28.79.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.7.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}