summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-03-27 19:22:51 +0200
committerDavid Seifert <soap@gentoo.org>2016-03-27 19:44:04 +0200
commit9beb6a85cf9b68618e2346cb584be1860f4986c3 (patch)
tree71ed95d82b80f70d7c1e2062807c5cdde6182164
parentnet-libs/libsignon-glib: Add python3_5 support (diff)
downloadgentoo-9beb6a85.tar.gz
gentoo-9beb6a85.tar.bz2
gentoo-9beb6a85.zip
dev-python/dnspython: Add python3_5 support
Package-Manager: portage-2.2.28
-rw-r--r--dev-python/dnspython/dnspython-1.12.0-r301.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/dnspython/dnspython-1.12.0-r301.ebuild b/dev-python/dnspython/dnspython-1.12.0-r301.ebuild
new file mode 100644
index 000000000000..482d8a022040
--- /dev/null
+++ b/dev-python/dnspython/dnspython-1.12.0-r301.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python3_{3,4,5} )
+
+inherit distutils-r1
+
+MY_PN="${PN}3"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="DNS toolkit for Python"
+HOMEPAGE="http://www.dnspython.org/ https://pypi.python.org/pypi/dnspython"
+SRC_URI="http://www.dnspython.org/kits3/${PV}/${MY_P}.zip"
+
+LICENSE="ISC"
+SLOT="py3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="examples test"
+
+RDEPEND="dev-python/pycrypto[${PYTHON_USEDEP}]
+ !dev-python/dnspython:0"
+DEPEND="${RDEPEND}
+ !dev-python/dnspython:0
+ app-arch/unzip"
+
+S="${WORKDIR}/${MY_P}"
+
+# For testsuite
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_test() {
+ cd tests || die
+ "${PYTHON}" utest.py || die "tests failed under ${EPYTHON}"
+ einfo "Testsuite passed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}