summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <Matt.Jolly@footclan.ninja>2023-08-16 18:58:40 +1000
committerSam James <sam@gentoo.org>2023-08-25 00:24:52 +0100
commit9bf0d743d96a432b16331ad9474a1d296166ada1 (patch)
tree1223d690d5cd93c730a1349b4cbca68a55d25282
parentsys-devel/gcc: add 11.4.1_p20230824 (diff)
downloadgentoo-9bf0d743d96a432b16331ad9474a1d296166ada1.tar.gz
gentoo-9bf0d743d96a432b16331ad9474a1d296166ada1.tar.bz2
gentoo-9bf0d743d96a432b16331ad9474a1d296166ada1.zip
app-antivirus/clamav: package maintenance
- fix failing build - add USE=system-mspack - Bump minimum rust version Closes: https://bugs.gentoo.org/912178 Bug: https://bugs.gentoo.org/911402 Bug: https://bugs.gentoo.org/911589 Signed-off-by: Matt Jolly <Matt.Jolly@footclan.ninja> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-antivirus/clamav/clamav-1.2.0_rc.ebuild15
-rw-r--r--app-antivirus/clamav/metadata.xml6
2 files changed, 10 insertions, 11 deletions
diff --git a/app-antivirus/clamav/clamav-1.2.0_rc.ebuild b/app-antivirus/clamav/clamav-1.2.0_rc.ebuild
index 58bd5cfeb5d5..9985517bf6ae 100644
--- a/app-antivirus/clamav/clamav-1.2.0_rc.ebuild
+++ b/app-antivirus/clamav/clamav-1.2.0_rc.ebuild
@@ -174,7 +174,7 @@ if [[ ${PV} != *_rc* ]] ; then
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
fi
-IUSE="doc clamonacc +clamapp experimental jit libclamav-only milter rar selinux systemd test"
+IUSE="doc clamonacc +clamapp experimental jit libclamav-only milter rar selinux +system-mspack systemd test"
REQUIRED_USE="libclamav-only? ( !clamonacc !clamapp !milter )
clamonacc? ( clamapp )
@@ -192,7 +192,6 @@ COMMON_DEPEND="
app-arch/bzip2
dev-libs/json-c:=
dev-libs/libltdl
- dev-libs/libmspack
dev-libs/libpcre2:=
dev-libs/libxml2
dev-libs/openssl:=
@@ -204,12 +203,14 @@ COMMON_DEPEND="
jit? ( <sys-devel/llvm-$((${LLVM_MAX_SLOT} + 1)):= )
milter? ( mail-filter/libmilter:= )
rar? ( app-arch/unrar )
+ system-mspack? ( dev-libs/libmspack )
test? ( dev-python/pytest )
"
-
+# rust-bin < 1.71 has an executable stack
+# which is not supported on selinux #911589
BDEPEND="
virtual/pkgconfig
- >=virtual/rust-1.61
+ >=virtual/rust-1.71
doc? ( app-doc/doxygen )
test? (
${PYTHON_DEPS}
@@ -246,7 +247,7 @@ src_configure() {
-DENABLE_CLAMONACC=$(usex clamonacc ON OFF)
-DENABLE_DOXYGEN=$(usex doc)
-DENABLE_EXPERIMENTAL=$(usex experimental ON OFF)
- -DENABLE_EXTERNAL_MSPACK=ON
+ -DENABLE_EXTERNAL_MSPACK=$(usex system-mspack ON OFF)
-DENABLE_JSON_SHARED=ON
-DENABLE_MAN_PAGES=ON
-DENABLE_MILTER=$(usex milter ON OFF)
@@ -352,10 +353,8 @@ src_install() {
fi
done
- # These both need to be writable by the clamav user;
- # remove the installer-created empty directories
+ # These both need to be writable by the clamav user
# TODO: use syslog by default; that's what it's for.
- rm -r "${ED}"/var/lib/clamav || die
diropts -o clamav -g clamav
keepdir /var/lib/clamav
keepdir /var/log/clamav
diff --git a/app-antivirus/clamav/metadata.xml b/app-antivirus/clamav/metadata.xml
index b28f9ad70e51..ad6c8d27e1b3 100644
--- a/app-antivirus/clamav/metadata.xml
+++ b/app-antivirus/clamav/metadata.xml
@@ -21,17 +21,17 @@
<flag name="clamapp">
Build applications (clamscan, clamd, clamdscan, clamonacc (also has its own USE flag), sigtool, clambc, clamav-milter (also requires milter USE flag), clamdtop, clamsubmit, clamconf).
</flag>
- <flag name="clamonacc">Build the clamonacc on-access scanner</flag>
<flag name="clamdtop">A Top like tool which shows what clamd is currently scanning amongst other things</flag>
+ <flag name="clamonacc">Build the clamonacc on-access scanner</flag>
<flag name="clamsubmit">A tool to submit false positives / negatives</flag>
<flag name="experimental">Enable experimental features</flag>
<flag name="libclamav-only">Bypass building of libfreshclam and the ClamAV CLI applications.</flag>
<flag name="metadata-analysis-api">Enables collection of file property metadata using ClamAV API for analysis by ClamAV bytecode programs.</flag>
- <flag name="xml">DMG and XAR support</flag>
<flag name="rar">RAR support</flag>
+ <flag name="system-mspack">Use <pkg>dev-libs/libmspack</pkg> instead of the version bundled with ClamAV</flag>
+ <flag name="xml">DMG and XAR support</flag>
</use>
<upstream>
<remote-id type="github">Cisco-Talos/clamav</remote-id>
- <remote-id type="sourceforge">clamav</remote-id>
</upstream>
</pkgmetadata>