summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-02-11 12:18:18 -0800
committerMatt Turner <mattst88@gentoo.org>2022-02-11 12:56:02 -0800
commit9bf3e22595f28abf8c71272da13676325ff4e550 (patch)
tree9ea0c3566c5e12999e59982cb3e3a61207fdf1d0
parentapp-arch/gnome-autoar: Version bump to 0.4.3 (diff)
downloadgentoo-9bf3e22595f28abf8c71272da13676325ff4e550.tar.gz
gentoo-9bf3e22595f28abf8c71272da13676325ff4e550.tar.bz2
gentoo-9bf3e22595f28abf8c71272da13676325ff4e550.zip
dev-cpp/mm-common: Version bump to 1.0.4
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--dev-cpp/mm-common/Manifest1
-rw-r--r--dev-cpp/mm-common/mm-common-1.0.4.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-cpp/mm-common/Manifest b/dev-cpp/mm-common/Manifest
index bf9e4e494ffd..02f220f197f0 100644
--- a/dev-cpp/mm-common/Manifest
+++ b/dev-cpp/mm-common/Manifest
@@ -1 +1,2 @@
DIST mm-common-1.0.3.tar.xz 272932 BLAKE2B 90459cfa75dbcab8bb9b0512f3f3f3703850000e4ea0124afb020c476fce9948ec0128d67510b13482d52f165ba0b7a8aa72e6b1afd4a88554fa52bc4f5598d2 SHA512 fdd79e9a2ca3d7ed311a6994bd04e7cbf2b1562c39968d309765ce3b5268128f98b3f1c08a434b460276e6d911d302a12ccc7aebd6cd67e4df13241a97034a70
+DIST mm-common-1.0.4.tar.xz 290164 BLAKE2B 2731c501ed79d2481b9094639bad1971e5a27e6416a7433982481e939bd44202f7e5769f3a9dbe5b7fd2e09a3f7bd4687d7ce85d79dafa877f5cc3c333f9d526 SHA512 e686f19cb4d40a3dda68e30b98b43fca3db51b387e28f5569bef0cfbb1cc3a7d72503ec5dfa0f2621dd349ac4c9c21f0fe93bdda224026534c509fbb60400243
diff --git a/dev-cpp/mm-common/mm-common-1.0.4.ebuild b/dev-cpp/mm-common/mm-common-1.0.4.ebuild
new file mode 100644
index 000000000000..e6043bdae1c8
--- /dev/null
+++ b/dev-cpp/mm-common/mm-common-1.0.4.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit gnome.org python-any-r1 meson
+
+DESCRIPTION="Build infrastructure and utilities for GNOME C++ bindings"
+HOMEPAGE="https://www.gtkmm.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+BDEPEND="${PYTHON_DEPS}"
+
+src_prepare() {
+ default
+
+ # Include project version in docdir name
+ sed -i -e "s:^install_docdir.*:& + '-' + meson.project_version():" meson.build || die
+}