summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-06-04 08:40:50 +0100
committerJustin Lecher <jlec@gentoo.org>2017-06-04 12:49:50 +0100
commit9c18cfcc691ee1f1709848c89d8ce5e658a9e4da (patch)
treef36bebe56ed235fc6c0599e8e6ca0c4e197a8c84
parentx11-libs/qtscriptgenerator: Disable webkit bindings, bump to EAPI 6 (diff)
downloadgentoo-9c18cfcc.tar.gz
gentoo-9c18cfcc.tar.bz2
gentoo-9c18cfcc.zip
sci-biology/biopandas: Version Bump
Package-Manager: Portage-2.3.6, Repoman-2.3.2 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--sci-biology/biopandas/Manifest1
-rw-r--r--sci-biology/biopandas/biopandas-0.2.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/sci-biology/biopandas/Manifest b/sci-biology/biopandas/Manifest
index 30cee4308714..df72c3835751 100644
--- a/sci-biology/biopandas/Manifest
+++ b/sci-biology/biopandas/Manifest
@@ -1 +1,2 @@
DIST biopandas-0.1.4.tar.gz 5386 SHA256 0cc9e43e2ddcb0c33448660ee2ed2db02694e57daa1875d004525c40633a6d95 SHA512 efd7ec94bbcc069d8bf0d160480e7ef2c7c0f9febe21a684b46b6b14c69cebb0b3d9f2c315897be6b0ae888ed40731e2f5a16dee45b9c932b05c2c0209b62b84 WHIRLPOOL 1429e59bbb1b29ba116864e577d4be2f1b988e3a82b07c65525eae825b2a742b52da86ed49c837ba461814abf79f2e70d0ea43ee7d4f7906d6a38b39f0ad98f4
+DIST biopandas-0.2.1.tar.gz 209379 SHA256 8952e1177d09b920b24d71e2a83ee76cbbd08055dd2672a366f03cc4fa9678c8 SHA512 0ea7aec84251d8d6ec4736c4968228133bd8622afb17d6916287168cb9f9757c5a97a4d5a52ac0e2f30027bf0edf9d76413db142f70d606f1359b8a4e06de7c8 WHIRLPOOL 9f3d088fde230cbc8c9efc25e06430ab8ea87a7050bcbb26bba1b3bb2ef2a300d7f9ebd77490652423a93b517f604156af6f11bde1702b7187c849b171f030f6
diff --git a/sci-biology/biopandas/biopandas-0.2.1.ebuild b/sci-biology/biopandas/biopandas-0.2.1.ebuild
new file mode 100644
index 000000000000..5243039d53b6
--- /dev/null
+++ b/sci-biology/biopandas/biopandas-0.2.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+MY_PN="BioPandas"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Molecular Structures in Pandas DataFrames"
+HOMEPAGE="
+ https://rasbt.github.io/biopandas/
+ https://github.com/rasbt/biopandas
+ https://pypi.python.org/pypi/BioPandas"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ "${EPYTHON}" --version
+ "${EPYTHON}" -c "import numpy; print('numpy %s' % numpy.__version__)"
+ "${EPYTHON}" -c "import scipy; print('scipy %s' % scipy.__version__)"
+ "${EPYTHON}" -c "import pandas; print('pandas %s' % pandas.__version__)"
+ nosetests -s --verbose ${PN} || die
+}