summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2017-08-01 18:07:46 +0000
committerBrian Dolbec <dolsen@gentoo.org>2017-08-01 18:51:22 +0000
commit9c2b6f470898b451ec5560cba062f2b3ea66f935 (patch)
tree558f79d7d988f008f84da059de6f5e6eeb397d72
parentapp-eselect/eselect-php: Revbump to remove set call in files/php-fpm-launcher-r2 (diff)
downloadgentoo-9c2b6f470898b451ec5560cba062f2b3ea66f935.tar.gz
gentoo-9c2b6f470898b451ec5560cba062f2b3ea66f935.tar.bz2
gentoo-9c2b6f470898b451ec5560cba062f2b3ea66f935.zip
dev-python/autobahn: Version bump
Package-Manager: Portage-2.3.6, Repoman-2.3.1
-rw-r--r--dev-python/autobahn/Manifest1
-rw-r--r--dev-python/autobahn/autobahn-17.7.1.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/autobahn/Manifest b/dev-python/autobahn/Manifest
index 3af3f99fc66b..53ccc12405e4 100644
--- a/dev-python/autobahn/Manifest
+++ b/dev-python/autobahn/Manifest
@@ -1,3 +1,4 @@
DIST autobahn-0.16.0.tar.gz 185053 SHA256 a1dcb4315a0914da56ec484659816de72dfad229be4ac19fa61bbc0111ada884 SHA512 8873202a33c7b68577e89cc91503b8002aa19638836ff39ef99022e3b0ddcfb613154ddf0c373bf315eeb8b6c36f31afc20eb0164c47caa087b2a1b28449d3a8 WHIRLPOOL b5f5f80c1d88b3b031fab0837f0d191d4d71e21798aeec6ae1ee718bad0e21cb403a1b2ecb199615b4c8351522be8d4882781fd02de95e422203cee14f1c01ef
DIST autobahn-0.9.4-2.zip 175894 SHA256 5bb64191cfdd1cbdd90d8e359b389ef62c0acdffd2f68d16ec01fa0a287262f0 SHA512 7e0d4246b8b1c552b25c2ae36f1923ed9931e3d3ca684039a422773fecd92ca04734a0b24394a9bbc787f245c72b5552522351a7c1c8e500128e7c46c740a3d5 WHIRLPOOL aa0f06b82acbebb97ca2e3c424429ada7169dca5b39237ce082a17440ec9701a307e9fc7f162f957023cfc4c067f8e8b82b9923cb056ffcab7b3e64a61a4aae8
DIST autobahn-17.5.1.tar.gz 205144 SHA256 2a32fa76a11f8aa8de482e99ad2b7a8acc8f6c0d430c48aebd4666f080e85d5c SHA512 904f8f4c527a6c1c7840ea8634d0c0a47141458500c6d29f4aa1f05ff51f91c65a451b7c447201cbdf5e255c4c2d07509efa106790217b09398e7d50c1d85382 WHIRLPOOL 28b9608110ecfd058b9bfc3a3c587e7d33c7538f62b4ada1969efc2d434dcbcd9b1d3b1711448a09b425016c2622d2135ce789ae1edeaf7f0a1dc96fcdfb7acd
+DIST autobahn-17.7.1.tar.gz 211238 SHA256 801a318d5bf6776a60f7a93d715f83f7f12204b470019a339e4e7e14087c17e6 SHA512 592c4e21a7986fc9ac992fdfd24055654c5db7a3b8963fb5814bc32bdfbcdd7e3271bc84ed35faaf50755022a115a5f026de825ba5c35dacad4cfa2cf776d50f WHIRLPOOL 5c521d3e2c65c30ef8e96683d25b1aa4d862461a53f1c59608f3d5065d899f5ad39b58c38048c6cff126af436108093d10f04563ce0a5ef45c27a1f999fd95bf
diff --git a/dev-python/autobahn/autobahn-17.7.1.ebuild b/dev-python/autobahn/autobahn-17.7.1.ebuild
new file mode 100644
index 000000000000..776ea9153caf
--- /dev/null
+++ b/dev-python/autobahn/autobahn-17.7.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1 versionator
+
+MY_P="${PN}-$(replace_version_separator 3 -)"
+
+DESCRIPTION="WebSocket and WAMP for Twisted and Asyncio"
+HOMEPAGE="https://pypi.python.org/pypi/autobahn http://autobahn.ws/python/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64"
+IUSE="crypt test"
+
+RDEPEND="
+ $(python_gen_cond_dep '>=dev-python/trollius-2.0[${PYTHON_USEDEP}]' 'python2_7')
+ $(python_gen_cond_dep '>=dev-python/futures-3.0.4[${PYTHON_USEDEP}]' 'python2_7')
+ >=dev-python/cbor-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/lz4-0.7.0[${PYTHON_USEDEP}]
+ crypt? (
+ >=dev-python/pyopenssl-16.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pynacl-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pytrie-0.2[${PYTHON_USEDEP}]
+ >=dev-python/pyqrcode-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/service_identity-16.0.0
+ )
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/snappy-0.5[${PYTHON_USEDEP}]
+ >=dev-python/twisted-16.6.0-r2[${PYTHON_USEDEP}]
+ >=dev-python/txaio-2.7.0[${PYTHON_USEDEP}]
+ >=dev-python/u-msgpack-2.1[${PYTHON_USEDEP}]
+ >=dev-python/py-ubjson-0.8.4[${PYTHON_USEDEP}]
+ >=dev-python/wsaccel-0.6.2[${PYTHON_USEDEP}]
+ >=dev-python/zope-interface-3.6[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ >=dev-python/pynacl-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pytrie-0.2[${PYTHON_USEDEP}]
+ >=dev-python/pyqrcode-1.1.0[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}"/${MY_P}
+
+python_test() {
+ #esetup.py test
+ cd "${BUILD_DIR}"/lib || die
+ py.test -v || die
+}
+
+pkg_postinst() {
+ python_foreach_impl twisted-regen-cache || die
+}
+
+pkg_postrm() {
+ python_foreach_impl twisted-regen-cache || die
+}