summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2017-05-08 17:33:26 -0400
committerZero_Chaos <zerochaos@gentoo.org>2017-05-08 23:08:39 -0400
commit9c340993a2e5b0aed4251c604f6b1231c6666a0b (patch)
tree5e8876b122aaca510a5f4cdae6548216827e15a7
parentdev-ruby/patch_finder: ruby23 (diff)
downloadgentoo-9c340993a2e5b0aed4251c604f6b1231c6666a0b.tar.gz
gentoo-9c340993a2e5b0aed4251c604f6b1231c6666a0b.tar.bz2
gentoo-9c340993a2e5b0aed4251c604f6b1231c6666a0b.zip
dev-ruby/metasploit_payloads-mettle: bump preparing for metasploit bump
Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--dev-ruby/metasploit_payloads-mettle/Manifest1
-rw-r--r--dev-ruby/metasploit_payloads-mettle/metasploit_payloads-mettle-0.0.6.ebuild4
-rw-r--r--dev-ruby/metasploit_payloads-mettle/metasploit_payloads-mettle-0.1.9.ebuild49
3 files changed, 52 insertions, 2 deletions
diff --git a/dev-ruby/metasploit_payloads-mettle/Manifest b/dev-ruby/metasploit_payloads-mettle/Manifest
index 1cb185b5b13b..7807fc4d754f 100644
--- a/dev-ruby/metasploit_payloads-mettle/Manifest
+++ b/dev-ruby/metasploit_payloads-mettle/Manifest
@@ -1 +1,2 @@
DIST metasploit_payloads-mettle-0.0.6.gem 3259904 SHA256 b9b0a5062dc27345e23fc62f26047533d153b322b1d19b5dbae60c7deb08fc23 SHA512 c95c4774f1295e6e5953fdf2738560a2f5c3380d9a0de72dd435d475e05948cb36ca6596406c0ad7e12f7e1e7db831d6651c579458b99a252a678197874f7c34 WHIRLPOOL 7261a3efa2f5d42011a1a1c697e70d31e462c4d65316bb81b88990407ed36b36af2f8298bbbd38157bfc7301d58e5b69ea3abaee9735cab3a392cb0f7617ef92
+DIST metasploit_payloads-mettle-0.1.9.gem 8368640 SHA256 a16117e77db77b5750ad8166432cf926c9aa1b7f05de66dae8b813683f961115 SHA512 75573a3156551a47a6a826166d0964a0e4addff4c0fde60fb44b2fa078357153ed4e64813d4639e64e92523cb946c8b2e2153e3fc10021733482b1a083be983a WHIRLPOOL 8c80cd7a6c894fbad636804ef11f04ab73ff2e7a1c6221be1856e55ae5a63a5962e000e1ce3beedf8c8948881f9dc95028783212df41bbeb95426c13a0ec8054
diff --git a/dev-ruby/metasploit_payloads-mettle/metasploit_payloads-mettle-0.0.6.ebuild b/dev-ruby/metasploit_payloads-mettle/metasploit_payloads-mettle-0.0.6.ebuild
index 2bd3ef31453c..52ff9ae18e57 100644
--- a/dev-ruby/metasploit_payloads-mettle/metasploit_payloads-mettle-0.0.6.ebuild
+++ b/dev-ruby/metasploit_payloads-mettle/metasploit_payloads-mettle-0.0.6.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-USE_RUBY="ruby20 ruby21 ruby22"
+USE_RUBY="ruby21 ruby22"
RUBY_FAKEGEM_TASK_DOC=""
diff --git a/dev-ruby/metasploit_payloads-mettle/metasploit_payloads-mettle-0.1.9.ebuild b/dev-ruby/metasploit_payloads-mettle/metasploit_payloads-mettle-0.1.9.ebuild
new file mode 100644
index 000000000000..bbe49b6aebf2
--- /dev/null
+++ b/dev-ruby/metasploit_payloads-mettle/metasploit_payloads-mettle-0.1.9.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRAINSTALL="build"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Compiled binaries for Metasploit's next-gen Meterpreter"
+HOMEPAGE="https://rubygems.org/gems/metasploit_payloads-mettle"
+
+LICENSE="BSD"
+
+SLOT="${PV}"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+#no tests
+RESTRICT="test strip"
+
+QA_PREBUILT="
+ usr/lib*/ruby/gems/*/gems/${P}/build/mips-linux-muslsf/bin/mettle.bin
+ usr/lib*/ruby/gems/*/gems/${P}/build/mips64-linux-muslsf/bin/mettle.bin
+ usr/lib*/ruby/gems/*/gems/${P}/build/aarch64-linux-musl/bin/mettle.bin
+ usr/lib*/ruby/gems/*/gems/${P}/build/armv5b-linux-musleabi/bin/mettle.bin
+ usr/lib*/ruby/gems/*/gems/${P}/build/armv5l-linux-musleabi/bin/mettle.bin
+ usr/lib*/ruby/gems/*/gems/${P}/build/i486-linux-musl/bin/mettle.bin
+ usr/lib*/ruby/gems/*/gems/${P}/build/mipsel-linux-muslsf/bin/mettle.bin
+ usr/lib*/ruby/gems/*/gems/${P}/build/powerpc-linux-muslsf/bin/mettle.bin
+ usr/lib*/ruby/gems/*/gems/${P}/build/powerpc64le-linux-musl/bin/mettle.bin
+ usr/lib*/ruby/gems/*/gems/${P}/build/x86_64-linux-musl/bin/mettle.bin
+ usr/lib*/ruby/gems/*/gems/${P}/build/s390x-linux-musl/bin/mettle
+ usr/lib*/ruby/gems/*/gems/${P}/build/s390x-linux-musl/bin/mettle.bin
+ "
+
+src_install() {
+ ruby-ng_src_install
+ #tell revdep-rebuild to ignore binaries meant for the target
+ dodir /etc/revdep-rebuild
+ cat <<-EOF > "${ED}"/etc/revdep-rebuild/99-${PN}-${SLOT} || die
+ #These dirs contain prebuilt binaries for running on the TARGET not the HOST
+ SEARCH_DIRS_MASK="/usr/lib*/ruby/gems/*/gems/${P}/build"
+ EOF
+}