summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-14 22:46:07 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-14 23:13:14 +0200
commit9c68a42bea717ef80f0ab401703fdb70e11b7126 (patch)
treed4be80da01a0ef3c6e8a8362e8fd459dda6a36f7
parentapp-admin/awscli: Bump to 1.20.62 (diff)
downloadgentoo-9c68a42bea717ef80f0ab401703fdb70e11b7126.tar.gz
gentoo-9c68a42bea717ef80f0ab401703fdb70e11b7126.tar.bz2
gentoo-9c68a42bea717ef80f0ab401703fdb70e11b7126.zip
dev-python/lmfit: Bump to 1.0.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/lmfit/Manifest1
-rw-r--r--dev-python/lmfit/lmfit-1.0.3.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/lmfit/Manifest b/dev-python/lmfit/Manifest
index 2fac02b39c62..0b3cef266097 100644
--- a/dev-python/lmfit/Manifest
+++ b/dev-python/lmfit/Manifest
@@ -1 +1,2 @@
DIST lmfit-1.0.2.tar.gz 306039 BLAKE2B ab5fcda566f81f00a9d2371f6ae5b3477ed015c70e9b9faf8c5228e3f75f0bf9085d9bd3789042af7b46813d0b6c88f96da37ce295593a5368144d53f5f1799b SHA512 85adeac989117dab3cc9aaf216c37ea5087452351a7978238929216dd9d9be8b6b6790103d4fbbf5211a943c43fb99461750cf58287e2b18c27f66eeacc6ed9a
+DIST lmfit-1.0.3.tar.gz 292475 BLAKE2B 6d97fe671b0d5bb7751d0ead97ab83d8100e2bb16b81bed61ff07ee6355bffd99258ab554032c9b8a35bb4376a1efef0ab988b3eb6d5a9e26f52314719e45dae SHA512 33febdd68104bb41ca379a8acd03a8bb985ba8785d607ab110b63bc7b3b39b9d95161a683fe015613bee6d99100ede82d1f3574515a6bfb9160300a5791fcc55
diff --git a/dev-python/lmfit/lmfit-1.0.3.ebuild b/dev-python/lmfit/lmfit-1.0.3.ebuild
new file mode 100644
index 000000000000..266f2a8ebaa6
--- /dev/null
+++ b/dev-python/lmfit/lmfit-1.0.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Non-Linear Least-Squares Minimization and Curve-Fitting for Python"
+HOMEPAGE="https://lmfit.github.io/lmfit-py/ https://github.com/lmfit/lmfit-py/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/asteval-0.9.22[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.18[${PYTHON_USEDEP}]
+ >=dev-python/uncertainties-3.0.1[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.4[${PYTHON_USEDEP}]
+"
+# past from future needed for tests, bug #737978
+BDEPEND="
+ test? ( dev-python/future[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest