summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2020-12-01 14:57:54 +0300
committerMikle Kolyada <zlogene@gentoo.org>2020-12-01 14:58:44 +0300
commit9c6e0fc3fa97306e5e65efdba6fcbfafe8193b7a (patch)
treed3ef9e138b45ff7717bfa598afd25ec0a6057b36
parentdev-lua/luacov: bump to version 0.14.0, migrate to lua eclass (diff)
downloadgentoo-9c6e0fc3fa97306e5e65efdba6fcbfafe8193b7a.tar.gz
gentoo-9c6e0fc3fa97306e5e65efdba6fcbfafe8193b7a.tar.bz2
gentoo-9c6e0fc3fa97306e5e65efdba6fcbfafe8193b7a.zip
net-p2p/qbittorrent: Version bump (v4.3.1)
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
-rw-r--r--net-p2p/qbittorrent/Manifest1
-rw-r--r--net-p2p/qbittorrent/qbittorrent-4.3.1.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/net-p2p/qbittorrent/Manifest b/net-p2p/qbittorrent/Manifest
index f9391264ab4e..d7599dbcb34c 100644
--- a/net-p2p/qbittorrent/Manifest
+++ b/net-p2p/qbittorrent/Manifest
@@ -1,2 +1,3 @@
DIST qbittorrent-4.2.5.tar.gz 7961612 BLAKE2B 61d2f2154a291a6d1ddab7d4775d4ac4d19f471dceb783cb7933015ed9159afdca4075f429891dbbd7249f09d910ef643d27da4c4b7307adbf29354222265027 SHA512 8808029bdb3a1638fcf792e92c36bd39889dbc2ceb26c8d45ff17b086bd076f0b3a8ed78dd6a1e3debd32e5b0ce212eea194ec601210ae29093cfb567eb4ca0f
DIST qbittorrent-4.3.0.1.tar.gz 7752986 BLAKE2B c4541a5e93a9674dcaee02ef8f7d0335644e5530116070a4fac74952ab8a4ebaec2ae03b95f001c15c491d5f6963e6d305cef2392bd61bd615278a34a0ebb121 SHA512 b49ddafe8c01fa4dae4ee30130237456aee3eba2cdb666c4939d84f44d6b523c5ed7aba1174fad6d168db4de11210d2b97c0d304f5ee653cbf1c8ca2dd96afe3
+DIST qbittorrent-4.3.1.tar.gz 7836727 BLAKE2B aca72922c2fef567eaa8ecc54774f6ec7417d3b15fc9ef1aef87a5b5f0a96ec332e3ab59c49b1c62e85e73c8a8e61cd1da2e172290df8581b909ee3ad336b34e SHA512 078efb45ec65d7e1342624e71d11fc93516925b08084907266cb6154623bc8b817ecae0ce99489c48b294f8c94f5f6c5ea3f24a9a6ad005fe3249e2a67d0b815
diff --git a/net-p2p/qbittorrent/qbittorrent-4.3.1.ebuild b/net-p2p/qbittorrent/qbittorrent-4.3.1.ebuild
new file mode 100644
index 000000000000..15913a17fc03
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-4.3.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="https://www.qbittorrent.org
+ https://github.com/qbittorrent"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}/qBittorrent.git"
+else
+ SRC_URI="https://github.com/qbittorrent/qBittorrent/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+ S="${WORKDIR}/qBittorrent-release-${PV}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+dbus debug webui +X"
+REQUIRED_USE="dbus? ( X )"
+
+RDEPEND="
+ >=dev-libs/boost-1.62.0-r1:=
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtxml:5
+ >=net-libs/libtorrent-rasterbar-1.2.0:0=
+ sys-libs/zlib
+ dbus? ( dev-qt/qtdbus:5 )
+ X? (
+ dev-libs/geoip
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ )"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5"
+
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( AUTHORS Changelog CONTRIBUTING.md README.md TODO )
+
+src_configure() {
+ econf \
+ $(use_enable dbus qt-dbus) \
+ $(use_enable debug) \
+ $(use_enable webui) \
+ $(use_enable X gui)
+}
+
+src_install() {
+ emake STRIP="/bin/false" INSTALL_ROOT="${D}" install
+ einstalldocs
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}