summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-25 23:58:45 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-26 00:16:34 +0100
commit9c6f8f35d44407b32cd396f69156990986a6d1b8 (patch)
treee44168128de5da38ffd91a5373a10d900796ae20
parentdev-python/python-ironicclient: Bump to 4.11.0 (diff)
downloadgentoo-9c6f8f35.tar.gz
gentoo-9c6f8f35.tar.bz2
gentoo-9c6f8f35.zip
dev-python/python-cinderclient: Bump to 8.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/python-cinderclient/Manifest1
-rw-r--r--dev-python/python-cinderclient/python-cinderclient-8.3.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/python-cinderclient/Manifest b/dev-python/python-cinderclient/Manifest
index b4983caa1cf4..e82580587dd7 100644
--- a/dev-python/python-cinderclient/Manifest
+++ b/dev-python/python-cinderclient/Manifest
@@ -1 +1,2 @@
DIST python-cinderclient-8.2.0.tar.gz 233148 BLAKE2B 4ada4562ff1e51a284cf98e7ca4b324a05a4524951d6193bb4683a3986bc8a26a48373ef78613f3b94ed475992fb781b409fe58f9f3655f3f721b38f7eab770b SHA512 86e7a0c18d960f00448e20485d91443d185902db281014c99f35af463843be6d4bca80712edf44189b53e25853af064c14de18e943d9fdee29446180d9b91bbc
+DIST python-cinderclient-8.3.0.tar.gz 234371 BLAKE2B 092d7abdd348f5fac750efb3f3f4df1575584684ad613d22c558630576ad2f82c399af671aad7070dd224a89fa01d73333c2505dc0166d2e4c70e21ac01f298d SHA512 4d633b39a3c59cfdc2fc2c6235b3b87093f7617c89a80b50cf26d8f6fd63e8c3197d788e0b9e81347b9427cf363289b09b85376512d5820031472a735e0ca839
diff --git a/dev-python/python-cinderclient/python-cinderclient-8.3.0.ebuild b/dev-python/python-cinderclient/python-cinderclient-8.3.0.ebuild
new file mode 100644
index 000000000000..610b988ad6b8
--- /dev/null
+++ b/dev-python/python-cinderclient/python-cinderclient-8.3.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Cinder API"
+HOMEPAGE="https://launchpad.net/python-cinderclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/keystoneauth-4.2.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-5.0.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-4.8.0[${PYTHON_USEDEP}]
+ >=dev-python/pbr-5.5.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.2[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.25.1[${PYTHON_USEDEP}]
+ >=dev-python/simplejson-3.5.1[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-3.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ dev-python/ddt[${PYTHON_USEDEP}]
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/oslo-serialization[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ # functional tests require cloud instance access
+ eunittest -b cinderclient/tests/unit
+}