summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-10-03 18:24:02 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-10-03 20:09:22 +0200
commit9c6fba02844af3e30cb81d6ec83c769f59494e1b (patch)
treea047491ab3301aeb37a08bbe67515ff36f1d9530
parentwww-client/firefox-bin: bump to v78.3.1 (diff)
downloadgentoo-9c6fba02.tar.gz
gentoo-9c6fba02.tar.bz2
gentoo-9c6fba02.zip
www-client/firefox: synchronize with www-client/firefox-bin
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--www-client/firefox/files/gentoo-default-prefs.js1
-rw-r--r--www-client/firefox/firefox-78.3.1.ebuild17
-rw-r--r--www-client/firefox/firefox-81.0.1.ebuild17
3 files changed, 22 insertions, 13 deletions
diff --git a/www-client/firefox/files/gentoo-default-prefs.js b/www-client/firefox/files/gentoo-default-prefs.js
index dceaf893e40e..0407f5d3d234 100644
--- a/www-client/firefox/files/gentoo-default-prefs.js
+++ b/www-client/firefox/files/gentoo-default-prefs.js
@@ -4,7 +4,6 @@ pref("browser.urlbar.hideGoButton", true);
pref("accessibility.typeaheadfind", true);
pref("browser.shell.checkDefaultBrowser", false);
pref("browser.EULA.override", true);
-pref("general.useragent.vendor", "Gentoo");
pref("general.useragent.locale", "chrome://global/locale/intl.properties");
pref("intl.locale.requested", "");
/* Disable DoH by default */
diff --git a/www-client/firefox/firefox-78.3.1.ebuild b/www-client/firefox/firefox-78.3.1.ebuild
index 23022d628972..92ff0b2c883b 100644
--- a/www-client/firefox/firefox-78.3.1.ebuild
+++ b/www-client/firefox/firefox-78.3.1.ebuild
@@ -26,21 +26,24 @@ if [[ -n ${MOZ_ESR} ]] ; then
MOZ_PV="${MOZ_PV}esr"
fi
+MOZ_PN="${PN%-bin}"
+MOZ_P="${MOZ_PN}-${MOZ_PV}"
+
inherit autotools check-reqs desktop flag-o-matic gnome2-utils llvm \
multiprocessing pax-utils python-any-r1 toolchain-funcs \
virtualx xdg
-MOZ_SRC_BASE_URI="https://archive.mozilla.org/pub/${PN}/releases/${MOZ_PV}"
+MOZ_SRC_BASE_URI="https://archive.mozilla.org/pub/${MOZ_PN}/releases/${MOZ_PV}"
if [[ ${PV} == *_rc* ]] ; then
- MOZ_SRC_BASE_URI="https://archive.mozilla.org/pub/${PN}/candidates/${MOZ_PV}-candidates/build${PV##*_rc}"
+ MOZ_SRC_BASE_URI="https://archive.mozilla.org/pub/${MOZ_PN}/candidates/${MOZ_PV}-candidates/build${PV##*_rc}"
fi
PATCH_URIS=(
https://dev.gentoo.org/~{axs,polynomial-c,whissi}/mozilla/patchsets/${FIREFOX_PATCHSET}
)
-SRC_URI="${MOZ_SRC_BASE_URI}/source/${PN}-${MOZ_PV}.source.tar.xz
+SRC_URI="${MOZ_SRC_BASE_URI}/source/${MOZ_P}.source.tar.xz
${PATCH_URIS[@]}"
DESCRIPTION="Firefox Web Browser"
@@ -240,7 +243,7 @@ mozilla_set_globals() {
fi
SRC_URI+=" l10n_${xflag/[_@]/-}? ("
- SRC_URI+=" ${MOZ_SRC_BASE_URI}/linux-x86_64/xpi/${lang}.xpi -> ${PN}-${MOZ_PV}-${lang}.xpi"
+ SRC_URI+=" ${MOZ_SRC_BASE_URI}/linux-x86_64/xpi/${lang}.xpi -> ${MOZ_P}-${lang}.xpi"
SRC_URI+=" )"
IUSE+=" l10n_${xflag/[_@]/-}"
done
@@ -893,7 +896,7 @@ src_install() {
local desktop_file="${FILESDIR}/icon/${PN}-r2.desktop"
local display_protocols="auto X11"
local icon="${PN}"
- local name="Mozilla ${PN^}"
+ local name="Mozilla ${MOZ_PN^}"
local use_wayland="false"
if use wayland ; then
@@ -943,7 +946,7 @@ src_install() {
done
# Install generic wrapper script
- rm "${ED}/usr/bin/${PN}" || die
+ [[ -f "${ED}/usr/bin/${PN}" ]] && rm "${ED}/usr/bin/${PN}"
newbin "${FILESDIR}/${PN}.sh" ${PN}
# Update wrapper
@@ -957,6 +960,8 @@ src_install() {
sed -i \
-e "s:@PREFIX@:${EPREFIX}/usr:" \
+ -e "s:@MOZ_FIVE_HOME@:${MOZILLA_FIVE_HOME}:" \
+ -e "s:@APULSELIB_DIR@:${apulselib}:" \
-e "s:@DEFAULT_WAYLAND@:${use_wayland}:" \
"${wrapper}" \
|| die
diff --git a/www-client/firefox/firefox-81.0.1.ebuild b/www-client/firefox/firefox-81.0.1.ebuild
index e79df8202544..91b83e6df4f9 100644
--- a/www-client/firefox/firefox-81.0.1.ebuild
+++ b/www-client/firefox/firefox-81.0.1.ebuild
@@ -26,21 +26,24 @@ if [[ -n ${MOZ_ESR} ]] ; then
MOZ_PV="${MOZ_PV}esr"
fi
+MOZ_PN="${PN%-bin}"
+MOZ_P="${MOZ_PN}-${MOZ_PV}"
+
inherit autotools check-reqs desktop flag-o-matic gnome2-utils llvm \
multiprocessing pax-utils python-any-r1 toolchain-funcs \
virtualx xdg
-MOZ_SRC_BASE_URI="https://archive.mozilla.org/pub/${PN}/releases/${MOZ_PV}"
+MOZ_SRC_BASE_URI="https://archive.mozilla.org/pub/${MOZ_PN}/releases/${MOZ_PV}"
if [[ ${PV} == *_rc* ]] ; then
- MOZ_SRC_BASE_URI="https://archive.mozilla.org/pub/${PN}/candidates/${MOZ_PV}-candidates/build${PV##*_rc}"
+ MOZ_SRC_BASE_URI="https://archive.mozilla.org/pub/${MOZ_PN}/candidates/${MOZ_PV}-candidates/build${PV##*_rc}"
fi
PATCH_URIS=(
https://dev.gentoo.org/~{axs,polynomial-c,whissi}/mozilla/patchsets/${FIREFOX_PATCHSET}
)
-SRC_URI="${MOZ_SRC_BASE_URI}/source/${PN}-${MOZ_PV}.source.tar.xz
+SRC_URI="${MOZ_SRC_BASE_URI}/source/${MOZ_P}.source.tar.xz
${PATCH_URIS[@]}"
DESCRIPTION="Firefox Web Browser"
@@ -240,7 +243,7 @@ mozilla_set_globals() {
fi
SRC_URI+=" l10n_${xflag/[_@]/-}? ("
- SRC_URI+=" ${MOZ_SRC_BASE_URI}/linux-x86_64/xpi/${lang}.xpi -> ${PN}-${MOZ_PV}-${lang}.xpi"
+ SRC_URI+=" ${MOZ_SRC_BASE_URI}/linux-x86_64/xpi/${lang}.xpi -> ${MOZ_P}-${lang}.xpi"
SRC_URI+=" )"
IUSE+=" l10n_${xflag/[_@]/-}"
done
@@ -893,7 +896,7 @@ src_install() {
local desktop_file="${FILESDIR}/icon/${PN}-r2.desktop"
local display_protocols="auto X11"
local icon="${PN}"
- local name="Mozilla ${PN^}"
+ local name="Mozilla ${MOZ_PN^}"
local use_wayland="false"
if use wayland ; then
@@ -943,7 +946,7 @@ src_install() {
done
# Install generic wrapper script
- rm "${ED}/usr/bin/${PN}" || die
+ [[ -f "${ED}/usr/bin/${PN}" ]] && rm "${ED}/usr/bin/${PN}"
newbin "${FILESDIR}/${PN}.sh" ${PN}
# Update wrapper
@@ -957,6 +960,8 @@ src_install() {
sed -i \
-e "s:@PREFIX@:${EPREFIX}/usr:" \
+ -e "s:@MOZ_FIVE_HOME@:${MOZILLA_FIVE_HOME}:" \
+ -e "s:@APULSELIB_DIR@:${apulselib}:" \
-e "s:@DEFAULT_WAYLAND@:${use_wayland}:" \
"${wrapper}" \
|| die