summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-10 07:42:32 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-10 07:52:04 +0100
commit9c753269f47100a9b985bcb69e7a000eb8b962a1 (patch)
tree5be7134a41f13866d23cd415a546ef103088c788
parentdev-python/podman-py: Bump to 4.4.0 (diff)
downloadgentoo-9c753269.tar.gz
gentoo-9c753269.tar.bz2
gentoo-9c753269.zip
dev-python/pytest-rerunfailures: Bump to 11.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pytest-rerunfailures/Manifest1
-rw-r--r--dev-python/pytest-rerunfailures/pytest-rerunfailures-11.1.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pytest-rerunfailures/Manifest b/dev-python/pytest-rerunfailures/Manifest
index d621bcb0b6dd..1da996c953cc 100644
--- a/dev-python/pytest-rerunfailures/Manifest
+++ b/dev-python/pytest-rerunfailures/Manifest
@@ -1,2 +1,3 @@
DIST pytest-rerunfailures-10.3.tar.gz 15852 BLAKE2B 1063f55f4145eff4db22f121620cb3a53ad8cd0c44580578bd5027c4bd8005af6d33e0da8d67fceb7b8abe91f22c591e7b42b7a810cb5c7d8b5668b0a48eb3f2 SHA512 30ebafdb221d7ff8c46d50795b1a342b55293eaf60f5a012c631e2333dcf3114bfc4ed5210705edba4ad33a8f215ce7b5988362750149fc5e9463e4c3fa93860
DIST pytest-rerunfailures-11.0.tar.gz 15836 BLAKE2B 41c3695250e809123c468325d6bb78275c2e09911eb98de1b0951add44fffc24ee2157bdad346fb9bc923ee3865fe205eaeadd1a1e7b908ee728ac2a8e1375c7 SHA512 8e0f43f63a76161447de6cfbe9382b7aece05d25cf9d1f03b6f12dcb8d98edd85d6e8f5d74d360143cd99188f082c3ab412324543307b08c4bef0e5a2dc06b3a
+DIST pytest-rerunfailures-11.1.tar.gz 16681 BLAKE2B aa1e35659411bc9cc777253982d53b39a969fe1448990008e99903ca3bd2a675f07551ab806a0656b9ed329b519458c02e46dc8fa2f1e0f60be8e3b2457e48d1 SHA512 9a572faab4ee1907e829d38979a87c5eb24dc13edfbbd987801b610f67d0a5ce8743f2bdbe883bd247915e6ede6b73fceae9c4994774e74b1b1a192587829e05
diff --git a/dev-python/pytest-rerunfailures/pytest-rerunfailures-11.1.ebuild b/dev-python/pytest-rerunfailures/pytest-rerunfailures-11.1.ebuild
new file mode 100644
index 000000000000..5ed7cf6acb69
--- /dev/null
+++ b/dev-python/pytest-rerunfailures/pytest-rerunfailures-11.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="pytest plugin to re-run tests to eliminate flaky failures"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-rerunfailures/
+ https://pypi.org/project/pytest-rerunfailures/
+"
+
+SLOT="0"
+LICENSE="MPL-2.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/packaging-17.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_rerunfailures
+ epytest
+}