summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2019-08-01 15:56:12 +0200
committerManuel Rüger <mrueg@gentoo.org>2019-08-01 15:56:12 +0200
commit9c7faadf7c21a38c6fae5a98916da1413c4c79cc (patch)
tree8843482adcdee042912c8236810a967d1f230f13
parentdev-lisp/roswell: Add roswell ebuild (diff)
downloadgentoo-9c7faadf.tar.gz
gentoo-9c7faadf.tar.bz2
gentoo-9c7faadf.zip
net-misc/istioctl: Version bump to 1.1.12
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
-rw-r--r--net-misc/istioctl/Manifest1
-rw-r--r--net-misc/istioctl/istioctl-1.1.12.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/net-misc/istioctl/Manifest b/net-misc/istioctl/Manifest
index 214d5a07884a..b48f2375900d 100644
--- a/net-misc/istioctl/Manifest
+++ b/net-misc/istioctl/Manifest
@@ -1 +1,2 @@
+DIST istioctl-1.1.12.tar.gz 20720842 BLAKE2B c7b70ee162daabcf82cc8cbd8ec61d49b68189fcab43a1f04daa9dee6701075330557d2567cabae7f8fa37a2b3ebac23def53cca43930a9c1bf5079c15198f48 SHA512 a7aa37a2ec12b802d38a27cc4b6131ec604e14f0c64d2a3619f2918cc24cbf7bf0e291d58185e0481d544b28264f8782636abdca5afdacde6c3ad41ae616b90d
DIST istioctl-1.1.8.tar.gz 20718514 BLAKE2B 20b492932906bab3d8fd2e66452acf42a3b8fc07bb42e95217410b32ede68f2dc4256f4e33b104428996a3cfa2f30c798ccf2cc3794079c8936d353330763c88 SHA512 907bff4a7239e0e615fcc3ea92c98d944916dc88c744d574b5362e622729e8fb5a79e549a7f0beece5235918d7891ef6283e6b1e3f789980450d7eee1e131e2b
diff --git a/net-misc/istioctl/istioctl-1.1.12.ebuild b/net-misc/istioctl/istioctl-1.1.12.ebuild
new file mode 100644
index 000000000000..40518fcd4c12
--- /dev/null
+++ b/net-misc/istioctl/istioctl-1.1.12.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit golang-vcs-snapshot
+
+GIT_COMMIT="473d9b3"
+
+KEYWORDS="~amd64"
+DESCRIPTION="Istio configuration command line utility"
+EGO_PN="istio.io/istio"
+HOMEPAGE="https://github.com/istio/istio"
+MY_PV=${PV/_/-}
+SRC_URI="https://github.com/istio/istio/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RESTRICT="test"
+
+src_compile() {
+ pushd "src/${EGO_PN}" || die
+ BUILDINFO="istio.io/istio/pkg/version.buildVersion=${PV}
+ istio.io/istio/pkg/version.buildGitRevision=${GIT_COMMIT}
+ istio.io/istio/pkg/version.buildStatus=Clean" \
+ VERBOSE=1 GOPATH="${WORKDIR}/${P}" TAG=${PV} emake istioctl
+ popd || die
+}
+
+src_install() {
+ dobin out/linux_amd64/release/${PN}
+ pushd "src/${EGO_PN}" || die
+ dodoc README.md
+}