summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Smith <matt@offtopica.uk>2019-08-26 20:24:34 +0100
committerJoonas Niilola <juippis@gentoo.org>2019-08-28 21:19:31 +0300
commit9ca67b1bd2a2b5c6f93f08ee40fd0d2eb8d7fbe1 (patch)
tree67cf65b43f675bf38eff321c5734585160986106
parentdev-go/go-sqlite3: fix double prefix found by Gentoo CI (diff)
downloadgentoo-9ca67b1bd2a2b5c6f93f08ee40fd0d2eb8d7fbe1.tar.gz
gentoo-9ca67b1bd2a2b5c6f93f08ee40fd0d2eb8d7fbe1.tar.bz2
gentoo-9ca67b1bd2a2b5c6f93f08ee40fd0d2eb8d7fbe1.zip
net-mail/mu: bump to 1.3.3
Closes: https://bugs.gentoo.org/684140 Closes: https://bugs.gentoo.org/684144 Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Matt Smith <matt@offtopica.uk> Closes: https://github.com/gentoo/gentoo/pull/12795 Closes: https://github.com/gentoo/gentoo/pull/12127 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--net-mail/mu/Manifest1
-rw-r--r--net-mail/mu/metadata.xml9
-rw-r--r--net-mail/mu/mu-1.3.3.ebuild86
3 files changed, 95 insertions, 1 deletions
diff --git a/net-mail/mu/Manifest b/net-mail/mu/Manifest
index 1756c03a4865..8ad2c794d41c 100644
--- a/net-mail/mu/Manifest
+++ b/net-mail/mu/Manifest
@@ -1,2 +1,3 @@
DIST mu-0.9.18.tar.gz 2250319 BLAKE2B 7eb83a797eccff706ac6b264a7d56feae80e40f370e190e0a94f2524dd73a8bfdb35599909f90d0a2b87fc513bbcf2b00fa307a3e4d0b6718ebdc7f7fcdc6df0 SHA512 47104d18547de0871782abc4e1c6dbf1f9b2489410e5716043861bf8d973d33d2138de7d7ac568b300ca86ae9f1a0fda0fa9555ad9a5938771336ef958183546
DIST mu-1.0.tar.gz 2273670 BLAKE2B a771b00159142fa4a671d07cf9de6f0f941c432ddee31f19606c260ba3dfef857a36a333f5ede4ca30be88d7b7eae28e996e15a8deebd96971b341f0f72bfbbb SHA512 49b0b86f22e9a6ace1fc3fd6e7a8a523aa9edf092b953d59f59a1ef7311c8c546a261a1a186e3285cea788be20c816c70ac08d1514f700ff97258a2012ad394d
+DIST mu-1.3.3.tar.gz 2304029 BLAKE2B e2bbf3f7aa22ba2e1fd64b0e35df3e857dd3ec7874d08d36350a5d80abb36c667dee3cb43adf481dfbabd2a7944e84207d1913cb2525e637878a86fa70b213af SHA512 ab7844aef1ee6526a8b4ac1b98f6dc323fa01be6ac999f7b8a57b1c2aee6eec60a5643589c0477e8fede2f5140a8aa9050f00e52a30aaa1cd6b1cdbd66e441bf
diff --git a/net-mail/mu/metadata.xml b/net-mail/mu/metadata.xml
index f5c66685bfc7..52409e491151 100644
--- a/net-mail/mu/metadata.xml
+++ b/net-mail/mu/metadata.xml
@@ -1,7 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>matt@offtopica.uk</email>
+ <name>Matt Smith</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<longdescription lang="en">
'mu' is a set of command-line tools for Linux/Unix that enable you to quickly find the e-mails you
are looking for, assuming that you store your e-mails in Maildirs. It also includes an emacs based mail client mu4e.
diff --git a/net-mail/mu/mu-1.3.3.ebuild b/net-mail/mu/mu-1.3.3.ebuild
new file mode 100644
index 000000000000..da630a9ec6a7
--- /dev/null
+++ b/net-mail/mu/mu-1.3.3.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools elisp-common
+
+DESCRIPTION="Set of tools to deal with Maildirs, in particular, searching and indexing"
+HOMEPAGE="http://www.djcbsoftware.nl/code/mu/ https://github.com/djcb/mu"
+SRC_URI="https://github.com/djcb/mu/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="emacs guile"
+
+# net-mail/mailutils also installes /usr/bin/mu. Block it until somebody
+# really wants both installed at the same time.
+DEPEND="
+ dev-libs/gmime:3.0
+ dev-libs/xapian
+ dev-libs/glib:2
+ emacs? ( >=virtual/emacs-24.4 )
+ guile? ( >=dev-scheme/guile-2.0 )
+ !net-mail/mailutils"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+SITEFILE="70mu-gentoo.el"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # Note: Author recommends that packages do not build the webkit toy
+ # Todo: Add gtk USE-flag
+
+ econf --disable-gtk \
+ --disable-webkit \
+ $(use_enable emacs mu4e) \
+ $(use_enable guile)
+}
+
+src_install () {
+ dobin mu/mu
+ dodoc AUTHORS HACKING NEWS NEWS.org TODO README README.org ChangeLog
+ if use emacs; then
+ elisp-install ${PN} mu4e/*.el mu4e/*.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ doinfo mu4e/mu4e.info
+ fi
+
+ doman man/mu-add.1 man/mu-bookmarks.5 man/mu-cfind.1 man/mu-easy.1 \
+ man/mu-extract.1 man/mu-find.1 man/mu-help.1 man/mu-index.1 \
+ man/mu-mkdir.1 man/mu-query.7 man/mu-remove.1 \
+ man/mu-script.1 man/mu-server.1 man/mu-verify.1 \
+ man/mu-view.1 man/mu.1
+
+ if use guile; then
+ doinfo guile/mu-guile.info
+ fi
+}
+
+src_test () {
+ # Note: Fails with parallel make
+ emake -j1 check
+}
+
+pkg_postinst() {
+ if use emacs; then
+ einfo "To use mu4e you need to configure it in your .emacs file"
+ einfo "See the manual for more information:"
+ einfo "http://www.djcbsoftware.nl/code/mu/mu4e/"
+ fi
+
+ elog "If you upgrade from an older major version,"
+ elog "then you need to rebuild your mail index."
+
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}