summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-09-09 16:30:31 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-09-09 20:14:00 +0200
commit9cb6de9949e48ff71bb325e0d5672d633dde282f (patch)
tree3037a8542d6043d7b19aedf3fd3e4846e17cb206
parentgames-emulation/ppsspp: bump to 1.16 (diff)
downloadgentoo-9cb6de9949e48ff71bb325e0d5672d633dde282f.tar.gz
gentoo-9cb6de9949e48ff71bb325e0d5672d633dde282f.tar.bz2
gentoo-9cb6de9949e48ff71bb325e0d5672d633dde282f.zip
games-emulation/ppsspp: drop old 1.15
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--games-emulation/ppsspp/Manifest1
-rw-r--r--games-emulation/ppsspp/ppsspp-1.15.ebuild65
2 files changed, 0 insertions, 66 deletions
diff --git a/games-emulation/ppsspp/Manifest b/games-emulation/ppsspp/Manifest
index 0f39c295f736..d82b84485154 100644
--- a/games-emulation/ppsspp/Manifest
+++ b/games-emulation/ppsspp/Manifest
@@ -1,3 +1,2 @@
DIST ppsspp-1.15.4.tar.xz 51947468 BLAKE2B c6a5e621b02556b791ec41389f17dede63811c87ff628b8f1304ac950071b365ecc9be05f4042e4e3b81e77f5a14b6931577f08b0174fec821350a1d7eca4d6a SHA512 9d2c140b0d633e5ca6191aaf276b7e4f6d029f29d1313a45fb78ee3879fec09f57d816604c51474ab6fe9cde713787d5769e87466d3c3015fe6a9b195ff198d2
-DIST ppsspp-1.15.tar.xz 52176784 BLAKE2B f0733edd114e09c3dfc4910fb48b7c5687af06faf39ed9184429d5f9ad0af3149a9270426b92eccbe97f61e436e7399c49e4feb0db05ce9df4d4177d091d7a08 SHA512 88e97f964e826cf791725ed62178dbfa456094af06a1c896df640b24a4e2ae8ed79e0ae63cb29cc6a92e83ecd63ab60013ddf32333fb1e8b5024a6e3fce6b71f
DIST ppsspp-1.16.tar.xz 50656132 BLAKE2B 5149bd859134a76a191e0f144bdcefc4c521276ebb1390fe5e24eeeb1227b77bab0458a760f29aed5ba169d566f12d5226f2b50a19e44172f1ad98c4eb8f400f SHA512 d65a8c9fb5d7ff45a99f5852d1071029bc51c1e8bdb45b3e78d961a46587553db4465bbd97b301db54a94b60772359929524047f08de3067cd3336f5f7717826
diff --git a/games-emulation/ppsspp/ppsspp-1.15.ebuild b/games-emulation/ppsspp/ppsspp-1.15.ebuild
deleted file mode 100644
index 653f672374ea..000000000000
--- a/games-emulation/ppsspp/ppsspp-1.15.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit python-any-r1 xdg cmake
-
-DESCRIPTION="A PSP emulator written in C++"
-HOMEPAGE="https://www.ppsspp.org/
- https://github.com/hrydgard/ppsspp/"
-SRC_URI="https://github.com/hrydgard/${PN}/releases/download/v${PV}/${P}.tar.xz"
-
-LICENSE="Apache-2.0 BSD BSD-2 GPL-2 JSON MIT"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="discord qt5"
-RESTRICT="test"
-
-RDEPEND="
- app-arch/snappy:=
- app-arch/zstd:=
- dev-libs/libzip:=
- media-libs/glew:=
- media-libs/libpng:=
- media-libs/libsdl2[joystick]
- media-video/ffmpeg:0/56.58.58
- sys-libs/zlib:=
- virtual/opengl
- qt5? (
- dev-qt/qtcore:5
- dev-qt/qtgui:5[-gles2-only]
- dev-qt/qtmultimedia:5[-gles2-only]
- dev-qt/qtopengl:5[-gles2-only]
- dev-qt/qtwidgets:5[-gles2-only]
- )
- !qt5? ( media-libs/libsdl2[X,opengl,sound,video] )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="${PYTHON_DEPS}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-CMakeLists-flags.patch
- "${FILESDIR}"/${PN}-disable-ccache-autodetection.patch
-)
-
-pkg_setup() {
- python-any-r1_pkg_setup
-}
-
-src_configure() {
- local -a mycmakeargs=(
- -DBUILD_SHARED_LIBS=OFF
- -DCMAKE_SKIP_RPATH=ON
- -DHEADLESS=false
- -DUSE_SYSTEM_FFMPEG=ON
- -DUSE_SYSTEM_LIBZIP=ON
- -DUSE_SYSTEM_SNAPPY=ON
- -DUSE_SYSTEM_ZSTD=ON
- -DUSE_DISCORD=$(usex discord)
- -DUSING_QT_UI=$(usex qt5)
- )
- cmake_src_configure
-}