summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernardo Meurer <bernardo@standard.ai>2019-09-12 12:04:15 +0200
committerDavid Seifert <soap@gentoo.org>2019-09-12 12:04:15 +0200
commit9ced40ed7bbfddd48cc772b6de33e2e6b92e32cd (patch)
treeec2c800b61564517d9fb0ee142cba280a199523f
parentdev-python/mediafile: new package (0.2.0) (diff)
downloadgentoo-9ced40ed.tar.gz
gentoo-9ced40ed.tar.bz2
gentoo-9ced40ed.zip
dev-python/sphinxcontrib-pretty-searchresults: new package (0.3.5)
Decently styled search results for sphinx-doc projects. Closes: https://bugs.gentoo.org/693168 Closes: https://github.com/gentoo/gentoo/pull/12826 Package-Manager: Portage-2.3.73, Repoman-2.3.17 Signed-off-by: Bernardo Meurer <bernardo@standard.ai> Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--dev-python/sphinxcontrib-pretty-searchresults/Manifest1
-rw-r--r--dev-python/sphinxcontrib-pretty-searchresults/metadata.xml25
-rw-r--r--dev-python/sphinxcontrib-pretty-searchresults/sphinxcontrib-pretty-searchresults-0.3.5.ebuild42
3 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-pretty-searchresults/Manifest b/dev-python/sphinxcontrib-pretty-searchresults/Manifest
new file mode 100644
index 000000000000..e487c5a4317e
--- /dev/null
+++ b/dev-python/sphinxcontrib-pretty-searchresults/Manifest
@@ -0,0 +1 @@
+DIST sphinxcontrib-pretty-searchresults-0.3.5.tar.gz 9996 BLAKE2B 64324f306aec1d6eac9c791acc0f3f4a0a434f734abcf9bb0d34151137e20407d59e95ea3a3a981e425ded6b6fd82bd36627323a3ed493a47b92979ac5fe2f77 SHA512 30c9a0af183ffada3300c03495afb9f52fbba5522dd386c5a05a28fa1e6dd0fb66725499db7a537534496843e6707c7dcceea45511ee3953d02c3e2275e68630
diff --git a/dev-python/sphinxcontrib-pretty-searchresults/metadata.xml b/dev-python/sphinxcontrib-pretty-searchresults/metadata.xml
new file mode 100644
index 000000000000..479261280af7
--- /dev/null
+++ b/dev-python/sphinxcontrib-pretty-searchresults/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>bernardo@standard.ai</email>
+ <name>Bernardo Meurer</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Gentoo Proxy Maintainers Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Sphinx: pretty search results is an extension for the Sphinx
+ documentation tool.
+
+ To display search results, Sphinx is fetching the
+ source files of search hits and rendering excerpts in raw markup
+ (Example). This extension removes the markup from these source files
+ (during build time), so the search results look decent.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">sphinxprettysearchresults</remote-id>
+ <remote-id type="github">sphinx-contrib/sphinx-pretty-searchresults</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinxcontrib-pretty-searchresults/sphinxcontrib-pretty-searchresults-0.3.5.ebuild b/dev-python/sphinxcontrib-pretty-searchresults/sphinxcontrib-pretty-searchresults-0.3.5.ebuild
new file mode 100644
index 000000000000..93849564786c
--- /dev/null
+++ b/dev-python/sphinxcontrib-pretty-searchresults/sphinxcontrib-pretty-searchresults-0.3.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit distutils-r1
+
+MY_PN="${PN/sphinxcontrib/sphinx}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Decently styled search results for sphinx-doc projects"
+HOMEPAGE="https://github.com/sphinx-contrib/sphinx-pretty-searchresults"
+SRC_URI="https://github.com/sphinx-contrib/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/sphinx-testing[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/recommonmark[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ cd tests || die
+ "${EPYTHON}" run.py || die
+}