summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-14 23:03:12 +0000
committerSam James <sam@gentoo.org>2023-02-14 23:03:52 +0000
commit9cfa0d12cb3c46a1bb7cfd07e6a4ed67e7897613 (patch)
tree6973277799f9644ddcb09041828086c2791c500a
parentapp-crypt/gpgstats: fix build w/ clang 16 (diff)
downloadgentoo-9cfa0d12cb3c46a1bb7cfd07e6a4ed67e7897613.tar.gz
gentoo-9cfa0d12cb3c46a1bb7cfd07e6a4ed67e7897613.tar.bz2
gentoo-9cfa0d12cb3c46a1bb7cfd07e6a4ed67e7897613.zip
app-editors/yudit: add 3.1.0
Closes: https://bugs.gentoo.org/894384 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-editors/yudit/Manifest1
-rw-r--r--app-editors/yudit/yudit-3.1.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/app-editors/yudit/Manifest b/app-editors/yudit/Manifest
index b5f4f3c24507..93e80c06ad1c 100644
--- a/app-editors/yudit/Manifest
+++ b/app-editors/yudit/Manifest
@@ -1 +1,2 @@
DIST yudit-2.9.6.tar.gz 2797142 BLAKE2B 76fb8e0ade65c84389db71b4100e458f5b70aebba27eea4b604bfcee08974060dcd2bab2d86586b5ba729d8d5090c943e825dfe58d71c609f0ca2f2e0c3900c9 SHA512 a9a0b6f6c44451cf2fefc4fc0bb1bbd9ffccd17c4c622dc35b08113245b3bb9f3ca949f3e7b9d2aa919ebf3840295c5e63c0297576e74a5f2d1fb99cfc97c46b
+DIST yudit-3.1.0.tar.gz 4317815 BLAKE2B fdcec8402bd87f800b0e2712f74d5d546d7ba0733b36fec720e46ef0c5efc0be340ec8db7ffe101c5596d054cc10e1364bf2d5a70f25b234e57165b5116edd80 SHA512 07b89cdea29971fe49a7e61e2919261d6a39a6420c2587fad160a78885513460cb210b63dbfc1320f993d38e56e4104f77911530b9b7da210bfb7390e37ed352
diff --git a/app-editors/yudit/yudit-3.1.0.ebuild b/app-editors/yudit/yudit-3.1.0.ebuild
new file mode 100644
index 000000000000..242bbde3de65
--- /dev/null
+++ b/app-editors/yudit/yudit-3.1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Free (Y)unicode text editor for all unices"
+HOMEPAGE="https://www.yudit.org/"
+SRC_URI="https://yudit.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-devel/gettext"
+
+src_prepare() {
+ default
+ # Don't strip binaries, let portage do that.
+ sed -i "/^INSTALL_PROGRAM/s: -s::" Makefile.conf.in || die "sed failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc {BUGS,CHANGELOG,NEWS,TODO}.TXT
+}