summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYongxiang Liang <tanekliang@gmail.com>2024-04-04 10:38:13 +0800
committerYixun Lan <dlan@gentoo.org>2024-04-04 02:50:19 +0000
commit9d0b6a0580b36b4a6855594892ae0d491c866a87 (patch)
treea7da69663cca98ea3748ceebc5ccb3431aa71bff
parentapp-i18n/fcitx-qt: drop 5.1.4 (diff)
downloadgentoo-9d0b6a05.tar.gz
gentoo-9d0b6a05.tar.bz2
gentoo-9d0b6a05.zip
app-i18n/fcitx-qt: Add missing slot operators
It needs to be recompiled because it uses private api of QT when a subslot of qt6 changes. Closes: https://github.com/gentoo/gentoo/pull/36077 Signed-off-by: Yongxiang Liang <tanekliang@gmail.com> Signed-off-by: Yixun Lan <dlan@gentoo.org>
-rw-r--r--app-i18n/fcitx-qt/fcitx-qt-5.1.5-r2.ebuild (renamed from app-i18n/fcitx-qt/fcitx-qt-5.1.5-r1.ebuild)5
1 files changed, 2 insertions, 3 deletions
diff --git a/app-i18n/fcitx-qt/fcitx-qt-5.1.5-r1.ebuild b/app-i18n/fcitx-qt/fcitx-qt-5.1.5-r2.ebuild
index e08026f4846e..d942ecaa99a6 100644
--- a/app-i18n/fcitx-qt/fcitx-qt-5.1.5-r1.ebuild
+++ b/app-i18n/fcitx-qt/fcitx-qt-5.1.5-r2.ebuild
@@ -11,6 +11,7 @@ DESCRIPTION="Qt library and IM module for fcitx5"
HOMEPAGE="https://github.com/fcitx/fcitx5-qt"
SRC_URI="https://download.fcitx-im.org/fcitx5/${MY_PN}/${MY_PN}-${PV}.tar.xz -> ${P}.tar.xz"
+S="${WORKDIR}/${MY_PN}-${PV}"
LICENSE="BSD LGPL-2.1+"
SLOT="5"
KEYWORDS="~amd64 ~arm64 ~loong ~riscv ~x86"
@@ -34,7 +35,7 @@ RDEPEND="
wayland? ( dev-qt/qtwayland:5 )
)
qt6? (
- dev-qt/qtbase:6[dbus,gui,widgets,wayland?]
+ dev-qt/qtbase:6=[dbus,gui,widgets,wayland?]
wayland? ( dev-qt/qtwayland:6 )
)
X? (
@@ -50,8 +51,6 @@ BDEPEND="
!onlyplugin? ( sys-devel/gettext )
"
-S="${WORKDIR}/${MY_PN}-${PV}"
-
src_configure() {
local mycmakeargs=(
-DENABLE_QT4=no