summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-06-27 18:41:18 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-06-28 04:00:13 +0000
commit9d0dcd896f7433c28ad09b76c07b78a9fc6933f1 (patch)
treea8447819d58b57c4d95c3ee034e4e343e58b2aa3
parentdev-python/tqdm: added python-3.6 (diff)
downloadgentoo-9d0dcd89.tar.gz
gentoo-9d0dcd89.tar.bz2
gentoo-9d0dcd89.zip
dev-python/toro: initial import
Package-Manager: Portage-2.3.6, Repoman-2.3.2
-rw-r--r--dev-python/toro/Manifest1
-rw-r--r--dev-python/toro/files/toro-1.0.1-no-test-install.patch11
-rw-r--r--dev-python/toro/metadata.xml15
-rw-r--r--dev-python/toro/toro-1.0.1.ebuild38
4 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/toro/Manifest b/dev-python/toro/Manifest
new file mode 100644
index 000000000000..f4c3b4af3af4
--- /dev/null
+++ b/dev-python/toro/Manifest
@@ -0,0 +1 @@
+DIST toro-1.0.1.tar.gz 57343 SHA256 c5452e477e0d20ec459612a3be9eeed93e8dc5253423b604f73692ce628c6bc4 SHA512 a8a498868ff32dbd8ba9a0adf62b1fa2e9dea4f34be4e2701c08c7b58ef28b8daf4eab93916855a711a557049e587e886d6ba362487c151c5db34f6135f4f3e5 WHIRLPOOL a31ab1a0b33281cc7e248e297e77825a2015f57727b8d58912fabb17996e3e5e9a737de5748966abaf3db102a37e89fad2be20ca7afdc94773288f8382940d35
diff --git a/dev-python/toro/files/toro-1.0.1-no-test-install.patch b/dev-python/toro/files/toro-1.0.1-no-test-install.patch
new file mode 100644
index 000000000000..637f9091ac42
--- /dev/null
+++ b/dev-python/toro/files/toro-1.0.1-no-test-install.patch
@@ -0,0 +1,11 @@
+--- a/setup.py.orig 2017-06-27 18:38:37.256325950 +0000
++++ b/setup.py 2017-06-27 18:38:48.896243950 +0000
+@@ -45,8 +45,6 @@
+ kwargs['use_2to3'] = True
+
+ packages = ['toro']
+-if "test" in sys.argv:
+- packages.append('test')
+
+ setup(name='toro',
+ version='1.0.1',
diff --git a/dev-python/toro/metadata.xml b/dev-python/toro/metadata.xml
new file mode 100644
index 000000000000..214465d52996
--- /dev/null
+++ b/dev-python/toro/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription>
+ A set of locking and synchronizing primitives analogous to those in Python’s
+ threading module or Gevent’s coros, for use with Tornado’s gen.engine.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">toro</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/toro/toro-1.0.1.ebuild b/dev-python/toro/toro-1.0.1.ebuild
new file mode 100644
index 000000000000..195bd0f7796e
--- /dev/null
+++ b/dev-python/toro/toro-1.0.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Synchronization primitives for Tornado coroutines"
+HOMEPAGE="https://github.com/ajdavis/toro/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="examples test"
+
+RDEPEND="
+ virtual/python-futures[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+PATCHES=(
+ "${FILESDIR}"/${P}-no-test-install.patch
+)
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}