summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2016-03-21 14:06:37 +0800
committerYixun Lan <dlan@gentoo.org>2016-03-21 14:06:57 +0800
commit9d0fde94a897009dcd5c6a04ad599fa66d68cdec (patch)
tree669064c9eb8c023518be1d91a024ba03d037d694
parentprofiles: ia64: workaround --as-needed crashes in ld #541828 (diff)
downloadgentoo-9d0fde94a897009dcd5c6a04ad599fa66d68cdec.tar.gz
gentoo-9d0fde94a897009dcd5c6a04ad599fa66d68cdec.tar.bz2
gentoo-9d0fde94a897009dcd5c6a04ad599fa66d68cdec.zip
sys-process/criu: fix LIBDIR path, using $(get_libdir)
Package-Manager: portage-2.2.27
-rw-r--r--sys-process/criu/criu-2.0.ebuild2
-rw-r--r--sys-process/criu/files/2.0/criu-2.0-makefile.patch67
2 files changed, 40 insertions, 29 deletions
diff --git a/sys-process/criu/criu-2.0.ebuild b/sys-process/criu/criu-2.0.ebuild
index b8c219841a70..51da20c002ab 100644
--- a/sys-process/criu/criu-2.0.ebuild
+++ b/sys-process/criu/criu-2.0.ebuild
@@ -56,6 +56,7 @@ src_compile() {
CC="$(tc-getCC)" \
LD="$(tc-getLD)" \
OBJCOPY="$(tc-getOBJCOPY)" \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
ARCH="$(criu_arch)" \
V=1 WERROR=0 DEBUG=0 \
SETPROCTITLE=$(usex setproctitle) \
@@ -80,6 +81,7 @@ src_install() {
PREFIX="${EPREFIX}"/usr \
LOGROTATEDIR="${EPREFIX}"/etc/logrotate.d \
DESTDIR="${D}" \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
install
dodoc CREDITS README.md
diff --git a/sys-process/criu/files/2.0/criu-2.0-makefile.patch b/sys-process/criu/files/2.0/criu-2.0-makefile.patch
index b9c9cb4d83b3..a2783c711457 100644
--- a/sys-process/criu/files/2.0/criu-2.0-makefile.patch
+++ b/sys-process/criu/files/2.0/criu-2.0-makefile.patch
@@ -1,40 +1,36 @@
-Index: criu-2.0/Makefile.install
-===================================================================
---- criu-2.0.orig/Makefile.install
-+++ criu-2.0/Makefile.install
-@@ -5,13 +5,12 @@ PREFIX ?= /usr/local
+diff --git a/Makefile.install b/Makefile.install
+index 6fcf25e..103373b 100644
+--- a/Makefile.install
++++ b/Makefile.install
+@@ -5,23 +5,10 @@ PREFIX ?= /usr/local
SBINDIR ?= $(PREFIX)/sbin
MANDIR ?= $(PREFIX)/share/man
SYSTEMDUNITDIR ?= $(PREFIX)/lib/systemd/system/
-LOGROTATEDIR ?= $(PREFIX)/etc/logrotate.d/
--LIBDIR ?= $(PREFIX)/lib
+LOGROTATEDIR ?= $(SYSCONFDIR)/etc/logrotate.d/
+ LIBDIR ?= $(PREFIX)/lib
INCLUDEDIR ?= $(PREFIX)/include/criu
- #
- # For recent Debian/Ubuntu with multiarch support.
+-#
+-# For recent Debian/Ubuntu with multiarch support.
-DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH 2>/dev/null)
-+DEB_HOST_MULTIARCH ?=
- ifneq "$(DEB_HOST_MULTIARCH)" ""
- LIBDIR ?= $(PREFIX)/lib/$(DEB_HOST_MULTIARCH)
- else
-Index: criu-2.0/scripts/nmk/scripts/build.mk
-===================================================================
---- criu-2.0.orig/scripts/nmk/scripts/build.mk
-+++ criu-2.0/scripts/nmk/scripts/build.mk
-@@ -43,7 +43,7 @@ builtin-name := $(strip $(builtin-name))
+-ifneq "$(DEB_HOST_MULTIARCH)" ""
+- LIBDIR ?= $(PREFIX)/lib/$(DEB_HOST_MULTIARCH)
+-else
+- #
+- # For most other systems
+- ifeq "$(shell uname -m)" "x86_64"
+- LIBDIR ?= $(PREFIX)/lib64
+- endif
+-endif
+-
+ export SBINDIR MANDIR SYSTEMDUNITDIR LOGROTATEDIR
+ export INCLUDEDIR LIBDIR DESTDIR PREFIX
- #
- # Link flags.
--ld_flags := $(strip $(LDFLAGS) $(ldflags-y))
-+ld_flags := $(strip $(RAW_LDFLAGS) $(ldflags-y))
-
- #
- # Prepare targets.
-Index: criu-2.0/lib/Makefile
-===================================================================
---- criu-2.0.orig/lib/Makefile
-+++ criu-2.0/lib/Makefile
+diff --git a/lib/Makefile b/lib/Makefile
+index 0cd59a1..63bdaba 100644
+--- a/lib/Makefile
++++ b/lib/Makefile
@@ -20,10 +20,12 @@ PHONY += lib-c
#
@@ -57,7 +53,7 @@ Index: criu-2.0/lib/Makefile
$(E) " INSTALL " $(CRIU_SO)
$(Q) mkdir -p $(DESTDIR)$(LIBDIR)
$(Q) install -m 755 c/$(CRIU_SO) $(DESTDIR)$(LIBDIR)/$(CRIU_SO).$(CRIU_SO_VERSION_MAJOR).$(CRIU_SO_VERSION_MINOR)
-@@ -49,8 +51,6 @@ install: lib-c lib-py ../crit/crit c/cri
+@@ -49,8 +51,6 @@ install: lib-c lib-py ../crit/crit c/criu.pc.in
$(Q) mkdir -p $(DESTDIR)$(LIBDIR)/pkgconfig
$(Q) sed -e 's,@version@,$(CRIU_VERSION),' -e 's,@libdir@,$(LIBDIR),' -e 's,@includedir@,$(dir $(INCLUDEDIR)),' c/criu.pc.in > c/criu.pc
$(Q) install -m 644 c/criu.pc $(DESTDIR)$(LIBDIR)/pkgconfig
@@ -66,3 +62,16 @@ Index: criu-2.0/lib/Makefile
.PHONY: install
.PHONY: $(PHONY) clean
+diff --git a/scripts/nmk/scripts/build.mk b/scripts/nmk/scripts/build.mk
+index 10a5d44..ffe2a3c 100644
+--- a/scripts/nmk/scripts/build.mk
++++ b/scripts/nmk/scripts/build.mk
+@@ -43,7 +43,7 @@ builtin-name := $(strip $(builtin-name))
+
+ #
+ # Link flags.
+-ld_flags := $(strip $(LDFLAGS) $(ldflags-y))
++ld_flags := $(strip $(RAW_LDFLAGS) $(ldflags-y))
+
+ #
+ # Prepare targets.