summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-27 00:38:57 +0000
committerSam James <sam@gentoo.org>2021-02-27 01:00:13 +0000
commit9d1770570b346555c12a8fa5ef5653927dfbebe5 (patch)
treea517ded2482f6d2e9312695c3693c4814ae1927b
parentnet-analyzer/upnpscan: port to EAPI 7 (diff)
downloadgentoo-9d177057.tar.gz
gentoo-9d177057.tar.bz2
gentoo-9d177057.zip
x11-misc/viewglob: port to EAPI 7
Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--x11-misc/viewglob/viewglob-2.0.4-r1.ebuild28
1 files changed, 18 insertions, 10 deletions
diff --git a/x11-misc/viewglob/viewglob-2.0.4-r1.ebuild b/x11-misc/viewglob/viewglob-2.0.4-r1.ebuild
index 002f4494df2e..ebff9e4c1940 100644
--- a/x11-misc/viewglob/viewglob-2.0.4-r1.ebuild
+++ b/x11-misc/viewglob/viewglob-2.0.4-r1.ebuild
@@ -1,11 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-AUTOTOOLS_AUTORECONF=yes
-
-inherit autotools-utils readme.gentoo
+inherit autotools readme.gentoo-r1
DESCRIPTION="Graphical display of directories and globs referenced at the shell prompt"
HOMEPAGE="http://viewglob.sourceforge.net/"
@@ -14,21 +12,31 @@ SRC_URI="mirror://sourceforge/viewglob/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc ~sparc x86"
-IUSE=""
+BDEPEND="virtual/pkgconfig"
RDEPEND="
dev-libs/glib:2
x11-libs/gtk+:2
|| ( app-shells/bash:* app-shells/zsh )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}"/${P}-underlinking.patch
"${FILESDIR}"/${P}-format-security.patch
)
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
src_install() {
- autotools-utils_src_install
- readme.gentoo_src_install
+ default
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
}