summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-07 03:44:49 +0100
committerSam James <sam@gentoo.org>2022-04-07 04:37:41 +0100
commit9d1c977852df6f69ece2d34b831c7869d120ea47 (patch)
tree47bccd2c55ec801b97745569bc8dc0a8881a92c4
parentsci-mathematics/pari: new upstream version 2.13.4. (diff)
downloadgentoo-9d1c977852df6f69ece2d34b831c7869d120ea47.tar.gz
gentoo-9d1c977852df6f69ece2d34b831c7869d120ea47.tar.bz2
gentoo-9d1c977852df6f69ece2d34b831c7869d120ea47.zip
sys-libs/libcap-ng: add 0.8.3
Keep the Fedora patch for now (one last time?) which reverts a behaviour change until we're a bit more certain consumers are fixed. Given Fedora is still shipping it (and the upstream maintainer == Fedora maintainer), I'd rather wait a bit longer before dropping. That said, gnome-keyring is fixed since 40, and it was the only known breakage AFAIK. Bug: https://bugs.gentoo.org/759550 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-libs/libcap-ng/Manifest1
-rw-r--r--sys-libs/libcap-ng/libcap-ng-0.8.3.ebuild109
2 files changed, 110 insertions, 0 deletions
diff --git a/sys-libs/libcap-ng/Manifest b/sys-libs/libcap-ng/Manifest
index 91583ac0a494..c555c666fdf8 100644
--- a/sys-libs/libcap-ng/Manifest
+++ b/sys-libs/libcap-ng/Manifest
@@ -1,2 +1,3 @@
DIST libcap-ng-0.8.2-apply-disable.patch 723 BLAKE2B 70d9959c55119c02bbc4ea605251491c04c477511c20b9fe93e6527ffd3fe2f35a72fabab5ca149c4aaf536c6cd8dceb15375297158f8827a0c676744381bbc1 SHA512 8c9317bdd4fde7d6a4618ec613bce46bed7646891bd16bc3fa307e9a814e38601bf3c6ad13102389d4596d9ed6a7ad853cca58624e724fe07383007e386c51f8
DIST libcap-ng-0.8.2.tar.gz 456066 BLAKE2B 7e721d05b92fd3708b970527e76b1898daa91bde3ab6ed5d8f23b1435404fbe7d15731461c6d9d2c791738e5498d1f5eaba727413480d34b7edea13c8691c32b SHA512 0ac6e55c03b1fba3a849048b721e250951afb59190d9646704d4fd9938eccc3bd0767380fbddc42f186b4f55695475e31f34f537ae91c04a37662577a5b7a19b
+DIST libcap-ng-0.8.3.tar.gz 455383 BLAKE2B c54dd753e0ef6dd21bcf6af7b003f85ded9faf2fbf1ea834cda6b181b165ff4b11a0284c23c73d0e6f97a810b3e6a63fceeb57ff583a2b32f23924bdee597ef5 SHA512 0ef9bc7bc6b7b59991f43b79aa6cde3e8d2c22c4b9ced2af8deae501e01d51e893033d109cb8aa0fdcba190140110993089245346334d7b114d18f1bb1b55b97
diff --git a/sys-libs/libcap-ng/libcap-ng-0.8.3.ebuild b/sys-libs/libcap-ng/libcap-ng-0.8.3.ebuild
new file mode 100644
index 000000000000..9dbc035b5526
--- /dev/null
+++ b/sys-libs/libcap-ng/libcap-ng-0.8.3.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Keep an eye on Fedora's packaging (https://src.fedoraproject.org/rpms/libcap-ng/tree/rawhide) for patches
+# Same maintainer in Fedora as upstream
+PYTHON_COMPAT=( python3_{8..10} )
+inherit autotools flag-o-matic python-r1
+
+DESCRIPTION="POSIX 1003.1e capabilities"
+HOMEPAGE="https://people.redhat.com/sgrubb/libcap-ng/"
+# Patch works around / reverts a behaviour change because not all consumers were ready.
+# Keep this patch for a bit longer until Fedora stop shipping it (not clear what else
+# other than gnome-keyring was broken by it: bug #759550)
+# Fedora 0.8.2 https://src.fedoraproject.org/rpms/libcap-ng/c/a5b0f536df1132d8e7afa4c0ce07b630e7970cad?branch=master
+SRC_URI="https://people.redhat.com/sgrubb/${PN}/${P}.tar.gz
+ https://src.fedoraproject.org/rpms/libcap-ng/raw/a5b0f536df1132d8e7afa4c0ce07b630e7970cad/f/libcap-ng-0.8.2-apply-disable.patch"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x86-linux"
+IUSE="python static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ sys-kernel/linux-headers"
+BDEPEND="python? ( >=dev-lang/swig-2 )"
+
+PATCHES=(
+ "${DISTDIR}"/libcap-ng-0.8.2-apply-disable.patch
+)
+
+src_prepare() {
+ default
+
+ if use prefix ; then
+ sed -i "s@cat /usr@cat ${EPREFIX}/usr@" bindings/python*/Makefile.am || die
+ # bug #668722
+ eautomake
+ fi
+}
+
+src_configure() {
+ use sparc && replace-flags -O? -O0
+
+ local ECONF_SOURCE="${S}"
+
+ local myconf=(
+ $(use_enable static-libs static)
+ )
+
+ local pythonconf=(
+ --without-python
+ --without-python3
+ )
+
+ # Set up python bindings build(s)
+ if use python ; then
+ setup_python_flags_configure() {
+ pythonconf=(
+ --without-python
+ --with-python3
+ )
+
+ run_in_build_dir econf "${pythonconf[@]}" "${myconf[@]}"
+ }
+
+ python_foreach_impl setup_python_flags_configure
+ else
+ local BUILD_DIR="${WORKDIR}"/build
+ run_in_build_dir econf "${pythonconf[@]}" "${myconf[@]}"
+ fi
+}
+
+src_compile() {
+ if use python ; then
+ python_foreach_impl run_in_build_dir emake
+ else
+ local BUILD_DIR="${WORKDIR}"/build
+ emake -C "${BUILD_DIR}"
+ fi
+}
+
+src_test() {
+ if [[ "${EUID}" -eq 0 ]] ; then
+ ewarn "Skipping tests due to root permissions."
+ return
+ fi
+
+ if use python ; then
+ python_foreach_impl run_in_build_dir emake check
+ else
+ local BUILD_DIR="${WORKDIR}"/build
+ emake -C "${BUILD_DIR}" check
+ fi
+}
+
+src_install() {
+ if use python ; then
+ python_foreach_impl run_in_build_dir emake DESTDIR="${D}" install
+ else
+ local BUILD_DIR="${WORKDIR}"/build
+ emake -C "${BUILD_DIR}" DESTDIR="${D}" install
+ fi
+
+ find "${ED}" -name '*.la' -delete || die
+}