summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Seren <guillaumeseren@gmail.com>2020-03-13 22:31:47 +0100
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2020-03-18 22:21:26 +0000
commit9d2497303272322c7fc4e37ebe7f729df2b327ba (patch)
tree0197f29e5efb4ec379d768d0f4f1f5ef46abd365
parentmail-filter/afew: Add myself to maintainer (diff)
downloadgentoo-9d249730.tar.gz
gentoo-9d249730.tar.bz2
gentoo-9d249730.zip
mail-filter/afew: Add version bump 2.0.0
Closes: https://bugs.gentoo.org/712426 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Guillaume Seren <guillaumeseren@gmail.com> Signed-off-by: Amadeusz Piotr Żołnowski <aidecoe@gentoo.org>
-rw-r--r--mail-filter/afew/Manifest1
-rw-r--r--mail-filter/afew/afew-2.0.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/mail-filter/afew/Manifest b/mail-filter/afew/Manifest
index fa67404920a7..9532cb40e127 100644
--- a/mail-filter/afew/Manifest
+++ b/mail-filter/afew/Manifest
@@ -1,2 +1,3 @@
DIST afew-1.2.0.tar.gz 31831 BLAKE2B 7976dfc1e56461afbd6244220c5d548c7de5e95649bd7ac0c986457c99cfc4574e6f5d6b90bc8985ef37e84f55f52b8417fcc1644c9aadf0a37123e0ea0ecba2 SHA512 98184808ae37e169bdbda9ac43db00e3e0712aaadc9b75e07c8d483c8024aa0cafb0a3424bda5703dfe77a09f5efd9812b80b3468009cfb4562eb5d0069558e4
DIST afew-1.3.0.tar.gz 33361 BLAKE2B 2553c04fce7e1c9f0a6551a8a01ed85735320bea95fe723050bdbde97aea80b93631c3621ec6cb0687753cbd88ac26725b1c608f7b8a6bcb4fc5bce6d3fce411 SHA512 2e15dc2aa6032b14c3fed57cb5912e3c3471592586f5fa40991b2a007d8a9579c0e1f69e455e1405923b93de64b9b8c126b5ccf8da72144528c57108beea7370
+DIST afew-2.0.0.tar.gz 33116 BLAKE2B 59f2686a6495ee9e4a0afaf3180a83667bc65aaee453fe73cb2813401778d63fbb67adb45ed5f98c5c593d07d53411042096d44d85e652157d6705eb2e236152 SHA512 09eaca6fd387b76f310879f6e04c21f3247e703300d9995d40c420a06a5884cb08ebd51e5d1caee6d8c5be29844f6d562838104445e7b7efd372690c1856f97d
diff --git a/mail-filter/afew/afew-2.0.0.ebuild b/mail-filter/afew/afew-2.0.0.ebuild
new file mode 100644
index 000000000000..b9e74273e201
--- /dev/null
+++ b/mail-filter/afew/afew-2.0.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python{3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Initial tagging script for Notmuch"
+HOMEPAGE="https://github.com/afewmail/afew"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/chardet[${PYTHON_MULTI_USEDEP}]
+ dev-python/dkimpy[${PYTHON_MULTI_USEDEP}]
+ net-mail/notmuch[python,${PYTHON_MULTI_USEDEP}]
+ ')"
+DEPEND="
+ $(python_gen_cond_dep '
+ dev-python/sphinx[${PYTHON_MULTI_USEDEP}]
+ ')"
+
+DOCS=( "README.rst" )
+
+python_prepare_all() {
+ sed -r \
+ -e "s/^([[:space:]]+)use_scm_version=.*,$/\1version='${PV}',/" \
+ -e "/^([[:space:]]+)setup_requires=.*,$/d" \
+ -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ esetup.py build_sphinx -b man --build-dir=docs/build
+ use doc && esetup.py build_sphinx -b html --build-dir=docs/build
+}
+
+python_install_all() {
+ doman docs/build/man/*
+ dodoc afew/defaults/afew.config
+ use doc && local HTML_DOCS=( docs/build/html/. )
+}