summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-11-28 15:26:41 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-11-28 17:57:49 +0100
commit9d26b333831931f8d1c59d99fc2247e3ab2dca57 (patch)
tree9c30daf49ad19523d5365f868835be549f0bf5b4
parentnet-misc/gallery-dl: drop old 1.26.0 (diff)
downloadgentoo-9d26b333831931f8d1c59d99fc2247e3ab2dca57.tar.gz
gentoo-9d26b333831931f8d1c59d99fc2247e3ab2dca57.tar.bz2
gentoo-9d26b333831931f8d1c59d99fc2247e3ab2dca57.zip
net-misc/gallery-dl: bump to 1.26.3
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--net-misc/gallery-dl/Manifest1
-rw-r--r--net-misc/gallery-dl/gallery-dl-1.26.3.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/net-misc/gallery-dl/Manifest b/net-misc/gallery-dl/Manifest
index 0d370ea85aa0..2a6057d69bc5 100644
--- a/net-misc/gallery-dl/Manifest
+++ b/net-misc/gallery-dl/Manifest
@@ -1,2 +1,3 @@
DIST gallery-dl-1.26.1.gh.tar.gz 604212 BLAKE2B 980e7b8b3c8ec966bb77db7c4312398490add75580e557f4654ca3aeb62ab287599f85dc401ed5bfae4dc6124e5a87b9254904b442b3a0cc2b10acdf5ce6695a SHA512 60d32ac82df5dd837399b778c118d8f944b7f35c5dfbbe8168841f0ff76471016b6049b617fef4825b3e21b37237c58bbc9f44be3e4e7ddb9bdf97cba11154bb
DIST gallery-dl-1.26.2.gh.tar.gz 607389 BLAKE2B 9bacfa4ba4019dbd8abd87ad868b1f6d2c56eab165633a07ba99c569962f26df6d82c96ef12c0c033792ece2084e4f5b7a2121483d51d765b828d4997780edc1 SHA512 08f0caa07f1e3fddf003658e9261e711b2a5fc0049447f36794c441f37ba01b74cc091f90378d5a649196ceba487d5dff541dbfcd86ca8c1b0551a972dc1f848
+DIST gallery-dl-1.26.3.gh.tar.gz 621229 BLAKE2B d85be6e8f3e21d5f8e18bcf70fb51f46d5672d48115bf88fb5fa3316b6e8cddca8c8c6f540f3b1529e6607d746aba98097aa95f692e98effa4e51ba4578d16aa SHA512 43891d40de26527b7195c064fda6c8303461c5e4107b0482ca535f06b8fe923513acc212bd75b4d8d82fa12e19ef214e1ee395ced1525eceda7a433d3d05fef3
diff --git a/net-misc/gallery-dl/gallery-dl-1.26.3.ebuild b/net-misc/gallery-dl/gallery-dl-1.26.3.ebuild
new file mode 100644
index 000000000000..b3da2a9c870f
--- /dev/null
+++ b/net-misc/gallery-dl/gallery-dl-1.26.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="sqlite,ssl,xml(+)"
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Download image galleries and collections from several image hosting sites"
+HOMEPAGE="https://github.com/mikf/gallery-dl"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mikf/${PN}.git"
+else
+ SRC_URI="https://github.com/mikf/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+# Tests require network access.
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND=">=dev-python/requests-2.11.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests setup.py
+
+python_compile_all() {
+ emake PYTHON=${EPYTHON} data/completion/{,_}gallery-dl man
+}
+
+pkg_postinst() {
+ optfeature "Pixiv Ugoira to WebM conversion" media-video/ffmpeg
+ optfeature "video downloads" net-misc/yt-dlp
+}