summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-10-12 20:52:48 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-10-12 21:08:40 +0200
commit9d28aa0afd7a6dd0ddc76a0c0fcd47c9ffcd09eb (patch)
tree07bc895d03c3da1a5aa312e9404470200d1f175c
parentdev-ros/rosclean: Bump to 1.15.7. (diff)
downloadgentoo-9d28aa0afd7a6dd0ddc76a0c0fcd47c9ffcd09eb.tar.gz
gentoo-9d28aa0afd7a6dd0ddc76a0c0fcd47c9ffcd09eb.tar.bz2
gentoo-9d28aa0afd7a6dd0ddc76a0c0fcd47c9ffcd09eb.zip
dev-ros/roscreate: Bump to 1.15.7.
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
-rw-r--r--dev-ros/roscreate/Manifest1
-rw-r--r--dev-ros/roscreate/roscreate-1.15.7.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/roscreate/Manifest b/dev-ros/roscreate/Manifest
index 5e99ca56e734..fbd51ec223a9 100644
--- a/dev-ros/roscreate/Manifest
+++ b/dev-ros/roscreate/Manifest
@@ -1 +1,2 @@
DIST ros-1.15.6.tar.gz 178270 BLAKE2B dccadd6c3b59b54d732d94a173c40e940f2e7effad5bc8f835bbf56f2b7f3d6b7a80183d1e4826edd566697ffc22ae77b5b75d792493220c0fc04603b3c33f85 SHA512 740727c68113d7a84583a85f4fc3f575aea05067d1aa3b96d5636d3454dba09a4730413c92f49cb7800f26bae15ab02496bd5f91f964b28511e8b8cd3cb116a6
+DIST ros-1.15.7.tar.gz 178451 BLAKE2B 970b736c2ead0ca63e5b9ac5c47ef306ed22e5e6205e7529efd8bc8847f3ac0e73d5cdb55c00827e644e35e3ed49c534e797a8382bdd45451ba1f95a3af9634a SHA512 163a9c677d0213cea85f0d7c82d7a8da7f9423155f19857a8146f29c7b2b3a5ecd800f49d1e9b63b45da33544163acb6f32f7525602f249a30841e140654144a
diff --git a/dev-ros/roscreate/roscreate-1.15.7.ebuild b/dev-ros/roscreate/roscreate-1.15.7.ebuild
new file mode 100644
index 000000000000..5a077c7eb99f
--- /dev/null
+++ b/dev-ros/roscreate/roscreate-1.15.7.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/ros"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Tool that assists in the creation of ROS filesystem resources"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ $(python_gen_cond_dep "dev-python/rospkg[\${PYTHON_USEDEP}]")
+ dev-ros/roslib[${PYTHON_SINGLE_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]") )
+"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}