summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-30 05:46:44 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-30 06:34:39 +0200
commit9d2a229670fde1fa75a4d9028a6a0a30a9579de7 (patch)
tree4330e085c4b4ff0e17a62c586a8e1b378e4c316d
parentdev-python/botocore: Bump to 1.34.94 (diff)
downloadgentoo-9d2a229670fde1fa75a4d9028a6a0a30a9579de7.tar.gz
gentoo-9d2a229670fde1fa75a4d9028a6a0a30a9579de7.tar.bz2
gentoo-9d2a229670fde1fa75a4d9028a6a0a30a9579de7.zip
dev-python/boto3: Bump to 1.34.94
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.34.94.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 34a7f099fbb0..3d7886766396 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -1,3 +1,4 @@
DIST boto3-1.34.84.gh.tar.gz 796658 BLAKE2B 76ad7997f92167f1ed2f14a0a780a1a58b4a853ea132ca38797a228382ad8f55264dfaee99ebf6f8e2bea1848ec918f7b3b0943d0bb6a81b3b858e729b2e74c4 SHA512 55988d7ba69a46b986ed2cffd46b37a154baaa3a73ce62d9ee5b4b8b6f8987f714034ae4f3e59ed9907920216eaf8b18edea4c0fbac99037979b8b30e3b71133
DIST boto3-1.34.88.gh.tar.gz 798806 BLAKE2B 2d3e02f0584e138a75acb68593bd88126641d4617c668062685406d3dc1913556bdf8b821ed3deb6cd9abae40e27a5e03fda35f5824c40a8028346868776de67 SHA512 9bbff2c0589cb2dbc5ca52f224f052c2a924117f16903c2ecad32d486a8b2d31fb9253c827c5819a5203c3ac349d1c990be24a413fab7e0b9c558e1b94ed8e9e
DIST boto3-1.34.93.gh.tar.gz 802078 BLAKE2B 43f19efd6ae42bdb20e8dd79b1735df229ec2f231b5fe05006b26fcd5ddf4796a53fba6011c298fb919ee7b205b4ae3f4b563ad3b5325bdbbdebaeab7be59608 SHA512 4da1d9d7d8648e895f23763e5055a868d05bbfd8eb28d56e716975b3b8349bd1825d703f6fd11c316174004c39e1fca5ddcd8a4ad27a000e1a52f08a36eb4780
+DIST boto3-1.34.94.gh.tar.gz 803022 BLAKE2B fcc522fc68e31fae8086e21740e7ac286f4d2b38caa8a970d7c7851288eec35bd05853410bcfe8bd2bd3a0be52b89386b6c600d9c465ce63470fb0cbe863a345 SHA512 d341e3e3720e4c647e1f5ec578b8f55740f21df4430bbe1ff5e6de11c23126ceb68c956570778af03a0703798468733078c929b75612f6143bd24f929e861fb8
diff --git a/dev-python/boto3/boto3-1.34.94.ebuild b/dev-python/boto3/boto3-1.34.94.ebuild
new file mode 100644
index 000000000000..2c733040b7a3
--- /dev/null
+++ b/dev-python/boto3/boto3-1.34.94.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}