summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-04-22 03:58:39 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-04-22 04:01:50 -0400
commit9d3c743cbbb232e09cc99637455383a9f0e9e873 (patch)
tree90542b5feccec53a10fcebbdf2b4e06156b3034b
parentapp-admin/salt: Keyword 3006.0 riscv, #904721 (diff)
downloadgentoo-9d3c743cbbb232e09cc99637455383a9f0e9e873.tar.gz
gentoo-9d3c743cbbb232e09cc99637455383a9f0e9e873.tar.bz2
gentoo-9d3c743cbbb232e09cc99637455383a9f0e9e873.zip
dev-python/PyQt6-WebEngine: simplify using python_configure_all
Didn't really make a difference before, but now it does, Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--dev-python/PyQt6-WebEngine/PyQt6-WebEngine-6.4.0.ebuild3
-rw-r--r--dev-python/PyQt6-WebEngine/PyQt6-WebEngine-6.5.0.ebuild3
2 files changed, 2 insertions, 4 deletions
diff --git a/dev-python/PyQt6-WebEngine/PyQt6-WebEngine-6.4.0.ebuild b/dev-python/PyQt6-WebEngine/PyQt6-WebEngine-6.4.0.ebuild
index 5ee2a0f1316c..fac59ec70b21 100644
--- a/dev-python/PyQt6-WebEngine/PyQt6-WebEngine-6.4.0.ebuild
+++ b/dev-python/PyQt6-WebEngine/PyQt6-WebEngine-6.4.0.ebuild
@@ -42,8 +42,7 @@ src_prepare() {
PATH=${T}/cxx:${PATH}
}
-src_configure() {
- append-cppflags $(usex debug -{U,D}NDEBUG) # not set by eclass "yet"
+python_configure_all() {
append-cxxflags -std=c++17 # for old gcc / clang that use <17 (bug #892331)
append-cxxflags ${CPPFLAGS} # respect CPPFLAGS
diff --git a/dev-python/PyQt6-WebEngine/PyQt6-WebEngine-6.5.0.ebuild b/dev-python/PyQt6-WebEngine/PyQt6-WebEngine-6.5.0.ebuild
index bd4ef8fb4ddb..9cb83d4974a9 100644
--- a/dev-python/PyQt6-WebEngine/PyQt6-WebEngine-6.5.0.ebuild
+++ b/dev-python/PyQt6-WebEngine/PyQt6-WebEngine-6.5.0.ebuild
@@ -42,8 +42,7 @@ src_prepare() {
PATH=${T}/cxx:${PATH}
}
-src_configure() {
- append-cppflags $(usex debug -{U,D}NDEBUG) # not set by eclass "yet"
+python_configure_all() {
append-cxxflags -std=c++17 # for old gcc / clang that use <17 (bug #892331)
append-cxxflags ${CPPFLAGS} # respect CPPFLAGS