summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2024-03-09 22:16:19 +0000
committerJames Le Cuirot <chewi@gentoo.org>2024-03-09 22:16:19 +0000
commit9d632b7ec4dd911a86d08711082511f9dd2dd49a (patch)
tree2953411af0aa4a8ee183f3ac6fead74d01fbd448
parentsys-devel/binutils: backport LTO fixes to 2.42-r1 (diff)
downloadgentoo-9d632b7ec4dd911a86d08711082511f9dd2dd49a.tar.gz
gentoo-9d632b7ec4dd911a86d08711082511f9dd2dd49a.tar.bz2
gentoo-9d632b7ec4dd911a86d08711082511f9dd2dd49a.zip
media-video/ffmpeg: Patch to fix 4.4.4 with newer glslang
Closes: https://bugs.gentoo.org/926551 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
-rw-r--r--media-video/ffmpeg/ffmpeg-4.4.4-r8.ebuild1
-rw-r--r--media-video/ffmpeg/files/ffmpeg-4.4.4-glslang.patch25
2 files changed, 26 insertions, 0 deletions
diff --git a/media-video/ffmpeg/ffmpeg-4.4.4-r8.ebuild b/media-video/ffmpeg/ffmpeg-4.4.4-r8.ebuild
index 00d867dd517c..748acd8d7375 100644
--- a/media-video/ffmpeg/ffmpeg-4.4.4-r8.ebuild
+++ b/media-video/ffmpeg/ffmpeg-4.4.4-r8.ebuild
@@ -349,6 +349,7 @@ PATCHES=(
"${FILESDIR}"/${P}-fix-build-svt-av1-1.5.0.patch
"${FILESDIR}"/${PN}-5.1.3-binutils-2.41.patch
"${FILESDIR}"/${PN}-4.4.4-opencl-parallel-gmake-fix.patch
+ "${FILESDIR}"/${PN}-4.4.4-glslang.patch
"${WORKDIR}"/${PN}-4.4.4-texinfo.patch
)
diff --git a/media-video/ffmpeg/files/ffmpeg-4.4.4-glslang.patch b/media-video/ffmpeg/files/ffmpeg-4.4.4-glslang.patch
new file mode 100644
index 000000000000..f19bf8e47a42
--- /dev/null
+++ b/media-video/ffmpeg/files/ffmpeg-4.4.4-glslang.patch
@@ -0,0 +1,25 @@
+Bug: https://bugs.gentoo.org/926551
+
+diff -Naur a/configure b/configure
+--- a/configure 2024-03-09 22:07:52.005888104 +0000
++++ b/configure 2024-03-09 22:08:18.634656978 +0000
+@@ -6374,7 +6374,7 @@
+ enabled libfontconfig && require_pkg_config libfontconfig fontconfig "fontconfig/fontconfig.h" FcInit
+ enabled libfreetype && require_pkg_config libfreetype freetype2 "ft2build.h FT_FREETYPE_H" FT_Init_FreeType
+ enabled libfribidi && require_pkg_config libfribidi fribidi fribidi.h fribidi_version_info
+-enabled libglslang && require_cpp libglslang glslang/SPIRV/GlslangToSpv.h "glslang::TIntermediate*" -lglslang -lMachineIndependent -lOSDependent -lHLSL -lOGLCompiler -lGenericCodeGen -lSPVRemapper -lSPIRV -lSPIRV-Tools-opt -lSPIRV-Tools -lpthread -lstdc++
++enabled libglslang && require_cpp libglslang glslang/SPIRV/GlslangToSpv.h "glslang::TIntermediate*" -lglslang -lSPVRemapper -lSPIRV -lSPIRV-Tools-opt -lSPIRV-Tools -lpthread -lstdc++
+ enabled libgme && { check_pkg_config libgme libgme gme/gme.h gme_new_emu ||
+ require libgme gme/gme.h gme_new_emu -lgme -lstdc++; }
+ enabled libgsm && { for gsm_hdr in "gsm.h" "gsm/gsm.h"; do
+diff -Naur a/libavfilter/glslang.cpp b/libavfilter/glslang.cpp
+--- a/libavfilter/glslang.cpp 2023-04-12 19:01:50.000000000 +0100
++++ b/libavfilter/glslang.cpp 2024-03-09 22:08:36.210161783 +0000
+@@ -17,6 +17,7 @@
+ */
+
+ #include <pthread.h>
++#include <cassert>
+
+ extern "C" {
+ #include "libavutil/mem.h"