summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-13 02:07:04 +0100
committerSam James <sam@gentoo.org>2022-04-13 02:07:04 +0100
commit9d83df6e9a78345ba66bb2716669791a09e1810e (patch)
treeb8c99584613454cedc268c802d85a483a7e4a4ff
parentsci-libs/lapack: fix IncorrectCopyright (diff)
downloadgentoo-9d83df6e9a78345ba66bb2716669791a09e1810e.tar.gz
gentoo-9d83df6e9a78345ba66bb2716669791a09e1810e.tar.bz2
gentoo-9d83df6e9a78345ba66bb2716669791a09e1810e.zip
net-analyzer/nfdump: add 1.6.24
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-analyzer/nfdump/Manifest1
-rw-r--r--net-analyzer/nfdump/nfdump-1.6.24.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/net-analyzer/nfdump/Manifest b/net-analyzer/nfdump/Manifest
index 32325041d89f..00d4e7ade1ac 100644
--- a/net-analyzer/nfdump/Manifest
+++ b/net-analyzer/nfdump/Manifest
@@ -1 +1,2 @@
DIST nfdump-1.6.23.tar.gz 568879 BLAKE2B ca844f87e02fb3761d5b470cac11beada9873b0c7e3e9ca7ccc7899d57f0cfd96329698ac84467a55d683e83ce16c2b114a571845c7cb6069addcdd5d4a43903 SHA512 e3f79af69a170985fcbd1757fab86e90840d040cf7a6214c7f9851ed59695d3844a15269904c3ba989b6b6ed2ddf29fd19a493165d3037e49aa2bb69b831f168
+DIST nfdump-1.6.24.tar.gz 647945 BLAKE2B 6f054c7ccdbc6c5052d1c4655509414b9acc7de320152e932dd31d6cc9eb915b73efa29e42a212ea206c4619c9e025bfd751762808fd8136c38d4edb72f4fabf SHA512 b1e092663ce245247af721565139eb0a264918747e6c0695c59f0b70a99049e92d79674d75c248f60aa832949d7e13027887cc825e393fce7dc5571771bce1d7
diff --git a/net-analyzer/nfdump/nfdump-1.6.24.ebuild b/net-analyzer/nfdump/nfdump-1.6.24.ebuild
new file mode 100644
index 000000000000..abe553c93b29
--- /dev/null
+++ b/net-analyzer/nfdump/nfdump-1.6.24.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="A set of tools to collect and process netflow data"
+HOMEPAGE="https://github.com/phaag/nfdump"
+SRC_URI="https://github.com/phaag/nfdump/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc jnat ftconv nfpcapd nfprofile nftrack nsel readpcap sflow"
+
+REQUIRED_USE="?? ( jnat nsel )"
+
+RDEPEND="
+ app-arch/bzip2
+ sys-libs/zlib
+ ftconv? ( net-analyzer/flow-tools )
+ nfpcapd? ( net-libs/libpcap )
+ nfprofile? ( net-analyzer/rrdtool )
+ nftrack? ( net-analyzer/rrdtool )
+ readpcap? ( net-libs/libpcap )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/flex
+ virtual/yacc
+ doc? (
+ app-doc/doxygen
+ media-gfx/graphviz
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.6.19-libft.patch
+)
+
+DOCS=( AUTHORS ChangeLog README.md )
+
+src_prepare() {
+ default
+
+ eautoreconf
+
+ if use doc; then
+ doxygen -u doc/Doxyfile.in || die
+ fi
+}
+
+src_configure() {
+ tc-export CC
+
+ # --without-ftconf is not handled well, bug #322201
+ econf \
+ $(use ftconv && echo "--enable-ftconv --with-ftpath=/usr") \
+ $(use nfpcapd && echo --enable-nfpcapd) \
+ $(use nfprofile && echo --enable-nfprofile) \
+ $(use nftrack && echo --enable-nftrack) \
+ $(use_enable debug devel) \
+ $(use_enable jnat) \
+ $(use_enable nsel) \
+ $(use_enable readpcap) \
+ $(use_enable sflow)
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+
+ newinitd "${FILESDIR}"/nfcapd.initd nfcapd
+ newconfd "${FILESDIR}"/nfcapd.confd nfcapd
+
+ if use doc; then
+ dodoc -r doc/html
+ fi
+}