summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-23 08:21:50 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-23 08:53:01 +0200
commit9daf4a5aae44851436ee09f05c17bdc5154e72ab (patch)
tree07e5bdf3be7eb93f3802fe63db4447123ecceb81
parentdev-python/multiprocess: Enable py3.12 (diff)
downloadgentoo-9daf4a5aae44851436ee09f05c17bdc5154e72ab.tar.gz
gentoo-9daf4a5aae44851436ee09f05c17bdc5154e72ab.tar.bz2
gentoo-9daf4a5aae44851436ee09f05c17bdc5154e72ab.zip
dev-python/django-auth-ldap: Bump to 4.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/django-auth-ldap/Manifest1
-rw-r--r--dev-python/django-auth-ldap/django-auth-ldap-4.4.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/django-auth-ldap/Manifest b/dev-python/django-auth-ldap/Manifest
index 7f1b97901740..950f4a934be6 100644
--- a/dev-python/django-auth-ldap/Manifest
+++ b/dev-python/django-auth-ldap/Manifest
@@ -1,2 +1,3 @@
DIST django-auth-ldap-4.2.0.gh.tar.gz 49572 BLAKE2B e33241897a2ad6ec3cefe4d8bc6cfea322f478b3db7c2e8b7726b55f9e030f10ae25ee049842322f11939523df06af81a57122d4d3c8115416a253672c43dd39 SHA512 a37500c850b3cf49d6bc7324d721c05279570972547ebd69521033e4cd6aa340948829edb3ae94d3280a8142a42d88ce77f85bf4a8c9f32753a860881b3c5d90
DIST django-auth-ldap-4.3.0.tar.gz 53474 BLAKE2B b3f74739fd195b7a2e2cc785fa6493feaef8917b8473fad386da1569a158f13d7c765a32bd0d83ba02d20d7b50e845d3a5cda8b5fbbf5524576c62b84690705b SHA512 6a7826af60087a25970c6ae96b9bce40212cdfbe5e2d2ee0d903ff53f02edcd361eb56a0c5db9406e8525ee6be86e18d5c13db7e4ae6f2dd5d0adc7c593a8117
+DIST django-auth-ldap-4.4.0.tar.gz 53117 BLAKE2B 46ae8f9788c3ed12d8b3576b4335390d3bc902a3627dd5af9028c2bd49dc64eef2f31995bcf51a6d20c55400bbd3dd5f4882ecc01e8d92564a6664db743809ca SHA512 d01f40f64e0d6cd47a0efaaf3b5e6a30a399b0a3b9a6b4c6f683a8237b84076294821970bbb265f66e06b0fbec58417287188e5f09631b21f204137d003ecfd7
diff --git a/dev-python/django-auth-ldap/django-auth-ldap-4.4.0.ebuild b/dev-python/django-auth-ldap/django-auth-ldap-4.4.0.ebuild
new file mode 100644
index 000000000000..9e1094ca449c
--- /dev/null
+++ b/dev-python/django-auth-ldap/django-auth-ldap-4.4.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Django LDAP authentication backend"
+HOMEPAGE="
+ https://github.com/django-auth-ldap/django-auth-ldap/
+ https://pypi.org/project/django-auth-ldap/
+"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+LICENSE="BSD-2"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/django-2.2[${PYTHON_USEDEP}]
+ >=dev-python/python-ldap-3.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_impl_dep sqlite)
+ net-nds/openldap[-minimal]
+ )
+"
+
+distutils_enable_sphinx docs --no-autodoc
+
+python_test() {
+ # for slapd and slapdtest
+ local -x SBIN=/usr/sbin:/usr/$(get_libdir)/openldap
+ "${EPYTHON}" -m django test -v 2 --settings tests.settings ||
+ die "Tests failed with ${EPYTHON}"
+}