summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2023-10-02 13:29:13 +0200
committerFlorian Schmaus <flow@gentoo.org>2023-10-02 13:36:49 +0200
commit9dd02118b6f0149e41c814e40876e45481112148 (patch)
treea250d71cf3d8d9c9fe25379560f12bd35a645fc0
parentdev-python/pytz_deprecation_shim: treeclean (diff)
downloadgentoo-9dd02118b6f0149e41c814e40876e45481112148.tar.gz
gentoo-9dd02118b6f0149e41c814e40876e45481112148.tar.bz2
gentoo-9dd02118b6f0149e41c814e40876e45481112148.zip
sci-biology/express: treeclean
Closes: https://bugs.gentoo.org/912828 Signed-off-by: Florian Schmaus <flow@gentoo.org>
-rw-r--r--profiles/package.mask6
-rw-r--r--sci-biology/express/Manifest1
-rw-r--r--sci-biology/express/express-1.5.1.ebuild38
-rw-r--r--sci-biology/express/files/express-1.5.1-buildsystem.patch55
-rw-r--r--sci-biology/express/files/express-1.5.1-gcc6.patch19
-rw-r--r--sci-biology/express/metadata.xml8
6 files changed, 0 insertions, 127 deletions
diff --git a/profiles/package.mask b/profiles/package.mask
index e616cfe60492..647fbfd7c812 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -260,12 +260,6 @@ dev-ruby/twitter:7
# Removal on 2023-09-28. Bug #830477, bug #913004.
net-im/ricochet
-# Sam James <sam@gentoo.org> (2023-08-29)
-# Fails to build with new protobuf. Deprecated by upstream which recommend
-# sci-biology/kallisto as a replacement.
-# Removal on 2023-09-28. Bug #912828.
-sci-biology/express
-
# Sam James <sam@gentoo.org> (2023-08-04)
# Stricter behavior which causes some packages to fail, see bug #911721.
=dev-util/pkgconf-2.0.0
diff --git a/sci-biology/express/Manifest b/sci-biology/express/Manifest
deleted file mode 100644
index 9c2cc4ebf499..000000000000
--- a/sci-biology/express/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST express-1.5.1-src.tgz 931166 BLAKE2B 5eb185e4b001f26f0dd32885b256b9fa48c89f546d67d7f8472cade69dde25375a5fc8efed5f01b615d63b641b674f7034a13f9483eb7967a6fd784a55c8878e SHA512 59cf6511a879311247c65334285ea056d571d4fd950aa6243041fa10075ff0d1ddd2afbcfe12e5f7f3e7cdd22fe37fd7f6b43ed4a8eb28d7a33d72366dc549ee
diff --git a/sci-biology/express/express-1.5.1.ebuild b/sci-biology/express/express-1.5.1.ebuild
deleted file mode 100644
index 9511236b69f6..000000000000
--- a/sci-biology/express/express-1.5.1.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-DESCRIPTION="Streaming RNA-Seq Analysis"
-HOMEPAGE="https://pachterlab.github.io/eXpress/"
-SRC_URI="https://pachterlab.github.io/eXpress/downloads/${P}/${P}-src.tgz"
-
-LICENSE="Artistic"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="
- dev-libs/boost:=
- dev-libs/protobuf
- dev-util/google-perftools
- sci-biology/bamtools
- sys-libs/zlib
-"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${P}-src"
-
-PATCHES=(
- "${FILESDIR}"/${P}-buildsystem.patch
- "${FILESDIR}"/${P}-gcc6.patch
-)
-
-src_configure() {
- local mycmakeargs=(
- -DBAMTOOLS_INCLUDE="${EPREFIX}/usr/include/bamtools"
- )
- cmake_src_configure
-}
diff --git a/sci-biology/express/files/express-1.5.1-buildsystem.patch b/sci-biology/express/files/express-1.5.1-buildsystem.patch
deleted file mode 100644
index fca5feadd111..000000000000
--- a/sci-biology/express/files/express-1.5.1-buildsystem.patch
+++ /dev/null
@@ -1,55 +0,0 @@
- CMakeLists.txt | 8 +++-----
- src/CMakeLists.txt | 4 ++--
- 2 files changed, 5 insertions(+), 7 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index c768e28..65d5633 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -6,14 +6,12 @@ set(${PROJECT_NAME}_VERSION_MAJOR 1)
- set(${PROJECT_NAME}_VERSION_MINOR 5)
- set(${PROJECT_NAME}_VERSION_PATCH 1)
-
--set(CMAKE_CXX_FLAGS "-Wall")
--
- set(CMAKE_CXX_FLAGS_DEBUG "-g ${CMAKE_CXX_FLAGS}")
- set(CMAKE_CXX_FLAGS_RHDEBINFO "-O3 -g ${CMAKE_CXX_FLAGS}")
- set(CMAKE_CXX_FLAGS_MINSIZEREL "-Os ${CMAKE_CXX_FLAGS}")
-
- set(CMAKE_BUILD_TYPE Release)
--set(Boost_USE_STATIC_LIBS ON)
-+set(Boost_USE_STATIC_LIBS OFF)
-
- find_package(Boost 1.39
- COMPONENTS
-@@ -33,10 +31,10 @@ endif(GPERFTOOLS_TCMALLOC_LIB)
-
- find_package(Protobuf)
- if (PROTOBUF_FOUND)
-- include_directories(${Boost_INCLUDE_DIRS} ${PROTOBUF_INCLUDE_DIR} "${CMAKE_CURRENT_SOURCE_DIR}/bamtools/include")
-+ include_directories(${Boost_INCLUDE_DIRS} ${PROTOBUF_INCLUDE_DIR} ${BAMTOOLS_INCLUDE})
- set(PROTO_INT 1)
- else (PROTOBUF_FOUND)
-- include_directories(${Boost_INCLUDE_DIRS} "${CMAKE_CURRENT_SOURCE_DIR}/bamtools/include")
-+ include_directories(${Boost_INCLUDE_DIRS} ${BAMTOOLS_INCLUDE})
- set(PROTO_INT 0)
- endif(PROTOBUF_FOUND)
-
-diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
-index 1cc0c01..8929d1f 100644
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -16,11 +16,11 @@ endif (GPERFTOOLS_TCMALLOC)
- if(WIN32)
- set(LIBRARIES ${LIBRARIES} "${CMAKE_CURRENT_SOURCE_DIR}/../bamtools/lib/libbamtools.lib" "${CMAKE_CURRENT_SOURCE_DIR}/../win_build/zlibd.lib")
- else(WIN32)
-- set(LIBRARIES ${LIBRARIES} "${CMAKE_CURRENT_SOURCE_DIR}/../bamtools/lib/libbamtools.a" "pthread")
-+ set(LIBRARIES ${LIBRARIES} "bamtools" "pthread")
- endif(WIN32)
-
- if (PROTOBUF_FOUND)
-- set(LIBRARIES ${LIBRARIES} "libprotobuf.a")
-+ set(LIBRARIES ${LIBRARIES} "protobuf")
- endif(PROTOBUF_FOUND)
-
- target_link_libraries(express ${LIBRARIES})
diff --git a/sci-biology/express/files/express-1.5.1-gcc6.patch b/sci-biology/express/files/express-1.5.1-gcc6.patch
deleted file mode 100644
index 8a608b97b056..000000000000
--- a/sci-biology/express/files/express-1.5.1-gcc6.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-Bug: https://bugs.gentoo.org/610692
-
---- a/src/targets.cpp
-+++ b/src/targets.cpp
-@@ -113,12 +113,12 @@
-
- double ll = LOG_1;
- double tot_mass = mass(with_pseudo);
-- double tot_eff_len = cached_effective_length(lib.bias_table);
-+ double tot_eff_len = cached_effective_length(static_cast<bool>(lib.bias_table));
- if (neighbors) {
- foreach (const Target* neighbor, *neighbors) {
- tot_mass = log_add(tot_mass, neighbor->mass(with_pseudo));
- tot_eff_len = log_add(tot_eff_len,
-- neighbor->cached_effective_length(lib.bias_table));
-+ neighbor->cached_effective_length(static_cast<bool>(lib.bias_table)));
- }
- }
- ll += tot_mass - tot_eff_len;
diff --git a/sci-biology/express/metadata.xml b/sci-biology/express/metadata.xml
deleted file mode 100644
index ccdff086e20b..000000000000
--- a/sci-biology/express/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>sci-biology@gentoo.org</email>
- <name>Gentoo Biology Project</name>
- </maintainer>
-</pkgmetadata>