summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-01-17 10:09:06 +0100
committerHans de Graaff <graaff@gentoo.org>2016-01-17 10:10:10 +0100
commit9dd6f212f27476c54102e2d146fbe12a49b53fe3 (patch)
treee798fef9fe9893ca3a8115eb7b67e8301a48ce95
parentdev-ruby/actionmailer: add ruby22 (diff)
downloadgentoo-9dd6f212.tar.gz
gentoo-9dd6f212.tar.bz2
gentoo-9dd6f212.zip
dev-ruby/activerecord: add ruby22
Package-Manager: portage-2.2.26
-rw-r--r--dev-ruby/activerecord/activerecord-4.2.5.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-ruby/activerecord/activerecord-4.2.5.ebuild b/dev-ruby/activerecord/activerecord-4.2.5.ebuild
index 9da4868da977..a347afbd897d 100644
--- a/dev-ruby/activerecord/activerecord-4.2.5.ebuild
+++ b/dev-ruby/activerecord/activerecord-4.2.5.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-USE_RUBY="ruby20 ruby21"
+USE_RUBY="ruby20 ruby21 ruby22"
# this is not null so that the dependencies will actually be filled
RUBY_FAKEGEM_TASK_TEST="test"
@@ -47,7 +47,7 @@ all_ruby_prepare() {
# Remove items from the common Gemfile that we don't need for this
# test run. This also requires handling some gemspecs.
rm ../Gemfile.lock || die
- sed -i -e "/\(uglifier\|system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|'mysql'\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|redcarpet\|minitest\|sprockets\|stackprof\)/ s:^:#:" \
+ sed -i -e "/\(uglifier\|system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|execjs\|'mysql'\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|redcarpet\|minitest\|sprockets\|stackprof\)/ s:^:#:" \
-e '/:job/,/end/ s:^:#:' \
-e '/group :doc/,/^end/ s:^:#:' ../Gemfile || die
sed -i -e '/rack-ssl/d' -e 's/~> 3.4/>= 3.4/' ../railties/railties.gemspec || die