summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-18 22:46:48 +0000
committerSam James <sam@gentoo.org>2022-01-18 22:51:49 +0000
commit9df05022406405f6a9bae202e012de503d416757 (patch)
treef053a6e5f9540ae6bb7d2354286dabce07279023
parentdev-python/rfc3986-validator: Switch to PEP517 build (diff)
downloadgentoo-9df05022.tar.gz
gentoo-9df05022.tar.bz2
gentoo-9df05022.zip
net-wireless/gnome-bluetooth: fix build with meson 0.61
Closes: https://bugs.gentoo.org/831430 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-wireless/gnome-bluetooth/files/gnome-bluetooth-3.34.5-meson-0.61-build.patch19
-rw-r--r--net-wireless/gnome-bluetooth/gnome-bluetooth-3.34.5.ebuild6
2 files changed, 24 insertions, 1 deletions
diff --git a/net-wireless/gnome-bluetooth/files/gnome-bluetooth-3.34.5-meson-0.61-build.patch b/net-wireless/gnome-bluetooth/files/gnome-bluetooth-3.34.5-meson-0.61-build.patch
new file mode 100644
index 000000000000..2e6c912b3d5d
--- /dev/null
+++ b/net-wireless/gnome-bluetooth/files/gnome-bluetooth-3.34.5-meson-0.61-build.patch
@@ -0,0 +1,19 @@
+https://gitlab.gnome.org/GNOME/gnome-bluetooth/-/commit/755fd758f866d3a3f7ca482942beee749f13a91e
+https://bugs.gentoo.org/831430
+
+From: Bastien Nocera <hadess@hadess.net>
+Date: Fri, 7 Jan 2022 12:51:22 +0100
+Subject: [PATCH] build: Fix build for newer versions of meson
+
+sendto/meson.build:24:5: ERROR: Function does not take positional arguments.
+--- a/sendto/meson.build
++++ b/sendto/meson.build
+@@ -22,7 +22,6 @@ desktop_in = configure_file(
+ )
+
+ i18n.merge_file (
+- desktop,
+ type: 'desktop',
+ input: desktop_in,
+ output: desktop,
+GitLab
diff --git a/net-wireless/gnome-bluetooth/gnome-bluetooth-3.34.5.ebuild b/net-wireless/gnome-bluetooth/gnome-bluetooth-3.34.5.ebuild
index a1ab5dbfcbec..e6e7a267cbfa 100644
--- a/net-wireless/gnome-bluetooth/gnome-bluetooth-3.34.5.ebuild
+++ b/net-wireless/gnome-bluetooth/gnome-bluetooth-3.34.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -41,6 +41,10 @@ BDEPEND="
)
"
+PATCHES=(
+ "${FILESDIR}"/${P}-meson-0.61-build.patch
+)
+
python_check_deps() {
if use test; then
has_version -b "dev-python/python-dbusmock[${PYTHON_USEDEP}]" &&