summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-05-11 13:37:43 -0400
committerBrian Evans <grknight@gentoo.org>2018-05-11 13:37:43 -0400
commit9df0525a7b466902edb13d8a259bca797f30c4b0 (patch)
tree0b76a3f2b846614b4a6336bc8c387387cd03a5e9
parentsys-fs/zfs-auto-snapshot: new package (diff)
downloadgentoo-9df0525a.tar.gz
gentoo-9df0525a.tar.bz2
gentoo-9df0525a.zip
app-text/groonga: Version bump for 8.0.2
Bug: https://bugs.gentoo.org/655172 Package-Manager: Portage-2.3.36, Repoman-2.3.9
-rw-r--r--app-text/groonga/Manifest1
-rw-r--r--app-text/groonga/groonga-8.0.2.ebuild102
-rw-r--r--app-text/groonga/metadata.xml2
3 files changed, 105 insertions, 0 deletions
diff --git a/app-text/groonga/Manifest b/app-text/groonga/Manifest
index e87180557c3f..2c60f422ecf0 100644
--- a/app-text/groonga/Manifest
+++ b/app-text/groonga/Manifest
@@ -1,3 +1,4 @@
DIST groonga-5.0.3.tar.gz 12421501 BLAKE2B 22b695fca6c4d0859b7a9ed5b1bc46be48493faa513524634662b0d520d1159bc70b4dc34d82ba83e5c57681f01f01dbe47d5a957f110eab2db65cf8eefe878f SHA512 c4595054f46e150b0b95b3d1fb6a18098c93471ee0cdeefc54d266a710db57d6b68a6aceb1a61ede5ebb4e1b5518be64b9b96809bd85634b61c84c1923cbf158
DIST groonga-5.0.9.tar.gz 12851324 BLAKE2B a58084146e5e8fbcbc56f9737a3623b4385123cc449fb63b136f3f312d31d5574620831a4fa6e759381950ee6aa035e4d6a4c277c26c7d8ebb1e99fe5bf02e75 SHA512 6e89be8894737616cfcbd0edd92c94a25fb8a2f9c97bd0aab10c2d628664aa328384d6b953516fe96cec5b58fd229c42262caad4785ca9574c759d6d7177fba6
DIST groonga-6.1.2.tar.gz 14028916 BLAKE2B c05a1a5a73bce63655eb588b3021570d22a0016837810c12813bb4f208bf9b114fc514a8887e4f756fb0ec27ad2c991eea026bf57391e9234e49ee084656d26c SHA512 cd2dd667608fac856b36a824c5ea285da937cc11b6d4e5ad2f84581f6fbc714b4bb381515ec7b467ddccfad77c77c080000def653d9cdd8725c0f512c7b83f20
+DIST groonga-8.0.2.tar.gz 15095427 BLAKE2B fa83034a434edaa35dede08cb042e48f15e1e2edd78a121f9341f53f53a5eef863d02e2ea6384428c720c4ff9acf1083504046c8c11a1ea8d7bfc4b541db66b5 SHA512 bc5590604054c4adfbc80b39c7cf367e8a989c47d80c37c48feffb9a427b4b4e360289f3d732f6affa7d26a1c8559f23bda1c70b6736a06601398fce9a53acf1
diff --git a/app-text/groonga/groonga-8.0.2.ebuild b/app-text/groonga/groonga-8.0.2.ebuild
new file mode 100644
index 000000000000..ebc194e460c1
--- /dev/null
+++ b/app-text/groonga/groonga-8.0.2.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit libtool user
+
+DESCRIPTION="An Embeddable Fulltext Search Engine"
+HOMEPAGE="https://groonga.org/"
+SRC_URI="https://packages.groonga.org/source/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="abort benchmark debug doc dynamic-malloc-change +exact-alloc-count examples fmalloc futex jemalloc libedit libevent lzo +mecab msgpack +nfkc sphinx static-libs uyield zeromq zlib zstd"
+
+RDEPEND=">=dev-libs/onigmo-6.1.1:0=
+ benchmark? ( >=dev-libs/glib-2.8 )
+ jemalloc? ( dev-libs/jemalloc:0= )
+ libedit? ( >=dev-libs/libedit-3 )
+ libevent? ( dev-libs/libevent:0= )
+ lzo? ( dev-libs/lzo )
+ mecab? ( >=app-text/mecab-0.80 )
+ msgpack? ( dev-libs/msgpack )
+ sphinx? ( >=dev-python/sphinx-1.0.1 )
+ zeromq? ( net-libs/zeromq:0= )
+ zlib? ( sys-libs/zlib:0= )
+ zstd? ( app-arch/zstd:0= )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sphinx? ( dev-python/sphinx )"
+
+REQUIRED_USE=" abort? ( dynamic-malloc-change ) fmalloc? ( dynamic-malloc-change ) sphinx? ( doc )"
+
+pkg_setup() {
+ enewgroup groonga
+ enewuser groonga -1 -1 -1 groonga
+}
+
+src_prepare() {
+ default_src_prepare
+ elibtoolize
+}
+
+src_configure() {
+ # httpd is a bundled copy of nginx; disabled for security reasons
+ # prce only is used with httpd
+ # Apache arrow, kytea and libstemmer are not available in Gentoo repo
+ # ruby is only used for an http test
+ local econfopts=(
+ --disable-groonga-httpd
+ --without-pcre
+ --without-kytea
+ --without-libstemmer
+ --disable-arrow
+ --with-log-path="${EROOT%/}/var/log/${PN}.log"
+ --docdir="${EROOT%/}/usr/share/doc/${P}"
+ --without-ruby
+ --with-shared-onigmo
+ --with-onigmo=system
+ $(use_enable abort)
+ $(use_enable benchmark)
+ $(use_enable debug memory-debug)
+ $(use_enable doc document)
+ $(use_enable dynamic-malloc-change)
+ $(use_enable exact-alloc-count)
+ $(use_enable fmalloc)
+ $(use_enable futex)
+ $(use_with jemalloc)
+ $(use_enable libedit)
+ $(use_with libevent)
+ $(use_with lzo)
+ $(use_with mecab)
+ $(use_enable msgpack message-pack)
+ $(use_with msgpack message-pack "${EROOT%/}/usr")
+ $(use_enable nfkc)
+ $(use_with sphinx sphinx-build)
+ $(use_enable static-libs static)
+ $(use_enable uyield)
+ $(use_enable zeromq)
+ $(use_with zlib)
+ $(use_with zstd)
+ )
+ econf "${econfopts[@]}"
+}
+
+src_install() {
+ local DOCS=( README.md )
+ default
+
+ find "${D}" -name '*.la' -delete || die
+
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+
+ keepdir /var/{log,lib}/${PN}
+ fowners groonga:groonga /var/{log,lib}/${PN}
+
+ use examples || rm -r "${D%/}/usr/share/${PN}" || die
+ # Extra init script
+ rm -r "${D%/}/usr/sbin/groonga-httpd-restart" || die
+}
diff --git a/app-text/groonga/metadata.xml b/app-text/groonga/metadata.xml
index 937c8f296172..3bf71ce09a19 100644
--- a/app-text/groonga/metadata.xml
+++ b/app-text/groonga/metadata.xml
@@ -11,6 +11,7 @@
<flag name="exact-alloc-count">Atomic counting for memory alloc count</flag>
<flag name="fmalloc">Make memory allocation failed in specified condition for debug</flag>
<flag name="futex">Use futex</flag>
+ <flag name="jemalloc">Enable <pkg>dev-libs/jemalloc</pkg> for memory management</flag>
<flag name="libevent">Enable <pkg>dev-libs/libevent</pkg> used for suggestion</flag>
<flag name="mecab">Use <pkg>app-text/mecab</pkg> for morphological analysis</flag>
<flag name="msgpack">Enable <pkg>dev-libs/msgpack</pkg> used for suggestion</flag>
@@ -18,5 +19,6 @@
<flag name="sphinx">Enable document generation by <pkg>app-misc/sphinx</pkg></flag>
<flag name="uyield">Build for detecting race conditions</flag>
<flag name="zeromq">Enable <pkg>net-libs/zeromq</pkg> used for suggestion</flag>
+ <flag name="zstd">Utilize <pkg>app-arch/zstd</pkg> for Zstandard compression</flag>
</use>
</pkgmetadata>