summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-06 22:00:44 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-06 22:14:14 +0200
commit9df1bc51d536d8257ec42cf2649b2b7e8511e891 (patch)
tree12f322f09d67cf6079c18681f56ad85446012951
parentsys-devel/kgcc64: add 11.2.0 (diff)
downloadgentoo-9df1bc51.tar.gz
gentoo-9df1bc51.tar.bz2
gentoo-9df1bc51.zip
dev-python/flexmock: add 0.11.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/flexmock/Manifest1
-rw-r--r--dev-python/flexmock/flexmock-0.11.2.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/flexmock/Manifest b/dev-python/flexmock/Manifest
index 4f8612d4df04..4f416d984ee8 100644
--- a/dev-python/flexmock/Manifest
+++ b/dev-python/flexmock/Manifest
@@ -1 +1,2 @@
DIST flexmock-0.11.1.tar.gz 48331 BLAKE2B b4a670530050098706133d531f162516163e8bed5fe867277d8d729c3afbd21747d53f17e8cd0f2f087550137c864aa8ac912cb404103426e3fdb17e98d79645 SHA512 6b5ce669e29dc24313e94b0c0c24d75e25c99343c33d787987c6707532598fb0d28df751148a4f7183d4bbdb54822c07d88ded394358545fe8d822564e1408e6
+DIST flexmock-0.11.2.tar.gz 51330 BLAKE2B 3ebeea60c19a9234a362117009610802f10c68c55885ae9dd72c16b19af19fdfbf18634bbc56a80efb0c985f0c339bab234304088dc482b0ccf937c1d7c2fd0f SHA512 208876131155dd0febc9e6aad7a6e98082fccf52573758ac9280f9f767d81ece7af425c901a4a094b3eb56bd711219a55dcfc0d7747f9060b3ad6630c37e6618
diff --git a/dev-python/flexmock/flexmock-0.11.2.ebuild b/dev-python/flexmock/flexmock-0.11.2.ebuild
new file mode 100644
index 000000000000..db8b214775f5
--- /dev/null
+++ b/dev-python/flexmock/flexmock-0.11.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Testing library to create mocks, stubs and fakes"
+HOMEPAGE="https://flexmock.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ tests/test_teamcity.py
+ tests/test_testtools.py
+ tests/test_unittest.py
+ )
+ epytest -p no:flaky
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc -r docs
+}