summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2020-06-01 15:12:39 +0200
committerAlfredo Tupone <tupone@gentoo.org>2020-06-01 15:12:39 +0200
commit9dfbf7a90b70366380cc9daf70d0a90a37078d2c (patch)
treef0c585ec14883a111753798ab2c3fe68db9e9f84
parentmedia-sound/beets: sync 1.4.9 ebuild with -9999 (diff)
downloadgentoo-9dfbf7a90b70366380cc9daf70d0a90a37078d2c.tar.gz
gentoo-9dfbf7a90b70366380cc9daf70d0a90a37078d2c.tar.bz2
gentoo-9dfbf7a90b70366380cc9daf70d0a90a37078d2c.zip
dev-tcltk/tclpython: do not use colon in sed
Closes: https://bugs.gentoo.org/726610 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
-rw-r--r--dev-tcltk/tclpython/files/tclpython-5.0-gentoo.patch4
-rw-r--r--dev-tcltk/tclpython/tclpython-5.0.ebuild11
2 files changed, 4 insertions, 11 deletions
diff --git a/dev-tcltk/tclpython/files/tclpython-5.0-gentoo.patch b/dev-tcltk/tclpython/files/tclpython-5.0-gentoo.patch
index 965fe3d8d722..c77339982fd6 100644
--- a/dev-tcltk/tclpython/files/tclpython-5.0-gentoo.patch
+++ b/dev-tcltk/tclpython/files/tclpython-5.0-gentoo.patch
@@ -5,12 +5,12 @@
TCL_VERSION=$(shell echo 'puts $\$$tcl_version' | tclsh)
-CFLAGS:= -O2 -Wall -fPIC -DUSE_TCL_STUBS
-+CFLAGS:= @CFLAGS@ -fPIC -DUSE_TCL_STUBS
++CFLAGS:= $(MYCFLAGS) -fPIC -DUSE_TCL_STUBS
CFLAGS+= $(shell $(PYTHON_CONFIG) --includes)
CFLAGS+= -I/usr/include/tcl$(TCL_VERSION)
CFLAGS+= -DTCLPYTHON_VERSION=$(PKG_VERSION)
-LDFLAGS:= -shared -s
-+LDFLAGS:= @LDFLAGS@ -shared
++LDFLAGS:= $(MYLDFLAGS) -shared
LDFLAGS+= $(shell $(PYTHON_CONFIG) --libs)
LDFLAGS+= -ltclstub$(TCL_VERSION)
diff --git a/dev-tcltk/tclpython/tclpython-5.0.ebuild b/dev-tcltk/tclpython/tclpython-5.0.ebuild
index 90df040a57ae..2603ce545fdb 100644
--- a/dev-tcltk/tclpython/tclpython-5.0.ebuild
+++ b/dev-tcltk/tclpython/tclpython-5.0.ebuild
@@ -24,16 +24,9 @@ RDEPEND="${DEPEND}"
PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
-src_prepare() {
- default
- sed -i \
- -e "s:@CFLAGS@:${CFLAGS}:g" \
- -e "s:@LDFLAGS@:${LDFLAGS}:g" \
- Makefile || die
-}
-
src_compile() {
- emake PKG_NAME=tclpython3 CC=$(tc-getCC)
+ emake PKG_NAME=tclpython3 CC=$(tc-getCC) \
+ MYCFLAGS="${CFLAGS}" MYLDFLAGS="${LDFLAGS}"
}
src_test() {