summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-12-29 15:24:37 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-12-29 15:28:56 -0500
commit9e5a5e76bb743ac23db130f86f9569821ca5258b (patch)
tree12060594665a3089249f6a91259bae4561c007da
parentapp-emulation/ruffle: drop vulnerable 0_p20221212 (diff)
downloadgentoo-9e5a5e76.tar.gz
gentoo-9e5a5e76.tar.bz2
gentoo-9e5a5e76.zip
games-emulation/pcsx2: add 1.7.3818 (qt6-only, masked)
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--games-emulation/pcsx2/Manifest1
-rw-r--r--games-emulation/pcsx2/pcsx2-1.7.3818.ebuild244
2 files changed, 245 insertions, 0 deletions
diff --git a/games-emulation/pcsx2/Manifest b/games-emulation/pcsx2/Manifest
index 6866d173ca7c..b99b2a8df7f3 100644
--- a/games-emulation/pcsx2/Manifest
+++ b/games-emulation/pcsx2/Manifest
@@ -1,5 +1,6 @@
DIST pcsx2-1.6.0.tar.gz 17963332 BLAKE2B d1370fd089e1f8716a3365b9f499fef9418c4a9464e701cf0dbac8296cf59a2c6fc9b85ed680c514d8128da7b5c47aa8a067d48cac9eb0482ef2ba5f9234e60e SHA512 0a3e01a25384719fc72b636a1e9cf1cd966d0c978c1c3adfb46d6b3f76f43a25f90ef63d27a1d8092cdf444c5dc7560ce807ca81908d11ade9715e7eaaad6253
DIST pcsx2-1.7.3738.tar.gz 15935061 BLAKE2B 51e113e2148c94861a3d6baab8de5b8ed613cdb6e3aa3574445f0a66e628dffb3bf26a6a3b54e0be65d71a90088fe6e79f65055d54e580d46ad4db1dadbb8a66 SHA512 7da8dd46cd065fefc4c2bb4ab76b8fc2bf9769dba78f47759c59b2a21e62cf0e5d53e9f800e16bf09238bf156cd7fa63a4ca75a47f41b78df9512a701536c789
+DIST pcsx2-1.7.3818.tar.gz 9165699 BLAKE2B adfff6d4c1fc74e6fab052a03ec42b519f3cd9898c5719482e8b9bbdb9d224caf9a4bb95aef3e4f3993944e877e9a4f79e48d74e427c59c70c1480238ee0146b SHA512 4a3bdd4d4b18fa06fd942ed93ff2bc9dd5e332bdf59ba5fc54b185e6e58957d4f5da74e4371cfb6964696a2ed08df61fdc1d3738ce9b781a39c7c08f10e9c99e
DIST pcsx2-fast_float-32d21dcecb.tar.gz 76108 BLAKE2B 7a4e8e3bb67387c03912e5f7035ba3fab1aeaa119b36ebdeb14c45069b3270270a8b87de2774ec325d8ed2ef0604a3d3762432d42f1e026a213990ac39341e10 SHA512 2cbdc5b05ab7c19e20b4e34959b90d1fa866d4ba239ec0a4c434cd33bddfb1cb6f1da467b0a525f5a4887c9b1860e975fe074aca0d9e211f0fc7bc6402d3601e
DIST pcsx2-glslang-c9706bdda0.tar.gz 3433325 BLAKE2B f2449a6c8b05e47367164d09036ae2302f0f28ec83c2e2f401426f52fbd4edf55f717f01eea2cbfe7554e1004b89ffdebc34ec21a95809fcbc719f69e65e8487 SHA512 5ff0902e95592525b2671788bf27717c85d0876b31e96374eff5128f9bf7caf93bb636e4d5e1916a5d641715a780172308403bd49305d9a07cf66358d7e6407c
DIST pcsx2-rcheevos-31f8788fe0.tar.gz 522855 BLAKE2B 39533199f6b1e0cd821d817ff57101ccad0049f5144b856f1e796c83d81fcee059caa944a0fb14a0e95e51da43a6bc003cd6891ca85c2b9a959b4c42d8ca0a84 SHA512 cb0e8bf4d222f3ef127d20a9d6738e6c39d7cff48a0da8fe19fcc43669433b7e53cc63ab332e8f0cd935b6a33eddef3e741ee862a82bd4f29a02df1d9a42ec45
diff --git a/games-emulation/pcsx2/pcsx2-1.7.3818.ebuild b/games-emulation/pcsx2/pcsx2-1.7.3818.ebuild
new file mode 100644
index 000000000000..eebe34cc10de
--- /dev/null
+++ b/games-emulation/pcsx2/pcsx2-1.7.3818.ebuild
@@ -0,0 +1,244 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake desktop fcaps flag-o-matic
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/PCSX2/pcsx2.git"
+else
+ HASH_FASTFLOAT=32d21dcecb404514f94fb58660b8029a4673c2c1
+ HASH_RCHEEVOS=31f8788fe0e694e99db7ce138d45a655c556fa96
+ HASH_GLSLANG=c9706bdda0ac22b9856f1aa8261e5b9e15cd20c5
+ HASH_VULKAN=9f4c61a31435a7a90a314fc68aeb386c92a09c0f
+ SRC_URI="
+ https://github.com/PCSX2/pcsx2/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/fastfloat/fast_float/archive/${HASH_FASTFLOAT}.tar.gz
+ -> ${PN}-fast_float-${HASH_FASTFLOAT::10}.tar.gz
+ https://github.com/RetroAchievements/rcheevos/archive/${HASH_RCHEEVOS}.tar.gz
+ -> ${PN}-rcheevos-${HASH_RCHEEVOS::10}.tar.gz
+ vulkan? (
+ https://github.com/KhronosGroup/glslang/archive/${HASH_GLSLANG}.tar.gz
+ -> ${PN}-glslang-${HASH_GLSLANG::10}.tar.gz
+ https://github.com/KhronosGroup/Vulkan-Headers/archive/${HASH_VULKAN}.tar.gz
+ -> ${PN}-vulkan-headers-${HASH_VULKAN::10}.tar.gz
+ )"
+ KEYWORDS="-* ~amd64"
+fi
+
+DESCRIPTION="PlayStation 2 emulator"
+HOMEPAGE="https://pcsx2.net/"
+
+LICENSE="
+ GPL-3+ Apache-2.0 BSD BSD-2 BSD-4 Boost-1.0 CC0-1.0 GPL-2+
+ ISC LGPL-2.1+ LGPL-3+ MIT OFL-1.1 ZLIB public-domain"
+SLOT="0"
+IUSE="alsa cpu_flags_x86_sse4_1 jack pulseaudio sndio test vulkan wayland"
+REQUIRED_USE="cpu_flags_x86_sse4_1" # dies at runtime if no support
+RESTRICT="!test? ( test )"
+
+# dlopen: ffmpeg, qtsvg, vulkan-loader, wayland
+RDEPEND="
+ app-arch/xz-utils
+ app-arch/zstd:=
+ dev-cpp/rapidyaml:=
+ dev-libs/libaio
+ dev-libs/libchdr
+ dev-libs/libfmt:=
+ dev-libs/libzip:=[zstd]
+ dev-qt/qtbase:6[gui,network,widgets]
+ dev-qt/qtsvg:6
+ media-libs/libglvnd
+ media-libs/libpng:=
+ >=media-libs/libsdl2-2.0.22[haptic,joystick]
+ media-libs/libsoundtouch:=
+ media-video/ffmpeg:=
+ net-libs/libpcap
+ net-misc/curl
+ sys-libs/zlib:=
+ virtual/libudev:=
+ x11-libs/libXrandr
+ alsa? ( media-libs/alsa-lib )
+ jack? ( virtual/jack )
+ pulseaudio? ( media-libs/libpulse )
+ sndio? ( media-sound/sndio:= )
+ vulkan? ( media-libs/vulkan-loader )
+ wayland? ( dev-libs/wayland )"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+ test? ( dev-cpp/gtest )"
+BDEPEND="
+ dev-lang/perl
+ dev-qt/qttools[linguist]"
+
+FILECAPS=(
+ -m 0755 "CAP_NET_RAW+eip CAP_NET_ADMIN+eip" usr/bin/pcsx2
+)
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.7.0-crcs.patch
+ "${FILESDIR}"/${PN}-1.7.3351-unbundle.patch
+ "${FILESDIR}"/${PN}-1.7.3468-cubeb-automagic.patch
+ "${FILESDIR}"/${PN}-1.7.3773-lto.patch
+)
+
+src_unpack() {
+ if [[ ${PV} == 9999 ]]; then
+ local EGIT_SUBMODULES=(
+ # has no build system and is not really setup for unbundling
+ 3rdparty/rcheevos/rcheevos
+
+ # system rapidyaml is still used, but this uses another part
+ # of the source directly (fast_float) and so allow the submodule
+ # https://github.com/PCSX2/pcsx2/commit/af646e449
+ 3rdparty/rapidyaml/rapidyaml
+ 3rdparty/rapidyaml/rapidyaml/extern/c4core
+ 3rdparty/rapidyaml/rapidyaml/ext/c4core/src/c4/ext/fast_float
+
+ # uses glslang's StandAlone/ResourceLimits.h unavailable with
+ # system's (also keep bundled vulkan-headers to be in sync)
+ $(usev vulkan '
+ 3rdparty/glslang/glslang
+ 3rdparty/vulkan-headers')
+ )
+
+ git-r3_src_unpack
+ else
+ default
+
+ mkdir -p "${S}"/3rdparty/rapidyaml/rapidyaml/ext/c4core/src/c4/ext || die
+ mv fast_float-${HASH_FASTFLOAT} \
+ "${S}"/3rdparty/rapidyaml/rapidyaml/ext/c4core/src/c4/ext/fast_float || die
+
+ rmdir "${S}"/3rdparty/rcheevos/rcheevos || die
+ mv rcheevos-${HASH_RCHEEVOS} "${S}"/3rdparty/rcheevos/rcheevos || die
+
+ if use vulkan; then
+ rmdir "${S}"/3rdparty/{glslang/glslang,vulkan-headers} || die
+ mv glslang-${HASH_GLSLANG} "${S}"/3rdparty/glslang/glslang || die
+ mv Vulkan-Headers-${HASH_VULKAN} "${S}"/3rdparty/vulkan-headers || die
+ fi
+ fi
+}
+
+src_prepare() {
+ # could depend on >=0.5 for unconditional, but rather not force it yet
+ # https://github.com/PCSX2/pcsx2/issues/7623
+ has_version '>=dev-cpp/rapidyaml-0.5' &&
+ eapply "${FILESDIR}"/${PN}-1.7.3803-rapidyaml-0.5.0.patch
+
+ cmake_src_prepare
+
+ sed -e "/EmuFolders::AppRoot =/s|=.*|= \"${EPREFIX}/usr/share/${PN}\";|" \
+ -i pcsx2/Frontend/CommonHost.cpp || die
+
+ if [[ ${PV} != 9999 ]]; then
+ sed -e '/set(PCSX2_GIT_TAG "")/s/""/"v'${PV}'"/' \
+ -i cmake/Pcsx2Utils.cmake || die
+
+ # delete all 3rdparty/* except known-used ones in non-live
+ local keep=(
+ # TODO?: rapidjson and xbyak are packaged and could be unbundlable
+ # w/ patch, and discord-rpc be optional w/ dependency on rapidjson
+ cpuinfo cubeb demangler discord-rpc glad imgui include jpgd lzma
+ rapidjson rapidyaml rcheevos simpleini xbyak zydis
+ $(usev vulkan 'glslang vulkan-headers')
+ )
+ find 3rdparty -mindepth 1 -maxdepth 1 -type d \
+ -not \( -false ${keep[*]/#/-o -name } \) -exec rm -r {} + || die
+ fi
+}
+
+src_configure() {
+ # for bundled glslang (bug #858374)
+ use vulkan && append-flags -fno-strict-aliasing
+
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=no
+ -DDISABLE_BUILD_DATE=yes
+ -DDISABLE_SETCAP=yes
+ -DENABLE_TESTS=$(usex test)
+ -DUSE_SYSTEM_LIBS=yes
+ -DUSE_VTUNE=no
+ -DUSE_VULKAN=$(usex vulkan)
+ -DWAYLAND_API=$(usex wayland)
+ -DX11_API=yes # fails if X libs are missing even if disabled
+ -DXDG_STD=yes
+
+ # sse4.1 is the bare minimum required, -m is required at build time
+ # (see PCSX2Base.h) and it dies if no support at runtime (AppInit.cpp)
+ # https://github.com/PCSX2/pcsx2/pull/4329
+ -DARCH_FLAG=-msse4.1
+
+ # bundled cubeb flags, see media-libs/cubeb and cubeb-automagic.patch
+ -DCHECK_ALSA=$(usex alsa)
+ -DCHECK_JACK=$(usex jack)
+ -DCHECK_PULSE=$(usex pulseaudio)
+ -DCHECK_SNDIO=$(usex sndio)
+ -DLAZY_LOAD_LIBS=no
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ cmake_build unittests
+}
+
+src_install() {
+ # package mode was removed turning cmake_src_install into a noop
+ newbin "${BUILD_DIR}"/pcsx2-qt/pcsx2-qt ${PN}
+
+ insinto /usr/share/${PN}
+ doins -r "${BUILD_DIR}"/pcsx2-qt/resources
+
+ dodoc README.md bin/docs/{Debugger.pdf,GameIndex.pdf,PCSX2_FAQ.pdf,debugger.txt}
+ newman bin/docs/PCSX2.1 ${PN}.1
+
+ newicon linux_various/PCSX2.xpm ${PN}.xpm
+ make_desktop_entry ${PN} ${PN^^}
+}
+
+pkg_postinst() {
+ fcaps_pkg_postinst
+
+ local replacing=
+ if [[ ${REPLACING_VERSIONS##* } ]]; then
+ if ver_test ${REPLACING_VERSIONS##* } -lt 1.6.1; then
+ replacing=old
+ elif ver_test ${REPLACING_VERSIONS##* } -lt 1.7.3773; then
+ replacing=wx
+ else
+ replacing=any
+ fi
+ fi
+
+ if [[ ${replacing} == old ]]; then
+ elog
+ elog ">=${PN}-1.7 has received several changes since <=${PN}-1.6.0, notably"
+ elog "it is now a 64bit build using Qt6. Just-in-case it is recommended to"
+ elog "backup your configs, save states, and memory cards before use."
+ elog "The executable was also renamed from 'PCSX2' to 'pcsx2'."
+ fi
+
+ if [[ ${replacing} == @(|old) && ${PV} != 9999 ]]; then
+ elog
+ elog "${PN}-1.7.x is a development branch using a nightly release model"
+ elog "(new 'release' every 1-2 days). Stable 1.6.0 is getting old and lacks"
+ elog "many notable features (e.g. native 64bit builds). Given it may be a long"
+ elog "time before there is a new stable, Gentoo will carry and update 1.7.x"
+ elog "roughly every months."
+ elog
+ elog "Please report an issue if feel a picked nightly release needs to be"
+ elog "updated ahead of time or masked (notably for handling regressions)."
+ fi
+
+ if [[ ${replacing} == wx ]]; then
+ ewarn
+ ewarn "Note that wxGTK support been dropped upstream since >=${PN}-1.7.3773,"
+ ewarn "and so USE=qt6 is gone and Qt6 is now always used."
+ fi
+}