summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-27 18:01:10 +0100
committerSam James <sam@gentoo.org>2022-08-27 18:01:10 +0100
commit9e6bd0b440cda7abd4452fb87013a8e6819ef0a3 (patch)
tree69843e0ed8f7a8b0efad9aba5179b1aa1e5973cc
parentdev-libs/libdynd: fix EbuildReservedName (diff)
downloadgentoo-9e6bd0b4.tar.gz
gentoo-9e6bd0b4.tar.bz2
gentoo-9e6bd0b4.zip
sys-fs/static-dev: fix EbuildReservedName
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-fs/static-dev/static-dev-0.1-r2.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/sys-fs/static-dev/static-dev-0.1-r2.ebuild b/sys-fs/static-dev/static-dev-0.1-r2.ebuild
index ca46b76ab1e5..c915e4e6bc45 100644
--- a/sys-fs/static-dev/static-dev-0.1-r2.ebuild
+++ b/sys-fs/static-dev/static-dev-0.1-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -13,7 +13,7 @@ KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86"
RDEPEND="sys-apps/makedev"
pkg_pretend() {
- abort() {
+ bailout() {
eerror "We have detected that you currently use udev or devfs or devtmpfs"
eerror "and this ebuild cannot install to the same mount-point."
die "Cannot install on udev/devfs tmpfs."
@@ -26,13 +26,13 @@ pkg_pretend() {
# We want to not clobber udev (tmpfs) or older devfs setups.
if [[ -d ${ROOT}/dev/.udev || -c ${ROOT}/dev/.devfs ]] ; then
- abort
+ bailout
fi
# We also want to not clobber newer devtmpfs setups.
if [[ -z ${ROOT} ]] && \
! awk '$2 == "/dev" && $3 == "devtmpfs" { exit 1 }' /proc/mounts ; then
- abort
+ bailout
fi
}