summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2022-02-23 10:20:03 +0100
committerJakov Smolić <jsmolic@gentoo.org>2022-02-23 10:40:00 +0100
commit9e73effa51918eb614a66f4fa7670fded98a0d66 (patch)
tree587cbd7670707605b1242742a25451a172b63d77
parentdev-java/leiningen-bin: Drop 2.8.0 and 2.8.1 (diff)
downloadgentoo-9e73effa51918eb614a66f4fa7670fded98a0d66.tar.gz
gentoo-9e73effa51918eb614a66f4fa7670fded98a0d66.tar.bz2
gentoo-9e73effa51918eb614a66f4fa7670fded98a0d66.zip
sys-devel/prelink: treeclean
Closes: https://bugs.gentoo.org/579388 Closes: https://bugs.gentoo.org/726062 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
-rw-r--r--profiles/package.mask1
-rw-r--r--sys-devel/prelink/Manifest2
-rw-r--r--sys-devel/prelink/files/prelink-20130503-libiberty-md5.patch61
-rw-r--r--sys-devel/prelink/files/prelink-20130503-prelink-conf.patch39
-rw-r--r--sys-devel/prelink/files/prelink.confd43
-rw-r--r--sys-devel/prelink/files/prelink.cron61
-rw-r--r--sys-devel/prelink/files/prelink.service6
-rw-r--r--sys-devel/prelink/files/prelink.timer10
-rw-r--r--sys-devel/prelink/metadata.xml8
-rw-r--r--sys-devel/prelink/prelink-20151030-r1.ebuild72
-rw-r--r--sys-devel/prelink/prelink-99999999.ebuild71
11 files changed, 0 insertions, 374 deletions
diff --git a/profiles/package.mask b/profiles/package.mask
index 1c4a8c944217..0b1cdb8a034a 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -180,7 +180,6 @@ dev-java/felix-gogo-runtime
# already somewhat broken for a while...
# hmaccalc hard-depends on it (?).
# Removal in 30 days.
-sys-devel/prelink
app-crypt/hmaccalc
# James Beddek <telans@posteo.de> (2022-01-19)
diff --git a/sys-devel/prelink/Manifest b/sys-devel/prelink/Manifest
deleted file mode 100644
index 139e3eee1b83..000000000000
--- a/sys-devel/prelink/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST prelink-cross-20151030.tar.bz2 701337 BLAKE2B 4875b936254a03afd0eeb1ee81ee99f97a2d654b7c0379acb80ea3763412f3e892c366a9962ff3e1493bba9c83a8a140e79a1d5fb08b269a08ef596d63fd1d32 SHA512 75edd8617b95ae5bd3bfc968732ee142c968855c97c5b2b93784d3476a9724e0fd9a4eb7af681a5356616a4f023e24d5c5a2e75fb57e2a25b142cc901d9bfcaf
-DIST prelink.pdf 474129 BLAKE2B 6df5d4998d0822a8032c5dcd1103d7eafa8e9002f2cbfa8fa821131d7c804d2998100dc98d310ae3ae601137b6815435ecdd2684d547a8d25025984c20c06318 SHA512 86b7163fcf6f43d1764183b3dfc30aad8de99ce198b2721af276c81fc361e9f5fd8f4aea1e8e0c653f0566e8346dff4b4ba72909359167aa92c094f5561d2e1e
diff --git a/sys-devel/prelink/files/prelink-20130503-libiberty-md5.patch b/sys-devel/prelink/files/prelink-20130503-libiberty-md5.patch
deleted file mode 100644
index 5a9fffb838f9..000000000000
--- a/sys-devel/prelink/files/prelink-20130503-libiberty-md5.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-From 8eeb9da6d017761037bf757780ea544dfeabbad8 Mon Sep 17 00:00:00 2001
-From: Mike Frysinger <vapier@gentoo.org>
-Date: Tue, 31 Jul 2012 09:02:35 +0000
-Subject: [PATCH] libiberty/md5: fix strict alias warnings
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Current libiberty md5 code triggers these warnings with gcc-4.7.1 for me:
-
-libiberty/md5.c: In function ‘md5_finish_ctx’:
-libiberty/md5.c:117:3: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
-libiberty/md5.c:118:3: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
-
-The change below fixes things for me. The optimized output (-O2) is the same
-before/after my change on x86_64-linux. I imagine it'll be the same for most
-targets. It seems simpler than using a union on the md5_ctx buffer since these
-are the only two locations in the code where this occurs.
----
- libiberty/ChangeLog | 5 +++++
- libiberty/md5.c | 12 ++++++++----
- 2 files changed, 13 insertions(+), 4 deletions(-)
-
-2012-07-31 Mike Frysinger <vapier@gentoo.org>
-
- * md5.c (md5_finish_ctx): Declare swap_bytes. Assign SWAP() output
- to swap_bytes, and then call memcpy to move it to ctx->buffer.
-
-diff --git a/libiberty/md5.c b/libiberty/md5.c
-index 0db8fc8..8cc0cb5 100644
---- a/src/md5.c
-+++ b/src/md5.c
-@@ -103,6 +103,7 @@ md5_finish_ctx (struct md5_ctx *ctx, void *resbuf)
- {
- /* Take yet unprocessed bytes into account. */
- md5_uint32 bytes = ctx->buflen;
-+ md5_uint32 swap_bytes;
- size_t pad;
-
- /* Now count remaining bytes. */
-@@ -113,10 +114,13 @@ md5_finish_ctx (struct md5_ctx *ctx, void *resbuf)
- pad = bytes >= 56 ? 64 + 56 - bytes : 56 - bytes;
- memcpy (&ctx->buffer[bytes], fillbuf, pad);
-
-- /* Put the 64-bit file length in *bits* at the end of the buffer. */
-- *(md5_uint32 *) &ctx->buffer[bytes + pad] = SWAP (ctx->total[0] << 3);
-- *(md5_uint32 *) &ctx->buffer[bytes + pad + 4] = SWAP ((ctx->total[1] << 3) |
-- (ctx->total[0] >> 29));
-+ /* Put the 64-bit file length in *bits* at the end of the buffer.
-+ Use memcpy to avoid aliasing problems. On most systems, this
-+ will be optimized away to the same code. */
-+ swap_bytes = SWAP (ctx->total[0] << 3);
-+ memcpy (&ctx->buffer[bytes + pad], &swap_bytes, sizeof (swap_bytes));
-+ swap_bytes = SWAP ((ctx->total[1] << 3) | (ctx->total[0] >> 29));
-+ memcpy (&ctx->buffer[bytes + pad + 4], &swap_bytes, sizeof (swap_bytes));
-
- /* Process last bytes. */
- md5_process_block (ctx->buffer, bytes + pad + 8, ctx);
---
-1.8.2.1
-
diff --git a/sys-devel/prelink/files/prelink-20130503-prelink-conf.patch b/sys-devel/prelink/files/prelink-20130503-prelink-conf.patch
deleted file mode 100644
index 9233a4114827..000000000000
--- a/sys-devel/prelink/files/prelink-20130503-prelink-conf.patch
+++ /dev/null
@@ -1,39 +0,0 @@
---- a/doc/prelink.conf
-+++ b/doc/prelink.conf
-@@ -5,6 +5,7 @@
- # If a directory name is prefixed with `-h ', symbolic links in a
- # directory hierarchy are followed.
- # Directories or files with `-b ' prefix will be blacklisted.
-+-c /etc/prelink.conf.d/*.conf
- -b *.la
- -b *.png
- -b *.py
-@@ -16,8 +16,11 @@
- -b *.a
- -b *.js
- -b /lib/modules
---b /usr/lib/locale
---b /usr/X11R6/lib{,64}/X11/xfig
-+-b /usr/lib{,x32,32,64}/locale
-+-b /usr/lib{,x32,32,64}/wine
-+-b /usr/lib{,x32,32,64}/valgrind
-+-b /usr/X11R6/lib{,x32,32,64}/X11/xfig
-+-b /usr/src
- -l /bin
- -l /usr/bin
- -l /sbin
-@@ -27,9 +30,9 @@
- -l /usr/games
- -l /usr/libexec
- -l /var/ftp/bin
---l /lib{,64}
---l /usr/lib{,64}
---l /usr/X11R6/lib{,64}
---l /usr/kerberos/lib{,64}
-+-l /lib{,x32,32,64}
-+-l /usr/lib{,x32,32,64}
-+-l /usr/X11R6/lib{,x32,32,64}
-+-l /usr/kerberos/lib{,x32,32,64}
- -l /usr/X11R6/LessTif
---l /var/ftp/lib{,64}
-+-l /var/ftp/lib{,x32,32,64}
diff --git a/sys-devel/prelink/files/prelink.confd b/sys-devel/prelink/files/prelink.confd
deleted file mode 100644
index 6b89b8c1f1fd..000000000000
--- a/sys-devel/prelink/files/prelink.confd
+++ /dev/null
@@ -1,43 +0,0 @@
-# For an in depth prelinking guide, please see:
-# http://www.gentoo.org/doc/en/prelink-howto.xml
-
-# Control prelinking behavior in the cronjob.
-# yes - automatically prelink the system
-# no - automatically un-prelink the system
-# "" - do nothing at all (user manages)
-# (if you change this from yes to no prelink -ua
-# will be run next night to undo prelinking)
-PRELINKING=""
-
-# Options to pass to prelink
-# -m Try to conserve virtual memory by allowing overlapping
-# assigned virtual memory slots for libraries which
-# never appear together in one binary
-# -R Randomize virtual memory slot assignments for libraries.
-# This makes it slightly harder for various buffer overflow
-# attacks, since library addresses will be different on each
-# host using -R.
-PRELINK_OPTS=-mR
-
-# How often should full prelink be run (in days)
-# Normally, prelink will be run in quick mode, every
-# $PRELINK_FULL_TIME_INTERVAL days it will be run
-# in normal mode. Comment it out if it should be run
-# in normal mode always.
-PRELINK_FULL_TIME_INTERVAL=14
-
-# How often should prelink run (in days) even if
-# no packages have been upgraded via portage.
-# If $PRELINK_FULL_TIME_INTERVAL days have not elapsed
-# yet since last normal mode prelinking, last
-# quick mode prelinking happened less than
-# $PRELINK_NOEMER_CHECK_INTERVAL days ago
-# and no packages have been upgraded by portage
-# since last quick mode prelinking, prelink
-# will not do anything.
-# Change to
-# PRELINK_NOEMER_CHECK_INTERVAL=0
-# if you want to disable the portage database timestamp
-# check (especially if you don't use portage
-# exclusively to upgrade system libraries and/or binaries).
-PRELINK_NOEMER_CHECK_INTERVAL=7
diff --git a/sys-devel/prelink/files/prelink.cron b/sys-devel/prelink/files/prelink.cron
deleted file mode 100644
index 067fc2ea97a2..000000000000
--- a/sys-devel/prelink/files/prelink.cron
+++ /dev/null
@@ -1,61 +0,0 @@
-#!/bin/sh
-
-. /etc/conf.d/prelink
-log="/var/log/prelink.log"
-
-case $PRELINKING in
- yes|no);;
- *) exit 0;;
-esac
-
-ionice -c3 -p $$ >/dev/null 2>&1
-renice +19 -p $$ >/dev/null 2>&1
-
-if [ "$PRELINKING" != yes ]; then
- sed -ri '/^[[:space:]]*#?[[:space:]]*KDE_IS_PRELINKED=/s:.*:#KDE_IS_PRELINKED=1:' /etc/env.d/*kde* 2>/dev/null
- if [ -f /etc/prelink.cache ]; then
- echo /usr/sbin/prelink -uav > ${log}
- /usr/sbin/prelink -uav >> ${log} 2>&1 \
- || echo Prelink failed with return value $? >> ${log}
- rm -f /etc/prelink.cache
- # Restart init if needed
- [ -n "$(find `ldd /sbin/init | awk 'NF == 4 { print $3 }'` /sbin/init -ctime -1 2>/dev/null )" ] && /sbin/telinit u
- fi
- exit 0
-fi
-
-sed -ri '/^[[:space:]]*#?[[:space:]]*KDE_IS_PRELINKED=/s:.*:KDE_IS_PRELINKED=1:' /etc/env.d/*kde* 2>/dev/null
-
-if [ ! -f /etc/prelink.cache -o -f /var/lib/misc/prelink.force ] \
- || grep -q '^prelink-ELF0.[0-2]' /etc/prelink.cache; then
- # If cache does not exist or is from older prelink versions or
- # if we were asked to explicitely, force full prelinking
- rm -f /etc/prelink.cache /var/lib/misc/prelink.force
- PRELINK_OPTS="$PRELINK_OPTS -f"
- date > /var/lib/misc/prelink.full
- cp -a /var/lib/misc/prelink.full /var/lib/misc/prelink.quick
-elif [ -n "$PRELINK_FULL_TIME_INTERVAL" \
- -a "`find /var/lib/misc/prelink.full -mtime -${PRELINK_FULL_TIME_INTERVAL} 2>/dev/null`" \
- = /var/lib/misc/prelink.full ]; then
- # If no more than PRELINK_NOEMER_CHECK_INTERVAL days elapsed from last prelink
- # (be it full or quick) and no packages have been upgraded via rpm since then,
- # don't do anything.
- [ "`find /var/lib/misc/prelink.quick -mtime -${PRELINK_NOEMER_CHECK_INTERVAL:-7} 2>/dev/null`" \
- -a -f /var/cache/edb/counter \
- -a /var/cache/edb/counter -ot /var/lib/misc/prelink.quick ] && exit 0
- date > /var/lib/misc/prelink.quick
- # If prelink without -q has been run in the last
- # PRELINK_FULL_TIME_INTERVAL days, just use quick mode
- PRELINK_OPTS="$PRELINK_OPTS -q"
-else
- date > /var/lib/misc/prelink.full
- cp -a /var/lib/misc/prelink.full /var/lib/misc/prelink.quick
-fi
-
-echo /usr/sbin/prelink -av $PRELINK_OPTS > ${log}
-/usr/sbin/prelink -av $PRELINK_OPTS >> ${log} 2>&1 \
- || echo Prelink failed with return value $? >> ${log}
-# Restart init if needed (and if exists)
-[ -n "$(find `ldd /sbin/init 2>/dev/null | awk 'NF == 4 { print $3 }'` /sbin/init -ctime -1 2>/dev/null )" ] && /sbin/telinit u
-
-exit 0
diff --git a/sys-devel/prelink/files/prelink.service b/sys-devel/prelink/files/prelink.service
deleted file mode 100644
index dcdbf813a0e4..000000000000
--- a/sys-devel/prelink/files/prelink.service
+++ /dev/null
@@ -1,6 +0,0 @@
-[Unit]
-Description=Perform system-wide prelinking
-
-[Service]
-Type=oneshot
-ExecStart=/etc/cron.daily/prelink
diff --git a/sys-devel/prelink/files/prelink.timer b/sys-devel/prelink/files/prelink.timer
deleted file mode 100644
index 5d58d437158e..000000000000
--- a/sys-devel/prelink/files/prelink.timer
+++ /dev/null
@@ -1,10 +0,0 @@
-[Unit]
-Description=Daily system-wide prelinking
-
-[Timer]
-OnCalendar=daily
-AccuracySec=12h
-Persistent=true
-
-[Install]
-WantedBy=timers.target
diff --git a/sys-devel/prelink/metadata.xml b/sys-devel/prelink/metadata.xml
deleted file mode 100644
index 5a1e1dee65db..000000000000
--- a/sys-devel/prelink/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>toolchain@gentoo.org</email>
- <name>Gentoo Toolchain Project</name>
-</maintainer>
-</pkgmetadata>
diff --git a/sys-devel/prelink/prelink-20151030-r1.ebuild b/sys-devel/prelink/prelink-20151030-r1.ebuild
deleted file mode 100644
index 17c39b3993ef..000000000000
--- a/sys-devel/prelink/prelink-20151030-r1.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 2002-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-MY_PN="${PN}-cross"
-MY_P="${MY_PN}-${PV}"
-
-inherit autotools flag-o-matic systemd
-
-DESCRIPTION="Modifies ELFs to avoid runtime symbol resolutions resulting in faster load times"
-HOMEPAGE="https://git.yoctoproject.org/cgit/cgit.cgi/prelink-cross/ https://people.redhat.com/jakub/prelink"
-SRC_URI="https://git.yoctoproject.org/cgit/cgit.cgi/${MY_PN}/snapshot/${MY_P}.tar.bz2
- doc? ( https://people.redhat.com/jakub/prelink/prelink.pdf )"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ppc ppc64 x86"
-IUSE="doc selinux"
-
-RDEPEND=">=dev-libs/elfutils-0.100
- selinux? ( sys-libs/libselinux )
- !dev-libs/libelf"
-DEPEND="${RDEPEND}
- sys-libs/binutils-libs"
-
-S=${WORKDIR}/${MY_P}
-
-PATCHES=(
- "${FILESDIR}"/${PN}-20130503-prelink-conf.patch
- "${FILESDIR}"/${PN}-20130503-libiberty-md5.patch
-)
-
-# tests were fixed only in development version after 20151030
-RESTRICT=test
-
-src_prepare() {
- default
-
- sed -i -e '/^CC=/s: : -Wl,--disable-new-dtags :' testsuite/functions.sh #100147
-
- has_version 'dev-libs/elfutils[threads]' && append-ldflags -pthread
-
- eautoreconf
-}
-
-src_configure() {
- econf $(use_enable selinux)
-}
-
-src_install() {
- default
-
- use doc && dodoc "${DISTDIR}"/prelink.pdf
-
- insinto /etc
- doins doc/prelink.conf
-
- exeinto /etc/cron.daily
- newexe "${FILESDIR}"/prelink.cron prelink
- newconfd "${FILESDIR}"/prelink.confd prelink
- systemd_dounit "${FILESDIR}"/prelink.{service,timer}
-}
-
-pkg_postinst() {
- if [ -z "${REPLACING_VERSIONS}" ] ; then
- elog "You may wish to read the Gentoo Linux Prelink Guide, which can be"
- elog "found online at:"
- elog " https://wiki.gentoo.org/wiki/Prelink"
- elog "Please edit /etc/conf.d/prelink to enable and configure prelink"
- fi
-}
diff --git a/sys-devel/prelink/prelink-99999999.ebuild b/sys-devel/prelink/prelink-99999999.ebuild
deleted file mode 100644
index dfe534db6194..000000000000
--- a/sys-devel/prelink/prelink-99999999.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 2002-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-MY_PN="${PN}-cross"
-MY_P="${MY_PN}-${PV}"
-
-inherit autotools flag-o-matic git-r3 systemd
-
-DESCRIPTION="Modifies ELFs to avoid runtime symbol resolutions resulting in faster load times"
-HOMEPAGE="https://git.yoctoproject.org/cgit/cgit.cgi/prelink-cross/ https://people.redhat.com/jakub/prelink"
-EGIT_REPO_URI="https://git.yoctoproject.org/git/prelink-cross"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="doc selinux"
-
-RDEPEND=">=dev-libs/elfutils-0.100
- selinux? ( sys-libs/libselinux )
- !dev-libs/libelf"
-DEPEND="${RDEPEND}
- sys-libs/binutils-libs"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-20130503-prelink-conf.patch
- "${FILESDIR}"/${PN}-20130503-libiberty-md5.patch
-)
-
-src_prepare() {
- default
-
- sed -i -e '/^CC=/s: : -Wl,--disable-new-dtags :' testsuite/functions.sh #100147
-
- has_version 'dev-libs/elfutils[threads]' && append-ldflags -pthread
-
- eautoreconf
-}
-
-src_configure() {
- econf $(use_enable selinux)
-}
-
-src_test() {
- # prelink tests check exact library lists.
- # LD_PRELOADed libraries break the assumption.
- SANDBOX_ON=0 LD_PRELOAD= emake check VERBOSE=1
-}
-
-src_install() {
- default
-
- use doc && dodoc doc/prelink.pdf
-
- insinto /etc
- doins doc/prelink.conf
-
- exeinto /etc/cron.daily
- newexe "${FILESDIR}"/prelink.cron prelink
- newconfd "${FILESDIR}"/prelink.confd prelink
- systemd_dounit "${FILESDIR}"/prelink.{service,timer}
-}
-
-pkg_postinst() {
- if [ -z "${REPLACING_VERSIONS}" ] ; then
- elog "You may wish to read the Gentoo Linux Prelink Guide, which can be"
- elog "found online at:"
- elog " https://wiki.gentoo.org/wiki/Prelink"
- elog "Please edit /etc/conf.d/prelink to enable and configure prelink"
- fi
-}