summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-02-28 14:41:39 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-02-28 16:43:46 +0100
commit9e981ce8057dadd09934c9827df24d327f4ff62c (patch)
treec232e3b4ffc6bc28dcd2ccbfc35e8fea54ffe513
parentkde-plasma/systemsettings: 5.27.2 version bump (diff)
downloadgentoo-9e981ce8057dadd09934c9827df24d327f4ff62c.tar.gz
gentoo-9e981ce8057dadd09934c9827df24d327f4ff62c.tar.bz2
gentoo-9e981ce8057dadd09934c9827df24d327f4ff62c.zip
kde-plasma/xdg-desktop-portal-kde: 5.27.2 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-plasma/xdg-desktop-portal-kde/Manifest1
-rw-r--r--kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-5.27.2.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/kde-plasma/xdg-desktop-portal-kde/Manifest b/kde-plasma/xdg-desktop-portal-kde/Manifest
index ff89126a8099..5a8d7ee1a306 100644
--- a/kde-plasma/xdg-desktop-portal-kde/Manifest
+++ b/kde-plasma/xdg-desktop-portal-kde/Manifest
@@ -1,2 +1,3 @@
DIST xdg-desktop-portal-kde-5.26.5.tar.xz 110164 BLAKE2B 0eff7ac5fadce31831b9479fc812aede2f540917b186da0c71f9e85a4277923fd39e68ff4acb488772905cc296644b7a5e2f8c0fa12ef7e5cd7d5f7ccaf843d8 SHA512 d79ea70b476e08e0ff554e7a9b261abca21b07a177a576cf4c6e8d36b08dc8f48f5ccebf25d72b293439fafce53ae29e77b6289fce1ccccfabe69a5d21f6389c
DIST xdg-desktop-portal-kde-5.27.1.tar.xz 134372 BLAKE2B bca018865d570f48917df6c5a1a73e8014925178318d65cc4bd85d358e3d8af3cc6de1250d78b9817e84a3cef6ace33962b44081b96e3b57ed0a70c0ebbfdcbe SHA512 92e16476301f1438d1ea367506a9526cf3b5114141965e1614493f8b7f6a866fc32f8761bdf6ca4c162f2823faaada5e18a2111d8f6d2a0dca13fae1e43aebfb
+DIST xdg-desktop-portal-kde-5.27.2.tar.xz 137396 BLAKE2B c2c0f13ce5615d4d6892cd087a8b44403f24d33e654f39cc50bb8488f6c46c3514b07db37036998dccd8dc6fe19833c5d3097184f7c2168132ac5dce4be160e5 SHA512 46c56ae5f5cc7c3c265eb7b58d2e658f93bea9374ea56d9605f47875ceba91da610b4b6a152772e9f2fcd98fc3d38b2dbe04e8b62efa1b70a5ea28aebe6da853
diff --git a/kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-5.27.2.ebuild b/kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-5.27.2.ebuild
new file mode 100644
index 000000000000..73acc3e14c3d
--- /dev/null
+++ b/kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-5.27.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="forceoptional"
+KFMIN=5.102.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.7
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Backend implementation for xdg-desktop-portal that is using Qt/KDE Frameworks"
+
+LICENSE="LGPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+# dev-qt/qtgui: QtXkbCommonSupport is provided by either IUSE libinput or X
+COMMON_DEPEND="
+ >=dev-libs/wayland-1.15
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ || (
+ >=dev-qt/qtgui-${QTMIN}:5[libinput]
+ >=dev-qt/qtgui-${QTMIN}:5[X]
+ )
+ >=dev-qt/qtprintsupport-${QTMIN}:5[cups]
+ >=dev-qt/qtwayland-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5[dbus]
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/kglobalaccel-${KFMIN}:5
+ >=kde-frameworks/kguiaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kirigami-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-frameworks/kwayland-${KFMIN}:5
+ >=kde-frameworks/plasma-${KFMIN}:5
+ x11-libs/libxkbcommon
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/plasma-wayland-protocols-1.7.0
+ >=dev-libs/wayland-protocols-1.25
+ >=dev-qt/qtconcurrent-${QTMIN}:5
+"
+RDEPEND="${COMMON_DEPEND}
+ kde-misc/kio-fuse:5
+ sys-apps/xdg-desktop-portal
+"
+BDEPEND="
+ >=dev-qt/qtwaylandscanner-${QTMIN}:5
+ virtual/pkgconfig
+"