summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-13 07:07:14 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-13 07:12:58 +0200
commit9eb8d0d650c5caeeaf9e5e35f874af7646d6dec3 (patch)
tree4cd4fd6fb2cc87f69f27db3f7773de084849a2fe
parentdev-python/scikit-build: Bump to 0.17.1 (diff)
downloadgentoo-9eb8d0d650c5caeeaf9e5e35f874af7646d6dec3.tar.gz
gentoo-9eb8d0d650c5caeeaf9e5e35f874af7646d6dec3.tar.bz2
gentoo-9eb8d0d650c5caeeaf9e5e35f874af7646d6dec3.zip
dev-python/pytest-httpx: Bump to 0.22.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pytest-httpx/Manifest1
-rw-r--r--dev-python/pytest-httpx/pytest-httpx-0.22.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pytest-httpx/Manifest b/dev-python/pytest-httpx/Manifest
index 2441665a36ed..0b6f79575709 100644
--- a/dev-python/pytest-httpx/Manifest
+++ b/dev-python/pytest-httpx/Manifest
@@ -1 +1,2 @@
DIST pytest-httpx-0.21.3.gh.tar.gz 24373 BLAKE2B 8efa85974128a0c9d78bbc23b7c9bca17e68ebb09dafd3b49e5a09df54bd2808ab6e7995ab407b78495ac12a80239d7397169c8de539ec559a8c7cf95239b495 SHA512 8c25a702b9c049354a0f0b232eefeae5ac0c47764af023c89aba6829309971a1d79a0dab3e4d6275a6bf0f32f3a8309c9559eb22c9b742a6576ecea37ff0d15d
+DIST pytest-httpx-0.22.0.gh.tar.gz 24409 BLAKE2B 9db6622e4997ddf0a70c1a0ef835b077640b3ce1d1c19792feda573577fac1ecfba16bcb7ecb8e4c1578b345764d8301aa121335a259dc91a4805173a549bea3 SHA512 fd89ce70113608195eb8fa8e3d7465d9d15b5a300e7c00f3c50417ba9b205081671fbda9591bdb16accb1973da00f5d0bede9e73a3351b0652080d4059c5f6d6
diff --git a/dev-python/pytest-httpx/pytest-httpx-0.22.0.ebuild b/dev-python/pytest-httpx/pytest-httpx-0.22.0.ebuild
new file mode 100644
index 000000000000..aa42666a0557
--- /dev/null
+++ b/dev-python/pytest-httpx/pytest-httpx-0.22.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/_}"
+DESCRIPTION="Send responses to HTTPX using pytest"
+HOMEPAGE="
+ https://colin-b.github.io/pytest_httpx/
+ https://github.com/Colin-b/pytest_httpx/
+ https://pypi.org/project/pytest-httpx/
+"
+# no tests in sdist as of 0.22.0
+# https://github.com/Colin-b/pytest_httpx/pull/95
+SRC_URI="
+ https://github.com/Colin-b/pytest_httpx/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ =dev-python/httpx-0.24*[${PYTHON_USEDEP}]
+ <dev-python/pytest-8[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest