summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-29 23:30:24 +0100
committerSam James <sam@gentoo.org>2021-10-29 23:43:35 +0100
commit9eba4c8d45a806d2e757c67b832e991608143029 (patch)
tree837d25ad20dc3ab1e2fb20a6be948f88818dfeca
parentgames-action/supertuxkart: Drop old 1.1 (diff)
downloadgentoo-9eba4c8d45a806d2e757c67b832e991608143029.tar.gz
gentoo-9eba4c8d45a806d2e757c67b832e991608143029.tar.bz2
gentoo-9eba4c8d45a806d2e757c67b832e991608143029.zip
sys-apps/hwloc: add 2.6.0
We drop netloc support as it's about to be removed upstream. Bug: https://github.com/open-mpi/hwloc/issues/478 Closes: https://bugs.gentoo.org/796797 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-apps/hwloc/Manifest1
-rw-r--r--sys-apps/hwloc/hwloc-2.6.0.ebuild104
2 files changed, 105 insertions, 0 deletions
diff --git a/sys-apps/hwloc/Manifest b/sys-apps/hwloc/Manifest
index 3f39e4ffc938..014c8ec08907 100644
--- a/sys-apps/hwloc/Manifest
+++ b/sys-apps/hwloc/Manifest
@@ -1,3 +1,4 @@
DIST hwloc-1.11.13.tar.bz2 4120436 BLAKE2B a6a09f7d6abeaa9d23df555cfd2186ae61f0f67f83fa8f1aa4bc29376b233a8511f11745f35064f39545c7e62e9d271c1334b6906712028729e138e41d1f212f SHA512 dd38bcc9a5df2dcfd3bbd828ab13fdb1c1d21747a0b62e6c87df95d2835c0472590344ff5bda4f6c28e597eaba1ea11c0bc96907ad45f1215f51f95ac9f58138
DIST hwloc-2.3.0.tar.bz2 6414781 BLAKE2B 60bc80ae73d0ae9ff9a438474efe682dfff28149b843645c928d4c5531f25c7763311816d5c86028efa9e07aa86935dbb6cff56ec429ee607ce4e5b5b88d4bbe SHA512 ecb0950cd08eab7d97f7cbef9db0dc31cb5b4debedaae6f48814625ee5da0153fdc1f863fa84c5d59b76634e877a348fa556f3c8c29fc43bc6ae7211c313906c
DIST hwloc-2.5.0.tar.bz2 6688349 BLAKE2B 684367afa5fc056b9bf04b3a95bd8239ec70127d5e582948ca16a09323614ad0ef77278a120544af0a740b456f1ba24bffc861b9f132293fafb7da0597d0b688 SHA512 9e8b829868cb9f5fd2fe84d8515d0dc8725ddc84c788a61c1e9e918eb2b29659eb73cf22a4189e6b887f5bfa3255c206f4ba924bd7fe2c88c185f4308c0949cd
+DIST hwloc-2.6.0.tar.bz2 6728585 BLAKE2B 96099ae3527e11a83adc068e07756752d2effa38b4bae174045e5142a3457af8790e9fd3d778ff2d91708101aaf6e108affed7688918195e0f2bdbd55235ad46 SHA512 3f35ee685507469e2c7d4a2ab4c339eff24123b4bc21d96bc53fd2737a36bdd371f1e1e4440b410ecac6cf1881562187243bfbf846203cb3702a4c4c7be0d5df
diff --git a/sys-apps/hwloc/hwloc-2.6.0.ebuild b/sys-apps/hwloc/hwloc-2.6.0.ebuild
new file mode 100644
index 000000000000..e9b6ea7e9d16
--- /dev/null
+++ b/sys-apps/hwloc/hwloc-2.6.0.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit autotools bash-completion-r1 cuda flag-o-matic systemd toolchain-funcs multilib-minimal
+
+MY_PV="v$(ver_cut 1-2)"
+
+DESCRIPTION="displays the hardware topology in convenient formats"
+HOMEPAGE="https://www.open-mpi.org/projects/hwloc/"
+SRC_URI="https://www.open-mpi.org/software/${PN}/${MY_PV}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0/15"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="cairo +cpuid cuda debug gl nvml +pci static-libs svg udev xml X"
+
+# opencl support dropped with x11-drivers/ati-drivers being removed (bug #582406).
+# Anyone with hardware is welcome to step up and help test to get it re-added.
+RDEPEND=">=sys-libs/ncurses-5.9-r3:0[${MULTILIB_USEDEP}]
+
+ cairo? ( >=x11-libs/cairo-1.12.14-r4[X?,svg?,${MULTILIB_USEDEP}] )
+ cuda? ( >=dev-util/nvidia-cuda-toolkit-6.5.19-r1:= )
+ gl? ( x11-drivers/nvidia-drivers[static-libs,tools] )
+ nvml? ( x11-drivers/nvidia-drivers[${MULTILIB_USEDEP}] )
+ pci? (
+ >=sys-apps/pciutils-3.3.0-r2[${MULTILIB_USEDEP}]
+ >=x11-libs/libpciaccess-0.13.1-r1[${MULTILIB_USEDEP}]
+ )
+ udev? ( virtual/libudev )
+ xml? ( >=dev-libs/libxml2-2.9.1-r4[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}"
+# 2.69-r5 for --runstatedir
+BDEPEND="
+ >=sys-devel/autoconf-2.69-r5
+ virtual/pkgconfig
+"
+
+PATCHES=( "${FILESDIR}/${PN}-1.8.1-gl.patch" )
+
+DOCS=( AUTHORS NEWS README VERSION )
+
+src_prepare() {
+ default
+
+ eautoreconf
+
+ if use cuda ; then
+ append-cflags "-I${ESYSROOT}/opt/cuda/include"
+ append-cppflags "-I${ESYSROOT}/opt/cuda/include"
+ fi
+}
+
+multilib_src_configure() {
+ # bug #393467
+ export HWLOC_PKG_CONFIG="$(tc-getPKG_CONFIG)"
+
+ if use cuda ; then
+ local -x LDFLAGS="${LDFLAGS}"
+ append-ldflags "-L${ESYSROOT}/opt/cuda/$(get_libdir)"
+ fi
+
+ local myconf=(
+ --disable-opencl
+ # netloc is deprecated upstream, about to be removed
+ # bug #796797
+ --disable-netloc
+ --disable-plugin-ltdl
+ --enable-plugins
+ --enable-shared
+ --runstatedir="${EPREFIX}/run"
+ $(multilib_native_use_enable cuda)
+ $(multilib_native_use_enable gl)
+ $(use_enable cairo)
+ $(use_enable cpuid)
+ $(use_enable debug)
+ $(use_enable udev libudev)
+ $(use_enable nvml)
+ $(use_enable pci)
+ $(use_enable static-libs static)
+ $(use_enable xml libxml2)
+ $(use_with X x)
+ )
+
+ ECONF_SOURCE="${S}" econf "${myconf[@]}"
+}
+
+multilib_src_install_all() {
+ default
+
+ case ${ARCH} in
+ # hwloc-dump-hwdata binary only built on those arches, so don't install non-working unit.
+ amd64|x86)
+ systemd_dounit "${ED}/usr/share/hwloc/hwloc-dump-hwdata.service" ;;
+ esac
+
+ mv "${ED}"/usr/share/bash-completion/completions/hwloc{,-annotate} || die
+ bashcomp_alias hwloc-annotate \
+ hwloc-{diff,ps,compress-dir,gather-cpuid,distrib,info,bind,patch,calc,ls,gather-topology}
+ bashcomp_alias hwloc-annotate lstopo{,-no-graphics}
+
+ find "${ED}" -name '*.la' -delete || die
+}