summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYongxiang Liang <tanekliang@gmail.com>2024-01-18 06:53:04 +0800
committerWANG Xuerui <xen0n@gentoo.org>2024-01-18 23:09:33 +0800
commit9ed7b0d958425336fb3038f67a3fd3e43f684f02 (patch)
tree9c9cab38bae4bf774fee3995bed42f1d1b36674c
parentMove {dev-util → dev-debug}/peda (diff)
downloadgentoo-9ed7b0d958425336fb3038f67a3fd3e43f684f02.tar.gz
gentoo-9ed7b0d958425336fb3038f67a3fd3e43f684f02.tar.bz2
gentoo-9ed7b0d958425336fb3038f67a3fd3e43f684f02.zip
app-i18n/fcitx: add 5.1.7
Signed-off-by: Yongxiang Liang <tanekliang@gmail.com> Signed-off-by: WANG Xuerui <xen0n@gentoo.org>
-rw-r--r--app-i18n/fcitx/Manifest1
-rw-r--r--app-i18n/fcitx/fcitx-5.1.7.ebuild123
2 files changed, 124 insertions, 0 deletions
diff --git a/app-i18n/fcitx/Manifest b/app-i18n/fcitx/Manifest
index 7a5d7b726a37..066d709e0cfb 100644
--- a/app-i18n/fcitx/Manifest
+++ b/app-i18n/fcitx/Manifest
@@ -1,5 +1,6 @@
DIST fcitx-4.2.9.8_dict.tar.xz 8737888 BLAKE2B 2de3ccbf1b37a9bcf1a3cb257d7837669e946765722c3d6f442ad071d7d81a6e8178e47051fc3aa53b9b4771d3aca602c2e22fa7a3d117a9e1f2779497e02c52 SHA512 50a954c3178f53fd2d441cdaf81fb44a7fe8dfb263fa6d8dd4ee4884fc7ae8321880c726c9366d11e2a4ac8da2233268d06e5d0800d4527ba0bdb1a1430248ed
DIST fcitx-5.1.6.tar.xz 7493752 BLAKE2B b34d4cbe495b3d85090755e6291125a393e9b259cc35ac3eb60550d32160bf315ff2db2e9904b65b365a375f35d922b031f2428f106e196c2a91106c7d0965d2 SHA512 8f10dfb230d4b4c7e559eb77e7a56c17964e404dc12bd3319f7dc715159a289faa1df95a342a0a1723e7d645aba808b967fd10d04ac065de2c49843a7905e7cb
+DIST fcitx-5.1.7.tar.xz 7497708 BLAKE2B 3063148573a5fc7d564784bf4ed82ddabb8c1763c9c41e232b8aff442f15df21586abda37e3908abd3da2c90ffd21746add8664d98ed78cf14620edff8f45105 SHA512 0bc11065e0c3357471c51bdfa6f752e089a6d361349002e62f4ac952c8a0f1790a27aba195d027b340103eb4a6eef0efec124b8931ac2285e8b1b69ca3487269
DIST fcitx-data-en_dict-20121020.tar.gz 630491 BLAKE2B 2df897b1c9fb3a2ce186ee590e5f3ccbc7930f047218bf0fefa317f74b3287fc0be9c393d3310fe07208379118ec4c46608a1c703ef37b3aee65b2d790cb7f0d SHA512 8418bd02492bfd786c0fab93be4400ef027ec8e9fac02220cc1f653f5eb67f54573a6a84a15baba19bb34ab892745c87df16499d6304ea75009131e2ab3b97f2
DIST fcitx-data-pinyin.tar.gz 1608886 BLAKE2B 3b7e72559bb838b4f2245e6faf2d627df17e9383ef8fe382e10333c1a95d79409ec042caa7d77c9bcd956b1c5d5456dab9d82208cd89d90e2be759c76f56f3d1 SHA512 1ee19eed3ee58be6cd6562ec363fe3bf630fff5e8820b3bfdd6d4618fceb082695e888dec5366a3685d58706f720e19319d891c223227237aed12674ea982131
DIST fcitx-data-py_stroke-20121124.tar.gz 445601 BLAKE2B 43b29b30da11b18196918e4df847406871eff75595b62608ad86b0ef6de83ec5e1b722645cabb809281075b393b5970e4d9580594caa73060c866c2d3cd988e7 SHA512 d80ff9a3549e07c7a6935e686785f9a076c58f1a782a832ae28ee65e2a213d67f089f450ce09bed87ec2a141c32b9c1fcb83c221ddcab436858fa9009f161fb3
diff --git a/app-i18n/fcitx/fcitx-5.1.7.ebuild b/app-i18n/fcitx/fcitx-5.1.7.ebuild
new file mode 100644
index 000000000000..3e0b4a144558
--- /dev/null
+++ b/app-i18n/fcitx/fcitx-5.1.7.ebuild
@@ -0,0 +1,123 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="fcitx5"
+
+inherit cmake xdg
+
+DESCRIPTION="Fcitx 5 is a generic input method framework"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx5"
+SRC_URI="https://download.fcitx-im.org/fcitx5/fcitx5/fcitx5-${PV}_dict.tar.xz -> ${P}.tar.xz"
+
+LICENSE="LGPL-2+ Unicode-DFS-2016"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~loong ~riscv ~x86"
+IUSE="+autostart doc +emoji +enchant +keyboard presage +server systemd test wayland +X"
+REQUIRED_USE="
+ || ( wayland X )
+ X? ( keyboard )
+ wayland? ( keyboard )
+"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ !app-i18n/fcitx:4
+ dev-libs/libfmt
+ sys-devel/gettext
+ virtual/libintl
+ x11-libs/cairo[X?]
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango[X?]
+ doc? (
+ app-text/doxygen
+ dev-texlive/texlive-fontutils
+ )
+ emoji? ( sys-libs/zlib )
+ enchant? ( app-text/enchant:2 )
+ keyboard? (
+ app-text/iso-codes
+ dev-libs/expat
+ dev-libs/json-c:=
+ x11-misc/xkeyboard-config
+ x11-libs/libxkbcommon[X?,wayland?]
+ )
+ systemd? (
+ sys-apps/systemd
+ )
+ !systemd? (
+ dev-libs/libuv
+ sys-apps/dbus
+ )
+ wayland? (
+ dev-libs/glib:2
+ dev-libs/wayland
+ dev-libs/wayland-protocols
+ dev-util/wayland-scanner
+ )
+ X? (
+ dev-libs/glib:2
+ >=x11-libs/xcb-imdkit-1.0.3:5
+ x11-libs/libX11
+ x11-libs/libxkbfile
+ x11-libs/xcb-util
+ x11-libs/xcb-util-keysyms
+ x11-libs/xcb-util-wm
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ kde-frameworks/extra-cmake-modules:0
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_DBUS=on
+ -DENABLE_XDGAUTOSTART=$(usex autostart)
+ -DENABLE_SERVER=$(usex server)
+ -DENABLE_KEYBOARD=$(usex keyboard)
+ -DENABLE_TEST=$(usex test)
+ -DENABLE_ENCHANT=$(usex enchant)
+ -DENABLE_EMOJI=$(usex emoji)
+ -DENABLE_PRESAGE=$(usex presage)
+ -DENABLE_WAYLAND=$(usex wayland)
+ -DENABLE_X11=$(usex X)
+ -DENABLE_DOC=$(usex doc)
+ -DUSE_SYSTEMD=$(usex systemd)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ use doc && cmake_src_compile doc
+}
+
+src_install() {
+ cmake_src_install
+ use doc && dodoc -r "${BUILD_DIR}"/doc/*
+}
+
+src_test() {
+ # break by sandbox
+ local CMAKE_SKIP_TESTS=(
+ testdbus
+ testservicewatcher
+ )
+ cmake_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ elog
+ elog "Follow the instrcutions on:"
+ elog "https://wiki.gentoo.org/wiki/Fcitx#Using_Fcitx"
+ elog "https://fcitx-im.org/wiki/Setup_Fcitx_5"
+ elog "https://fcitx-im.org/wiki/Using_Fcitx_5_on_Wayland"
+ elog
+}