summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-07 13:59:20 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-07 14:19:58 +0200
commit9ed810f6b4f16bfcacf89d4dce3902291c4704be (patch)
treebc597ce388f582efef5c10f1730d75bbba520a94
parentdev-python/nuitka: Bump to 0.6.15.3 (diff)
downloadgentoo-9ed810f6b4f16bfcacf89d4dce3902291c4704be.tar.gz
gentoo-9ed810f6b4f16bfcacf89d4dce3902291c4704be.tar.bz2
gentoo-9ed810f6b4f16bfcacf89d4dce3902291c4704be.zip
dev-python/mongomock: Bump to 3.23.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/mongomock/Manifest1
-rw-r--r--dev-python/mongomock/mongomock-3.23.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/mongomock/Manifest b/dev-python/mongomock/Manifest
index 87ef267e3627..f6c5f5fb9068 100644
--- a/dev-python/mongomock/Manifest
+++ b/dev-python/mongomock/Manifest
@@ -1 +1,2 @@
DIST mongomock-3.22.1.tar.gz 121742 BLAKE2B b325fd917f27712d1fdd35564dd27e02a69a417b40c975b447d1d553a170fb45978303b47878e094c6360930b0293f7353552522b54c9228f8083ea88e672510 SHA512 efd8e46986076fb1b6aa2d68d17b136191bcb90408da305a860a99a86ce06c8377ea5f684902761ceb38b5e914b75f7307e9a73477a3297b502241d7517fc143
+DIST mongomock-3.23.0.tar.gz 123705 BLAKE2B d58f867628c8c80e1289c1a86fa910585431b5eca41818201dccd54d5adccb55c35aea41566ab2d483c7040cfcaa4c2afdbaad39fdd901497a0e1db4effd1c11 SHA512 35442f29907bb58693059a33f5941ca557965fe2b0b9b68ab3e4b31f5e2326bb41db8716a089dd18a1a1fdd5523a729b48a85e0caa0daca1bad2790c2ac017a9
diff --git a/dev-python/mongomock/mongomock-3.23.0.ebuild b/dev-python/mongomock/mongomock-3.23.0.ebuild
new file mode 100644
index 000000000000..c7b70822284d
--- /dev/null
+++ b/dev-python/mongomock/mongomock-3.23.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library to help testing Python code that interacts with MongoDB via Pymongo"
+HOMEPAGE="https://github.com/mongomock/mongomock https://pypi.org/project/mongomock/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND=">=dev-python/pbr-5.1.1[${PYTHON_USEDEP}]"
+
+RDEPEND="
+ >=dev-python/pymongo-3.10.1[${PYTHON_USEDEP}]
+ >=dev-python/sentinels-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.14.0[${PYTHON_USEDEP}]"
+
+src_test() {
+ # Use NO_LOCAL_MONGO to disable tests that need a MongoDB instance.
+ # TZ=UTC needed for date/time tests to pass
+ TZ=UTC NO_LOCAL_MONGO=1 distutils-r1_src_test
+}
+
+distutils_enable_tests pytest