summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 14:32:41 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 14:33:53 +0100
commit9ee6aadee80f5198a98f29172e673cf6a050c215 (patch)
tree575e4dc7f7d03910ed2311ebe63911d0c83469b7
parentnet-wireless/linssid: drop 3.6-r1 (diff)
downloadgentoo-9ee6aadee80f5198a98f29172e673cf6a050c215.tar.gz
gentoo-9ee6aadee80f5198a98f29172e673cf6a050c215.tar.bz2
gentoo-9ee6aadee80f5198a98f29172e673cf6a050c215.zip
dev-lua/md5: update EAPI 7 -> 8
Also fixed compilation with clang+lld Closes: https://bugs.gentoo.org/829682 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--dev-lua/md5/md5-1.3-r1.ebuild85
1 files changed, 85 insertions, 0 deletions
diff --git a/dev-lua/md5/md5-1.3-r1.ebuild b/dev-lua/md5/md5-1.3-r1.ebuild
new file mode 100644
index 000000000000..436e64e6656a
--- /dev/null
+++ b/dev-lua/md5/md5-1.3-r1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit lua
+
+DESCRIPTION="Offers basic cryptographic facilities for Lua"
+HOMEPAGE="https://github.com/keplerproject/md5"
+SRC_URI="https://github.com/keplerproject/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+RDEPEND="${LUA_DEPS}"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ lua_copy_sources
+}
+
+src_configure() {
+ # Provided 'configure' script is useless.
+ :;
+}
+
+lua_src_compile() {
+ pushd "${BUILD_DIR}" || die
+
+ local myemakeargs=(
+ "CC=$(tc-getCC)"
+ "CFLAGS=${CFLAGS} -fPIC $(lua_get_CFLAGS) ${LDFLAGS}"
+ )
+
+ emake "${myemakeargs[@]}"
+
+ popd
+}
+
+src_compile() {
+ lua_foreach_impl lua_src_compile
+}
+
+lua_src_test() {
+ pushd "${BUILD_DIR}/src" || die
+
+ # Workaround for tests.
+ ln -s core.so md5.so || die
+
+ "${ELUA}" ../tests/test.lua
+
+ popd
+}
+
+src_test() {
+ lua_foreach_impl lua_src_test
+}
+
+lua_src_install() {
+ pushd "${BUILD_DIR}" || die
+
+ # Workaround, as 'Makefile' does not create this directory.
+ dodir "$(lua_get_cmod_dir)"
+
+ local myemakeargs=(
+ "LUA_DIR=${ED}/$(lua_get_lmod_dir)"
+ "LUA_LIBDIR=${ED}/$(lua_get_cmod_dir)"
+ )
+
+ emake "${myemakeargs[@]}" install
+
+ popd
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+
+ einstalldocs
+}