summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-03-21 14:04:02 -0400
committerMatt Turner <mattst88@gentoo.org>2024-03-21 14:04:02 -0400
commit9f11e924ea5fc1aba7908adbb47e0cfd1b9c7932 (patch)
tree985c9c78b6a21fb03991903a6bcd35f9a8913fc7
parentdev-cpp/rapidfuzz-cpp: Stabilize 3.0.2 arm64, #927414 (diff)
downloadgentoo-9f11e924ea5fc1aba7908adbb47e0cfd1b9c7932.tar.gz
gentoo-9f11e924ea5fc1aba7908adbb47e0cfd1b9c7932.tar.bz2
gentoo-9f11e924ea5fc1aba7908adbb47e0cfd1b9c7932.zip
dev-libs/libinput: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--dev-libs/libinput/Manifest1
-rw-r--r--dev-libs/libinput/libinput-1.24.0.ebuild100
2 files changed, 0 insertions, 101 deletions
diff --git a/dev-libs/libinput/Manifest b/dev-libs/libinput/Manifest
index c3abe6b7d599..93761637c86b 100644
--- a/dev-libs/libinput/Manifest
+++ b/dev-libs/libinput/Manifest
@@ -1,2 +1 @@
-DIST libinput-1.24.0.tar.bz2 810034 BLAKE2B 41c9f5d47153ed5a885ec95a7e1032ea3783ced1dd94b89c688dee0c09dd849185acec8c16841257b05b8a7e3a7857acc74140745a8de1eb7c171b6fb1ca4eac SHA512 924554d62d232f99851db51386653e67083b8f3b8203b5d848294c08880e1ba153f80699900210d1b5b31566a2ef6bd4aa0662f107a2dcaed1fe0f7e1fb784db
DIST libinput-1.25.0.tar.bz2 812020 BLAKE2B 03034b6315c281d7eee6a7bc1f4c799c2c7f74add7a195501de75feb6b98fa8dc601b7573da5586b2b2882c3cfaddfad62f5c1b836402dce1f463bdb2884945d SHA512 b9dc3f3b5f34c82399dfb7ccb5f65d19a596c415f0198b39e3f360f5b87c42124a5355c8d9f6f42cc9ae2d4f9a90fe5da6260136fa83d278048392f93381a84b
diff --git a/dev-libs/libinput/libinput-1.24.0.ebuild b/dev-libs/libinput/libinput-1.24.0.ebuild
deleted file mode 100644
index e9161b1a48a1..000000000000
--- a/dev-libs/libinput/libinput-1.24.0.ebuild
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 2014-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..11} )
-inherit meson optfeature python-any-r1 udev
-
-DESCRIPTION="Library to handle input devices in Wayland"
-HOMEPAGE="https://www.freedesktop.org/wiki/Software/libinput/ https://gitlab.freedesktop.org/libinput/libinput"
-SRC_URI="https://gitlab.freedesktop.org/${PN}/${PN}/-/archive/${PV}/${P}.tar.bz2"
-
-LICENSE="MIT"
-SLOT="0/10"
-if [[ $(ver_cut 3) -lt 900 ]] ; then
- KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-fi
-IUSE="doc input_devices_wacom test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- input_devices_wacom? ( >=dev-libs/libwacom-0.27:= )
- >=dev-libs/libevdev-1.9.902
- >=sys-libs/mtdev-1.1
- virtual/libudev:=
- virtual/udev
-"
-DEPEND="
- ${RDEPEND}
- test? ( >=dev-libs/check-0.9.10 )
-"
-BDEPEND="
- virtual/pkgconfig
- doc? (
- $(python_gen_any_dep '
- dev-python/commonmark[${PYTHON_USEDEP}]
- dev-python/recommonmark[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- >=dev-python/sphinx-rtd-theme-0.2.4[${PYTHON_USEDEP}]
- ')
- >=app-text/doxygen-1.8.3
- >=media-gfx/graphviz-2.38.0
- )
- test? (
- $(python_gen_any_dep '
- dev-python/pytest[${PYTHON_USEDEP}]
- ')
- )
-"
-# test? ( dev-debug/valgrind )
-
-python_check_deps() {
- if use doc; then
- python_has_version \
- "dev-python/commonmark[${PYTHON_USEDEP}]" \
- "dev-python/recommonmark[${PYTHON_USEDEP}]" \
- "dev-python/sphinx[${PYTHON_USEDEP}]" \
- ">=dev-python/sphinx-rtd-theme-0.2.4[${PYTHON_USEDEP}]" \
- || return
- fi
- if use test; then
- python_has_version \
- "dev-python/pytest[${PYTHON_USEDEP}]" \
- || return
- fi
-}
-
-src_prepare() {
- default
- sed "s@, '-Werror'@@" -i meson.build || die #744250
-}
-
-src_configure() {
- # gui can be built but will not be installed
- local emesonargs=(
- -Ddebug-gui=false
- $(meson_use doc documentation)
- $(meson_use input_devices_wacom libwacom)
- $(meson_use test tests)
- -Dudev-dir="${EPREFIX}$(get_udevdir)"
- )
- meson_src_configure
-}
-
-src_install() {
- meson_src_install
- if use doc ; then
- docinto html
- dodoc -r "${BUILD_DIR}"/Documentation/.
- fi
-}
-
-pkg_postinst() {
- optfeature "measure and replay tools" dev-python/libevdev
- udev_reload
-}
-
-pkg_postrm() {
- udev_reload
-}