summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2021-10-27 21:45:23 +0900
committerAkinori Hattori <hattya@gentoo.org>2021-10-27 21:45:23 +0900
commit9f2252bd47ef9e0f122513e79279ac8135e983d8 (patch)
tree8e322a1d58afd7123310b158bcca11b7fad6c1ce
parentmedia-gfx/mkbold-mkitalic: initial import (diff)
downloadgentoo-9f2252bd.tar.gz
gentoo-9f2252bd.tar.bz2
gentoo-9f2252bd.zip
media-fonts/jisx0213-fonts: install bold and italic faces
Closes: https://bugs.gentoo.org/814770 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
-rw-r--r--media-fonts/jisx0213-fonts/jisx0213-fonts-20040425-r3.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/media-fonts/jisx0213-fonts/jisx0213-fonts-20040425-r3.ebuild b/media-fonts/jisx0213-fonts/jisx0213-fonts-20040425-r3.ebuild
new file mode 100644
index 000000000000..6f779b1d4f10
--- /dev/null
+++ b/media-fonts/jisx0213-fonts/jisx0213-fonts-20040425-r3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit font font-ebdftopcf
+
+DESCRIPTION="Japanese fixed fonts that cover JIS0213 charset"
+#HOMEPAGE="http://www12.ocn.ne.jp/~imamura/jisx0213.html"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="mirror://gentoo/jiskan16-2004-1.bdf.gz
+ mirror://gentoo/jiskan16-2000-1.bdf.gz
+ mirror://gentoo/jiskan16-2000-2.bdf.gz
+ mirror://gentoo/K14-2004-1.bdf.gz
+ mirror://gentoo/K14-2000-1.bdf.gz
+ mirror://gentoo/K14-2000-2.bdf.gz
+ mirror://gentoo/K12-1.bdf.gz
+ mirror://gentoo/K12-2.bdf.gz
+ mirror://gentoo/A14.bdf.gz
+ mirror://gentoo/A12.bdf.gz
+ mirror://gentoo/jiskan24-2000-1.bdf.gz
+ mirror://gentoo/jiskan24-2000-2.bdf.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="binchecks strip"
+
+BDEPEND="media-gfx/mkbold-mkitalic"
+S="${WORKDIR}"
+
+FONT_PN="${PN/-fonts/}"
+FONTDIR="/usr/share/fonts/${FONT_PN}"
+
+src_compile() {
+ einfo "Making bold and italic faces..."
+ for bdf in *.bdf; do
+ mkbold -r -L ${bdf} >${bdf%.bdf}b.bdf
+ mkitalic ${bdf} >${bdf%.bdf}i.bdf
+ mkbolditalic -r -L ${bdf} >${bdf%.bdf}bi.bdf
+ done
+ font-ebdftopcf_src_compile
+}
+
+pkg_postinst() {
+ font_pkg_postinst
+ if use X; then
+ elog "You need you add following line into 'Section \"Files\"' in"
+ elog "XF86Config and reboot X Window System, to use these fonts."
+ elog ""
+ elog "\t FontPath \"${FONTDIR}\""
+ elog ""
+ fi
+}